MozillaZine

Thunderbird Inserting Question Marks In Text

User Help for Mozilla Thunderbird
Peter P. Schifferli
 
Posts: 456
Joined: December 10th, 2004, 7:59 pm

Post Posted April 30th, 2019, 4:56 pm

Whenever I send a message using TB, it now inserts two question marks after the period in each sentence as: .?? Only visible in the recipient's copy. What can I do to eliminate this behavior? TIA

Pete Schifferli
Win 8.1, Fx 67.0, Tb 60.6.1

morat
 
Posts: 3164
Joined: February 3rd, 2009, 6:29 pm

Post Posted April 30th, 2019, 6:46 pm

Does the same thing occur if you launch the application in safe mode?

http://kb.mozillazine.org/Safe_mode

tanstaafl
Moderator

User avatar
 
Posts: 45244
Joined: July 30th, 2003, 5:06 pm

Post Posted April 30th, 2019, 11:38 pm

If the problem also occurs in safe mode, does configuring Thunderbird to use Unicode UFT-8 as the text encoding for outgoing mail in tools -> options -> display -> formatting -> advanced help? That can workaround many character encoding issues.

What email provider are you using?

In tools -> options -> advanced -> general press the config editor button and then type mail.strictly_mime in the search field. What does it say that setting is set to? Changing that from false to true has solved similar problems when sending accented characters with yahoo/ymail/aol/verizon SMTP servers. Those SMTP servers claim they support 8BITMIME but actually just support UTF-8.

https://bugzilla.mozilla.org/show_bug.cgi?id=1435903
viewtopic.php?f=39&t=3038519&start=30 (long thread last year about double spaces changed to question marks in messages sent using yahoo accounts)

Peter P. Schifferli
 
Posts: 456
Joined: December 10th, 2004, 7:59 pm

Post Posted May 1st, 2019, 8:00 am

Outgoing mail was already configured at UTF-8, problem persists. My eMail provider is AOL, thank you.

Pete
Win 8.1, Fx 67.0, Tb 60.6.1

makaiguy

User avatar
 
Posts: 16736
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted May 1st, 2019, 9:23 am

tanstaafl wrote:In tools -> options -> advanced -> general press the config editor button and then type mail.strictly_mime in the search field. What does it say that setting is set to? Changing that from false to true has solved similar problems when sending accented characters with yahoo/ymail/aol/verizon SMTP servers.


Did you try this?
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF Quantum 66.0.5 (64bit), TB 60.6.1 (32-bit) ║ Android 8.0/7.1.1: FF Mobile 66.0.4 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

act39
 
Posts: 5
Joined: April 27th, 2019, 1:47 pm

Post Posted May 1st, 2019, 10:39 am

This is an ongoing topic in another thread:
viewtopic.php?f=39&t=3049463
:D :D

Peter P. Schifferli
 
Posts: 456
Joined: December 10th, 2004, 7:59 pm

Post Posted May 1st, 2019, 5:03 pm

makaiguy wrote:
tanstaafl wrote:In tools -> options -> advanced -> general press the config editor button and then type mail.strictly_mime in the search field. What does it say that setting is set to? Changing that from false to true has solved similar problems when sending accented characters with yahoo/ymail/aol/verizon SMTP servers.

Did you try this?


That seems to have done the trick! Thanks a million.

Pete
Win 8.1, Fx 67.0, Tb 60.6.1

RobertBrown
 
Posts: 2
Joined: May 1st, 2019, 8:48 pm

Post Posted May 1st, 2019, 8:56 pm

Hi,
Could someone clarify for me the instructions for changing the setting? I am asking for my father. I don't use Thunderbird myself, so I can't poke around to see what happens.

Is this like typing at a c: prompt?
After typing mail.strictly_mime in the search field,
(a) how do you know whether it is true or false?
(b) how do you change it?
Thanks for the help.

tanstaafl
Moderator

User avatar
 
Posts: 45244
Joined: July 30th, 2003, 5:06 pm

Post Posted May 1st, 2019, 11:03 pm

Is this like typing at a c: prompt?

No. This is a scrollable window that lists all of the settings, which has a search field (that you can type in) at the top. The config editor uses four columns - preference name, status, type and value - to display the data. See https://support.mozilla.org/en-US/kb/config-editor

If you search for mail.strictly_mime it will probably list mail.strictly_mime , mail.strictly_mime.parm_folding and mail.strictly_mime_headers, each on their own line. The mail.strictly_mime line should have mail.strictly_mime , default, boolean and false in one horizontal line. If you select that line it should highlight it in blue. Double click on the "false" in the value column and that will toggle the settings value. There is no "save" or "okay" button, any changes you make are automatically kept.

If you're worried about mistakes, backup the prefs.js file in the profile beforehand. "help -> troubleshooting information -> open folder" will launch windows explorer at the profile directory. The profile directory is used to store all of your data (its deliberately not stored the the applications installation directory to avoid losing data when uninstallling or upgrading).

RobertBrown
 
Posts: 2
Joined: May 1st, 2019, 8:48 pm

Post Posted May 1st, 2019, 11:05 pm

Thank you!

whatsitsgalore
 
Posts: 25
Joined: August 9th, 2014, 12:37 pm

Post Posted May 4th, 2019, 12:28 pm

Woo! Worked for me. Awesome advice, thanks.

whatsitsgalore
 
Posts: 25
Joined: August 9th, 2014, 12:37 pm

Post Posted May 5th, 2019, 2:20 pm

Uh-oh, I spoke too soon. Once I shut down the laptop and rebooted the next day, my email doesn't work at all. Can't receive, can't send. It says there's a problem with my password, which hardly makes sense. But I tried re-entering the password, and got the same result. Now what do I do?

tanstaafl
Moderator

User avatar
 
Posts: 45244
Joined: July 30th, 2003, 5:06 pm

Post Posted May 5th, 2019, 4:06 pm

What is the full text of the error message? (if it mentions your email address replace that part of the text with something generic)

What email provider are you using?

If its Gmail go to https://www.google.com/settings/security/lesssecureapps and make certain that "Allow to let less secure apps access your Google account" is still enabled for Thunderbird.

whatsitsgalore
 
Posts: 25
Joined: August 9th, 2014, 12:37 pm

Post Posted May 5th, 2019, 6:50 pm

It says

Sending of password for user *******@********* did not succeed. Mail server pop.verizon.net responded: [SYS/TEMP] Server error - Please try again later.

Been 'trying again later' for hours and hours, and no go.

tanstaafl
Moderator

User avatar
 
Posts: 45244
Joined: July 30th, 2003, 5:06 pm

Post Posted May 5th, 2019, 7:55 pm

[SYS/TEMP] Server error means its Verizon's fault, there is a temporary problem with their server. Typically it might take a day or two for them to fix it. Webmail frequently works in the interim (since it doesn't rely upon the POP/IMAP and SMTP servers, it uses shared libraries instead) but any email client (not just Thunderbird) will fail.

However, my impression is that you should have migrated to either AOL or Yahoo mail. Verizon basically got out of the mail business and migrated all of their users to AOL or Yahoo mail servers.

See https://www.verizon.com/support/residential/email and https://www.verizonwireless.com/support ... ase-17067/

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 3 guests