MozillaZine

TB on PC and Android gmailapp drafts synchronisation problem

User Help for Mozilla Thunderbird
ishigaki
 
Posts: 24
Joined: November 21st, 2004, 12:54 pm

Post Posted May 7th, 2019, 12:07 am

Hi,

Since a few weeks I noticed a weird behaviour between the two mentioned in the title of the post.

When I start writing a message on the PC with Thunderbird, it saves only one copy of the message into the "Drafts" folder. This is the expected behaviour.

However, when I then check my Android phone, after having sent the email, there are, depending on the length of the message and the time spent writing it, many versions of the draft that show up in the conversation.

On PC everything is fine, once the message is sent, the draft version is removed from the "drafts" folder, however, when I go to the gmail app on Android phone, I find sometimes between 2 and 10 drafts in the conversation view, which is quite annoying and makes it difficult to follow the conversation.

Any help will be much appreciated. I have searched the forums, but the only post I found with Android gmail app and desktop Thunderbird is this one viewtopic.php?f=39&t=2252015&p=11021507&hilit=drafts+android+thunderbird#p11021507 which is not related to the issue I'm experiencing.

Thanks!

ishigaki

tanstaafl
Moderator

User avatar
 
Posts: 45248
Joined: July 30th, 2003, 5:06 pm

Post Posted May 7th, 2019, 6:37 am

See http://kb.mozillazine.org/Deleting_mess ... P_accounts

It might be due to what "when I delete a message" is set to in your Thunderbird accounts server settings. You'd prefer to have similar behavior in both email clients. If you can't change the behavior in the android mail app I suggest you change it in Thunderbird.

"When I start writing a message on the PC with Thunderbird, it saves only one copy of the message into the "Drafts" folder. This is the expected behaviour."

What happens depends upon whether you have autosave in tools -> options -> compose -> general enabled, and what you are configured to do with deleted messages. You might see only one copy, but there might be more, deleted messages. Thunderbird might not show them while the android mail app does. Its messy :)

Try disabling autosave and see if that helps (after you get rid of all the old extra copies of the drafts).

ishigaki
 
Posts: 24
Joined: November 21st, 2004, 12:54 pm

Post Posted May 7th, 2019, 8:24 am

I disabled the autosave function in thunderbird and will see if it helps. However, if I do that, it means that none of the messages I'm composing will be saved, that's not a 100% solution to my problem as if something crashes while I'm composing the message all I wrote will be lost.Thanks for the hint.

sfhowes
 
Posts: 374
Joined: April 1st, 2012, 10:21 am

Post Posted May 7th, 2019, 10:09 am

Do you really need the drafts saved to the IMAP server? If you change the location to Drafts on Local Folders, you won't have multiple (any) copies appearing on the Android device, but still have the benefits of autosave and the option to save messages for further editing.

ishigaki
 
Posts: 24
Joined: November 21st, 2004, 12:54 pm

Post Posted May 8th, 2019, 1:08 am

sfhowes wrote:Do you really need the drafts saved to the IMAP server? If you change the location to Drafts on Local Folders, you won't have multiple (any) copies appearing on the Android device, but still have the benefits of autosave and the option to save messages for further editing.


I definitely don't need that, it messes up the whole conversation view on the Android device. Could you please explain how to change the location of Drafts to Local folders? Also, though I've been using TB for years, I noticed this behaviour since only a couple weeks ago.

tanstaafl
Moderator

User avatar
 
Posts: 45248
Joined: July 30th, 2003, 5:06 pm

Post Posted May 8th, 2019, 4:08 am

In tools -> account settings -> account_name -> copies & folders -> "keep draft messages in" -> Drafts folder on" choose "Local Folders". You can do that for all of your one accounts if you want, the drafts folder does not have to be unique or in the account.

I'm assuming you have the menu bar enabled. If not, press the ALT key to temporarily enable it, so you can avoid using the hamburger button.

ishigaki
 
Posts: 24
Joined: November 21st, 2004, 12:54 pm

Post Posted May 10th, 2019, 3:03 am

Thanks for the reply. I created folders for the accounts, hope this will work and I'll get rid of drafts in my conversation view.

I wanted to underline just one more thing: this seems to be gmail only issue as with other mailboxes I don't have that problem. What do you think?

tanstaafl
Moderator

User avatar
 
Posts: 45248
Joined: July 30th, 2003, 5:06 pm

Post Posted May 10th, 2019, 3:35 am

Its possible you're just running into a mismatch between how your two email clients handle deleted messages, but since I suspect you typically have no control over that on Android email apps and it only occurs for Gmail, I suggest you browse the settings in the pop & imap tab in gmail webmail settings to see if something is over-ruling what Thunderbird does.

Return to Thunderbird Support


Who is online

Users browsing this forum: DanRaisch and 5 guests