MozillaZine

Taming random fonts

User Help for Mozilla Thunderbird
mozurkewich
 
Posts: 228
Joined: April 7th, 2008, 9:58 am

Post Posted May 22nd, 2019, 1:58 pm

My fonts in Thunderbird are too small, except when they are too large. They were tolerable, but now are not; I suppose as a result of the last update. I have Theme and Font Size Changer and there is some font stuff in Preferences. But no documentation for either. The way they work is ... opaque, with odd interactions.

Is there a way to fix this? Is there information on what changes which font? It seems there are different fonts for the folders list, the folder entries, messages being read, messages being quoted, things inserted in quoted messages (on // ...p.m.. *** wrote), text being composed. How do I change those? I just don't feel like spending another half hour trying stuff at random, only to settled on sort of acceptable until the next time it stops working.

Addition: Or is there a better add-on?

Please help.

DanRaisch
Moderator

User avatar
 
Posts: 123687
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 22nd, 2019, 4:55 pm


mozurkewich
 
Posts: 228
Joined: April 7th, 2008, 9:58 am

Post Posted May 22nd, 2019, 5:14 pm

I'll bookmark that for if I get desperate enough.

It would help to know what "zoom" does in Theme and Font Size Changer. Ditto for "size". Also "font size" under preferences/display.

I should add: Those things appear to interact in unpredictable ways.

kerft
 
Posts: 585
Joined: January 30th, 2019, 9:38 am

Post Posted May 22nd, 2019, 6:09 pm

These might be of some help, perhaps mainly in showing that you are not the only one:
viewtopic.php?f=39&t=3047875
viewtopic.php?f=39&t=3043492

mozurkewich
 
Posts: 228
Joined: April 7th, 2008, 9:58 am

Post Posted May 22nd, 2019, 7:00 pm

Yeah. Theme and Font Size Changer is bug-ridden junk. Without it, Thunderbird is unusable.

As near as I can tell, "zoom" is relative to some constantly changing value. What idiot made that decision? Sometimes, increasing the zoom increases the font sizes, sometimes it decreases the font size. Totally random so far as I can tell.

For composing, I seem to have better results now that I have noticed that preferences/display/font size is a cruel joke, designed solely to make life hard on the user. One must go to advanced and change each of the three font sizes there to be the same.

Now I seem to have about 6 pt font for incoming messages. Is there is nothing I can do about That?

Addition: Part of the problem seems to be that preferences sent on the senders system has an effect on what I see on my system. Surely, that can't be right? How do I overrule that?

p.p.s. - I have *not* checked "allow messages to use other fonts". I have checked "use fixed width fonts ..."

kerft
 
Posts: 585
Joined: January 30th, 2019, 9:38 am

Post Posted May 23rd, 2019, 4:40 am

What I linked does point out that whatever settings you set for "latin" you also need to switch to dropdown to "other languages" and set everything the same there. You may want to repeat the process even for "unicode"
The 3rd knowledge base article that has more is: http://kb.mozillazine.org/Bad_Eyesight_-_Thunderbird
along with the 2 already mentioned.

mozurkewich
 
Posts: 228
Joined: April 7th, 2008, 9:58 am

Post Posted May 23rd, 2019, 5:33 am

kerft wrote:What I linked does point out that whatever settings you set for "latin" you also need to switch to dropdown to "other languages" and set everything the same there. You may want to repeat the process even for "unicode"
The 3rd knowledge base article that has more is: http://kb.mozillazine.org/Bad_Eyesight_-_Thunderbird
along with the 2 already mentioned.


Thanks. Wait ... "the other 2"? Oh, there *were* two. I missed the first, which looks helpful.

mozurkewich
 
Posts: 228
Joined: April 7th, 2008, 9:58 am

Post Posted May 23rd, 2019, 6:51 am

OK, those articles did not help except that I can now be more specific as to the major problem.

In: http://kb.mozillazine.org/Font_settings ... erminology
it says: "Overly small text will be enlarged to your minimum font size so that you can read it more easily."

That is simply not true for me. The minimum font size is unaffected by that. Wait a minute; that only applies to HTML? In my mind, email is *always* plain text; maybe that is part of my problem.

Question: When I get a notification from forums@mozillazine.org, is that plain text or HTML? Those notifications are default unreadable on my computer.

mozurkewich
 
Posts: 228
Joined: April 7th, 2008, 9:58 am

Post Posted May 24th, 2019, 10:25 am

kerft wrote:you also need to switch to dropdown to "other languages" and set everything the same there.


I managed to overlook that bit. It is "other writing systems" on my system, but it seems to have worked! Thanks. :D

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 8 guests