MozillaZine

default browser problem

User Help for Mozilla Thunderbird
tanstaafl
Moderator

User avatar
 
Posts: 45402
Joined: July 30th, 2003, 5:06 pm

Post Posted June 8th, 2019, 10:34 am

I powered my PC up (it was shutdown and the power also turned off at the power strip for both it and the router/modem.) after being out of town a few days and Thunderbird 60.7.0 complains

"http://forums.mozillazine.org/viewtopic.php?f=39&t=3048998&p=14834796&e=14834796

This file does not have an app associated with for performing this action.Please install an app, or if one is already installed create an association in the default apps settings page."

When I try to click on a http link in a message.

1. I went to set Vivaldi as the default browser again using the Windows 10 settings app but it claims its already set. Ditto for "chose default apps by protocol" and "set defaults by app" for http and https. Still fails.
2. I upgraded Vivaldi, checked its configured to set itself as the default browser, exited it, restarted it. Still fails.
3. Per http://kb.mozillazine.org/Changing_the_ ... hunderbird I set network.protocol-handler.warn-external.http and network.protocol-handler.warn-external.https true and tried again. I got the popup window to choose the browser, and chose Vivaldi, also telling it to remember that choice. Still fails.
4. I ran the "em client" email client and clicked on the same link. It displayed a prompt asking me to chose a browser. I chose Vivaldi. It worked. Still fails with Thunderbird.
5. I tried a different message in em client. It failed, prompting me for the browser. That worked. However, when I switch to a third message, the problem re-occurs (despite my having chosen a browser and checked the checkbox to remember that choice).
6. I tried clicking on a https link in a different message in Thunderbird. That displayed the prompt asking me to chose a browser. I chose Vivaldi and checked "remember my choice for https links". It failed.
7. I tried #6 again, this time choosing Firefox. It worked. I tried again for the http link. It failed. I tried a different message with a https link. It worked. I ran the settings app and it still shows Vivaldi as the default browser app. I went to set defaults by app for Firefox, clicked manage and see that it claims Vivaldi is the default for everything (http, https, .html etc.)
8. tools -> options -> attachments -> incoming now shows "Use Vivaldi (default)" for http and "Use Firefox" for https.
9 I exited Thunderbird, deleted mimetypes.rdf and restarted Thunderbird. Still fails for http, still uses Firefox for https. Same http and https settings in tools -> options -> attachments -> incoming
10. I set the options to always ask for http. That brrought up the window to let me chose Vivaldi again. Still fails.
11. Tried again for the http link, this time choosing Microsoft Edge. It does nothing. The incoming setting for http shows the Microsoft logo and "Use Microsoft Edge"
12. I set the https link in tools -> options for Microsoft Edge. It silently fails.
13. I set http and https in tools -> options for Firefox, all links work okay with Firefox.

Thoughts?

tanstaafl
Moderator

User avatar
 
Posts: 45402
Joined: July 30th, 2003, 5:06 pm

Post Posted June 8th, 2019, 11:22 am

I worked around the problem by explicitly setting it to "C:\Users\Eric\AppData\Local\Vivaldi\Application\vivaldi.exe" rather than using the "Use Vivaldi (default)" setting. I wondered if the path for Vivaldi in the systems settings was corrupt but double clicking on a .html file displays it in Vivaldi. It also doesn't explain why em client could successfully use "Use Vivaldi (default)" but wouldn't remember it, and why I couldn't get Thunderbird to use Edge at all.

John Liebson
 
Posts: 6513
Joined: July 29th, 2003, 1:09 pm

Post Posted June 8th, 2019, 11:46 am

That one is easy, Shakespeare solved it many years ago, when Cassius says "The fault, dear Brutus, is not in our stars, But in ourselves, that we are underlings."

Julius Caesar (I, ii, 140-141)

However, I will have to leave it to you to figure out how to apply the solution to your problem....

tanstaafl
Moderator

User avatar
 
Posts: 45402
Joined: July 30th, 2003, 5:06 pm

Post Posted June 8th, 2019, 4:51 pm

“No one has ever become poor by giving.”
― Anne Frank, diary of Anne Frank: the play

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 9 guests