MozillaZine

Font size in plain text message display

User Help for Mozilla Thunderbird
DavidGB
 
Posts: 37
Joined: October 15th, 2003, 5:25 pm

Post Posted September 6th, 2019, 2:17 pm

I appear to be very stupid at the moment. Before the update from 60.8.0 to 68.0 I had everything displaying as I want it through some mixture of options settings, Theme Font and Size Changer and a userChrome file ... long enough ago I can't now remember which I used for changing what. After the update to 68.0 - and Theme and Font Size Changer becoming not compatible - all text went far too small a size for me. Between Options settings and the userChrome.css I've almost got everything to the right size for me again: folder and message list panes and text written into the message composition window (note, I always use plain text for emails, not HTML). But the one thing I can't find a control for is the display size of text in a plain text email (opened in a separate window) - it's fine in View Source, but way too small in the actual message display window. Can anyone point me to the control for that font size? The one that I would have thought should control it in Options is doing nothing.

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted September 6th, 2019, 3:06 pm

"Change the font/font size in messages by using Tools -> Options -> Display -> Fonts -> Advanced, set the "minimum font size" and consider also unchecking "allow messages to use other fonts"" is suggested in http://kb.mozillazine.org/Bad_Eyesight_-_Thunderbird

Did you try unchecking "allow messages to use other fonts"?

I think the font resizing depends upon using CSS, which requires a HTML message (or an add-on). The fixed version of the add-on at https://addons.thunderbird.net/en-US/th ... ed/?src=ss claims to only support versions 58.0 - 65.0, so it probably hasn't been rewritten as a webextension.

http://kb.mozillazine.org/Font_settings_in_Thunderbird

DavidGB
 
Posts: 37
Joined: October 15th, 2003, 5:25 pm

Post Posted September 6th, 2019, 3:32 pm

Ah, I'd just found a bug causing the problem and a solution and was coming back here to post when your message came in. In Options>Options>Display>Formatting>Fonts & colors>Advanced (as it is in 68.0 using the hamburger menu ... funny, my Thunderbird is supposed to be enGB, so you'd think it would spell 'colours' correctly for this side of the pond) I had 'Use fixed width font for plain text messages' ticked. I'm old enough and old fashioned enough to go back to when emails were all plain text, usually only displayable in a monospace font like courier, and HTML texts, when they arrived, were the spawn of the devil. And there appears to be a bug in that changing the font size for 'Monospace font' (Consolas by default) in that options panel has no effect. Turning OFF 'Use fixed width font for plain text messages' gets the text in plain text messages in the message window displaying in the configured proportional font, which DOES respond to the font size. Oh well, at least until that bug is fixed, after all these years I guess I'll have to put up with seeing plain text emails in a proportional font! So at least it's a bug, not being totally stupid (though pretty stupid not to be sure it was a bug much sooner).

BTW, I reported to the author of 'Theme Font & Size Changer (fixed)' that it didn't work the day 68.0 came out. That was the first he knew it was broken in 68, and he replied that he is planning to fix it, but has to wait for his particular Linux distro to push the TB 68 release (or something like that - I'm not up on Linux), which they are apparently always very behind in doing. So it IS going to be fixed, but it may take some days/weeks.

Thanks for trying to help.

(I had previously tried the minimum font size setting, and it made no difference, so I still have it set to none.)

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 9 guests