MozillaZine

Add Ons Now Disabled in 68.1

User Help for Mozilla Thunderbird
orealius
 
Posts: 331
Joined: June 15th, 2005, 2:16 pm

Post Posted October 23rd, 2019, 9:24 pm

Well...If any TB engineers and programmers are following this thread: Please make the fonts in the startup message and folder panes EASILY adjustable. Everyone’s eyesight is different. This shouldn’t be a Herculean task!

JYLD
 
Posts: 133
Joined: July 18th, 2019, 9:59 am

Post Posted October 24th, 2019, 10:29 am

James wrote:The older Tb 60.0 branch is End Of Life or EOL as in getting no more security and stability updates so the Tb 60.9.0 was the last. Only the 68.X.x is getting updates right now.


Yes, I understand that, but so far there aren't any security updates that beyond 60.9 that I need. I also don't need any of the "new features" in TB 68+. What I do NEED are the few add-ons I find essential to making TB usable for my needs.

We have people coming here and posting, who are still using TB 17 and TB 45. Their complaint or needed help is NEVER about security issues, getting hacked, or getting a virus etc. The fact is if you have good anti-virus protection (I use ESET NOD32) and great spam and virus filtering at the ISP/Mail Server level (I run my domain email through a gmail back-end using Gsuite) then TB 60.9 is as secure and safe as any other email program including TB 68+.

I will be sticking with 60.9 for quite some time into the future. Maybe several years into the future if TB doesn't get the functionality I find necessary with the add-ons I use.

DanRaisch
Moderator

User avatar
 
Posts: 122154
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 24th, 2019, 10:37 am

I will be sticking with 60.9 for quite some time into the future. Maybe several years into the future if TB doesn't get the functionality I find necessary with the add-ons I use.

That decision means accepting that, at some point, folks here won't be able to offer any guidance or support because they will not have older versions like 60.9 with which to evaluate the issues reported by those who have remained with those obsolete versions. As long as folks are aware of that when deciding what version to stay with that all is good.

Frank Lion

User avatar
 
Posts: 20475
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 24th, 2019, 2:58 pm

tanstaafl wrote:For example the NextDraft daily newsletter uses the Verlag font family. That over-rides whatever the add-on , Tools->Options->Display->Formatting and/or my chrome\userChrome.css file sets. Very annoying.



Image

That is T/Bird 68.2 (yep, that's also a Complete Theme you see there) and instead of doing this via userContent.css which I already know will work, I decided to focus on the core T/Bird program.

I couldn't get the Font Options to work for those messages, so switched to the Config Editor and a quick experimentation later shows that font.size.variable.x-unicode pref (for plain text) and font.minimum-size.x-unicode pref (for html) are controlling this and so changed both values to a massive 32.

Both plain text and simple html look fine, but although Original HTML also enlarges, it looks a bit cramped. As I don't use this, I didn't bother to investigate further.

Edit - I think I've figured what's going on. By default my T/Bird 68.2 has a Text Encoding of Unicode and in Advanced Fonts it's showing as Latin, which seems right.

However - short story - set the Advanced Fonts at the top to 'Other Writing Systems' and proper font-size control is now available in those options. Then do the same for Latin, as messages seem to be one or the other.

tl:dr? you don't have to touch the Config Editor, you just have to have the selection in the 'Fonts for' box right and you can adjust the font-sizes there. Worked for me. :)
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

JYLD
 
Posts: 133
Joined: July 18th, 2019, 9:59 am

Post Posted October 24th, 2019, 4:08 pm

DanRaisch wrote:
I will be sticking with 60.9 for quite some time into the future. Maybe several years into the future if TB doesn't get the functionality I find necessary with the add-ons I use.

That decision means accepting that, at some point, folks here won't be able to offer any guidance or support because they will not have older versions like 60.9 with which to evaluate the issues reported by those who have remained with those obsolete versions. As long as folks are aware of that when deciding what version to stay with that all is good.



True, but I think that some point in the future is pretty far off. Also, 60.9 is rock solid and I don't need any of the kind of support to which you are referring. However, if I switched to 68+, then I would need support because my must have add-ons would stop working. Best to stick with 60.9 until the add-ons become available AND out of beta so to speak.

orealius
 
Posts: 331
Joined: June 15th, 2005, 2:16 pm

Post Posted October 24th, 2019, 4:37 pm

However - short story - set the Advanced Fonts at the top to 'Other Writing Systems' and proper font-size control is now available in those options. Then do the same for Latin, as messages seem to be one or the other.

tl:dr? you don't have to touch the Config Editor, you just have to have the selection in the 'Fonts for' box right and you can adjust the font-sizes there. Worked for me. :)[/quote]

You are referring to the startup folder and message panes? That's where the problem has been for me! :D

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted October 24th, 2019, 4:40 pm

Terrific! Thanks Frank.

I modified font.size.variable.x-unicode from 17 to 24 and ordinary plain text messages now look great. I modified font.minimum-size.x-unicode from 0 to 24. The text is much more readable in the NextDraft newsletter and most HTML messages, but I noticed problems with a few types of HTML messages. They all use us-ascii (Content-Type: text/html; charset="us-ascii"). I noticed a font.minimum-size.x-western in the config editor that is set to 16, but normally defaults to 0. I set it to 24. That fixed the problem with the other HTML messages.

I had been keeping "allow messages to use other fonts" unchecked, but in many versions of Thunderbird that had no effect. On my system it doesn't work with 60.9 but works with 68.2.0. Tools -> Options -> Display -> Formatting has never had any effect on plain text messages on my system.

I reset the modified preferences and then tried setting fonts using userContent.css. It worked fine with most messages. However, any of the HTML messages that used us-ascii it causes many of the lines to overwrite each other. I also saw the same problem in tb-planning digests (which have posts with varying Content-Type: headers). I'll need to experiment some more. But now I have options :)

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted October 24th, 2019, 5:05 pm

Frank Lion wrote:However - short story - set the Advanced Fonts at the top to 'Other Writing Systems' and proper font-size control is now available in those options. Then do the same for Latin, as messages seem to be one or the other

Great. Unfortunately the list box for "Fonts for" only has Latin using 68.2. Version 72.0a1 (today's Daily build) has a long list of selections in that list box, including "Other writing systems". Selecting it and setting the font size seems to work for both plain text and HTML messages. I normally use Original HTML, but with this setting its much easier to read many HTML newsletters using Simple HTML as that uses the same spaces between lines, line wrapping etc. as plain text.

orealius wrote:You are referring to the startup folder and message panes? That's where the problem has been for me! :D
See http://kb.mozillazine.org/Pane_and_menu_fonts . Setting a global font for the user interface using userChrome.css works fine.

Frank Lion

User avatar
 
Posts: 20475
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 25th, 2019, 3:16 am

tanstaafl wrote:I normally use Original HTML, but with this setting its much easier to read many HTML newsletters using Simple HTML

The 'Original HTML' side with large fonts is fixable, I reckon.

This Email stuff is a mystery to me and 'font encoding' is even more so, but I do know browsers and webpage stuff. So, what you guys call original html is just an everyday webpage to me and that I do know how to fix with .css. (usually :) )

As for the font encoding side - like Firefox, T/Bird almost always hides options it thinks users don't need, rather than removing them. So, as a general principle if you can't find what you want in Options, then look in about:config as the pref you want is usually still there.

In this case, I couldn't make sense of how the T/Bird Font Options worked (my zero knowledge of this 'font encoding' stuff didn't help) so did a search for font.size and font.minimum in about:config (Config Editor) and took it from there.

If you have problems with T/Bird 72 font options then I'd suggest you take the same route.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Frank Lion

User avatar
 
Posts: 20475
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 25th, 2019, 5:59 am

Frank Lion wrote:The 'Original HTML' side with large fonts is fixable, I reckon.

A very wet and windy day here means that I have time to do this now. :)

I've chosen a huge 64 font to demonstrate the problem with Original html -

Image

Bunched up text and text running into the line above/below. Even Simple html will not sort this extreme example (see the horizontal scrollbar?) -

Image

However, apply the fix and it's sorted. I tested this with 5 different text-heavy Emails and font sizes of 20, 24 and 32. and the result -

Image

The fix goes into userContent.css -

Code: Select all
/*Franks TBird Original html with large fonts fix....*/
*:not(body):not(html) {
  width: auto ! important;
  height: auto ! important;
  max-width: 1000px ! important;
  position: static ! important;
  top: auto ! important;
  left: auto ! important;
  float: none ! important;
  padding: 1px ! important;
  margin: 0px ! important;
  white-space: normal ! important;
  overflow: hidden ! important;
  line-height: normal !important;}


The max-width line can be changed to a different width, but best not to touch much else. I won't explain the code as it's pretty dull stuff and it's also much quicker for me to write code, than explain it all.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

JYLD
 
Posts: 133
Joined: July 18th, 2019, 9:59 am

Post Posted October 25th, 2019, 7:14 am

Frank Lion wrote:
Frank Lion wrote:The 'Original HTML' side with large fonts is fixable, I reckon.

A very wet and windy day here means that I have time to do this now. :)

I've chosen a huge 64 font to demonstrate the problem with Original html -


Excellent. Thanks for posting this code.

Frank Lion

User avatar
 
Posts: 20475
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted November 6th, 2019, 12:58 pm

JYLD wrote:Excellent. Thanks for posting this code.

No problem.

I should just point out that this userContent.css fix is only really needed for very large fonts, which would otherwise throw out the whole layout. i.e. it's not necessary for font sizes of, say, 18 to 24.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

JYLD
 
Posts: 133
Joined: July 18th, 2019, 9:59 am

Post Posted November 8th, 2019, 9:43 pm

"Other Writing Systems" = Western
"Latin" = unicode

Changing the prefs settings via Tanstafl's post above merely changes the minimum font size that can be set via Tools-Options-Display-Fonts-Advanced.

If all you want is to increase the font size used to display the few messages one receives in plain text monospace. Doing so via the minimum font size preferences can have some bad effects. Like it makes my stylized html signatures all screwed up, and it affects the size and look of some html messages one receives.

I have come up with the following which so far works as a good solution for just increase the display size of certain specific messages without affecting all other messages or the display of the compose window when writing a new message.

Code: Select all
/* Put this in Thunderbird userContent.css file */

/* This fixes monospace-fixed width font messages that are too small */
/* For example text monospace-fixed width emails from an iPhone */

pre,
code,
kbd,
samp,
tt{
  font-family: monospace, monospace !important;
  font-size: 16px !important;
}

/* This fixes messages coming in from gmail online interface that are just too small */

.moz-text-html {
  font-size: 18px !important;
}

/*This fixes messages coming in from Office 365 whose text is too small */

.moz-text-html .MsoNormal {
  font-size: 18px !important;
}


If you don't like the pixel sizes I prefer, just edit the css for a different pixel size.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 5 guests