Thunderbird and IPv6 mail server issues...

User Help for Mozilla Thunderbird
Posts: 78
Joined: January 20th, 2018, 5:15 pm

Post Posted October 9th, 2019, 7:24 am

Well here is my story.

Been using TB for about 3 years now. Upgraded to 68.1.1 but had issues with lower versions. This affects email only. All other Internet activities worked, browsers, download and streaming.

Comcast ISP.

About July/August time frame I got this intermittent error: The server to has been reset.

Sometimes it would work for weeks, days and hours. Sometimes it would not. Just clicking Get Messages failed.

As this time I fell back to MS Outlook 2007 and it failed also!

I found a workaround by doing one of the following, and then TB and Outlook would work, but eventually fail again.

1. Switch to Airplane mode and back.
2. Switch to the 2.4G band.
3. Switch to 5G band and back.
4. Sometimes restart the modem.

TB would work days and then fail. I wait and it would work again. Comcast tried to say it was a TB issue but since Outlook failed the same way... can't be that. When email was working TB and Outlook worked.

Comcast came out and replaced the cable from the box to the house. It was defective but after this TB worked for about 2 days and then back to the error again.


Searching the Internet I found information on IPv6 and email issues. Folks said to disable IPv6 in their NIC cards and all worked.

Well, luckily IPv6 can be turned off in Thunderbird! So I turned off IPv6 and now Thunderbird works fine!

I can toggle the IPv6 off and on and duplicate the issue!

So, if you are having email problems turn off IPv6 in Thunderbird so it is IPv4 only.

Options/Advanced/General/Config Editor Except the risk.

Just enter IPv6 in the search bar.

Toggle the setting to read: TRUE

network.dns.disableIPv6 modified boolean true

Now your Thunderbird should work.

BTW... Outlook still will fail, but TB works! This is an intermittent problem with Comcast servers but can affect others.
Last edited by sabretooth04 on October 10th, 2019, 5:59 am, edited 1 time in total.


User avatar
Posts: 123849
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 10th, 2019, 5:45 am

Just to muddy the waters a bit...

I too am accessing a Comcast email account through Thunderbird 68.1.1 under Win 10. In my installation network.dns.disableIPv6 is set to False yet I have not seen any reset errors at all. Perhaps there are other variables in this issue beyond that option in Thunderbird, such as which Comcast servers you're hitting when you try to access your email.

Posts: 78
Joined: January 20th, 2018, 5:15 pm

Post Posted October 10th, 2019, 5:57 am

Yes... after checking it appears that Comcast has not fully implemented IPv6 correctly on all it's mail servers. Just depends on where you are and which one you get.

Posts: 78
Joined: January 20th, 2018, 5:15 pm

Post Posted October 10th, 2019, 6:16 am

Oh, just to add for more information. I have a small task tray widget called EmailTray notifier. It just pop up and tells me I have new mail. I use this with TB.

This widget NEVER failed to get mail. Same settings and all. So that was baffling. After I found the issue and corrected it, I emailed the support for EmailTray and asked them if this program is an IPv4 program only. Here is their response.
Thanks for your question.

EmailTray officially supports IPv4 only.

Let me know if you have more questions.

Best regards,

Jane xxxxxxxx
EmailTray Support

This now explains why Emailtray worked all the time.

Return to Thunderbird Support

Who is online

Users browsing this forum: Google [Bot] and 6 guests