MozillaZine

Filter rule

User Help for Mozilla Thunderbird
Greenstone
 
Posts: 10
Joined: January 14th, 2019, 1:56 pm

Post Posted November 1st, 2019, 2:27 am

Hi there,

I set up a new filter rule for my email account (exchange) so that I can back up sent emails into another account:

FILTER ON EXCHANGE ACCOUNT:

- if subject doesn´t contain XXXXXXX
- copy message to gmail sent folder.

But it just doesnt do the task.

Any ideas how to make it work?

Thank you

DanRaisch
Moderator

User avatar
 
Posts: 122524
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 1st, 2019, 5:16 am

Is that filter set up to evaluate new messages coming into the Inbox folder of the Exchange account?
How is the account set up in Thunderbird, as POP or IMAP? Find out using menu path Tools->Account Settings->Server Settings->Server Type at the top right of the dialogue.
How is the Gmail set up in Thunderbird, as POP or IMAP?

tanstaafl
Moderator

User avatar
 
Posts: 46212
Joined: July 30th, 2003, 5:06 pm

Post Posted November 1st, 2019, 5:19 am

I'd start small by modifying the rule to do something like add a star instead, to make it easier to debug whether it gets triggered. You can also enable logging in the message filter pane.

The message filters for each account are stored in a "msgFilterRules.dat" file in the accounts "local directory". The local directory is specified near the bottom of each accounts server settings by the browse button . If all else fails use Notepad to look at the contents of that file.

Greenstone
 
Posts: 10
Joined: January 14th, 2019, 1:56 pm

Post Posted November 1st, 2019, 5:57 am

Thank you for your reply.

Yes - the filter checks incoming messages in the Exchange account.

The account set up is through Exquilla as it is an Exchange EWS server.

The Gmail set up is IMAP

Greenstone
 
Posts: 10
Joined: January 14th, 2019, 1:56 pm

Post Posted November 1st, 2019, 6:02 am

Thank you

Filter on Gmail account (sender) adds a star into incoming message in Exchange account

Filter on Exchange account (sender) does not add a star into incoming message in Gmail account

Greenstone
 
Posts: 10
Joined: January 14th, 2019, 1:56 pm

Post Posted November 1st, 2019, 6:37 am

SOLVED

I think I got it to work now. I actually looked at the "msgFilterRules.dat" file as you suggested and looked like my condition was messing up the coding as it had some ")" characters in the

- if subject doesn´t contain XXXXXXX

field

So I removed those characters and left only numbers and letters and now it seems to be working. Thanks a lot!

Return to Thunderbird Support


Who is online

Users browsing this forum: tanstaafl and 4 guests