MozillaZine

T'Bird is also putting replies in Sent folder. Don't want it

User Help for Mozilla Thunderbird
bex1210
 
Posts: 95
Joined: April 17th, 2006, 11:10 am

Post Posted November 4th, 2019, 12:54 pm

I am running Thunderbird 60.9.0 (32 bit) on a Windows 7 Pro (64 bit) SP1 computer. I recently am having a problem which I never had before. I searched for an answer here and in the Thunderbird Help, but perhaps I am searching incorrectly, because I could not find the issue. I use the IMAP Mail Server.

When I reply to an Email, I want my response to be placed in my folder of the message being replied to (my Inbox), and not in any other folders. Recently however, my response is ALSO being placed in my Sent folder, which means that it is placed in two folders. I don't want my replies also placed in my Sent folder.

I compacted all the applicable folders. No change. I then ran T'bird with the Add-ons disabled. No change.

The Copies & Folders section of my account does not give me an option to only "place replies in the folder of the message being replied to". So I have to select an additional place for the copy. I choose the 'Sent' folder. BUT these settings have not changed in the 18 months or so that I have been running T'bird, and I never had this problem before.

I don't know exactly when it started because I don't always check my Sent folder. It MAY have begun when I upgraded to 60.9.0 from 60.0 a few weeks ago, but I am not sure.

In any case, What is want is this:
1. When I am replying to a message, place my reply ONLY in the folder of the message being replied to.
2. When I initiate the message, place it ONLY in the Sent folder.

Is this possible with 60.9.0?


Harry

DanRaisch
Moderator

User avatar
 
Posts: 122154
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 4th, 2019, 1:44 pm

By default, Thunderbird will always place an outgoing message in a designated Sent folder, either that of the email account or under Local Folder.

Under menu path Tools->Account Settings->Copies & Folders->"When sending a message automatically:" do you have "Place replies in the folder of the message being replied to"?

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted November 4th, 2019, 2:30 pm

If you use the Gmail SMTP server it automatically places a copy of the sent message in a sent folder. It does that regardless of what email client you are using or how the email client account is configured. That is why you are supposed to uncheck Thunderbird saving a copy for a Gmail account in copies&folders, to avoid duplicates. If you were using a Gmail account and configured it to "Place replies in the folder of the message being replied to"? that would occur in addition to the SMTP server saving a copy in the sent folder.

What email provider are you using?

bex1210
 
Posts: 95
Joined: April 17th, 2006, 11:10 am

Post Posted November 4th, 2019, 5:37 pm

tanstaafl wrote:If you use the Gmail SMTP server it automatically places a copy of the sent message in a sent folder. It does that regardless of what email client you are using or how the email client account is configured. That is why you are supposed to uncheck Thunderbird saving a copy for a Gmail account in copies&folders, to avoid duplicates. If you were using a Gmail account and configured it to "Place replies in the folder of the message being replied to"? that would occur in addition to the SMTP server saving a copy in the sent folder.

What email provider are you using?


My primary Email account (where I send/receive 99% of my Emails) is with Compuserve, and the IMAP mail server is imap.aol.com. My outgoing server (SMTP) for this account is smtp.aol.com.

My secondary account is with AT&T. There the IMAP mail server is imap.mail.att.net. My outgoing server (SMTP) for this account is smtp.mail.att.net.

My ISP is AT&T (a fiber connection). None of the above settings have changed since I changed my ISP to AT&T over a year ago. (I did not use Thunderbird until after I changed my ISP to AT&T.)

P. S. After I got your note, I went to Copies & Folders for my Compuserve account, and unchecked "Place a copy in:". When I tested it that way, NO copies were placed in either my Inbox or my Sent folder.


Harry

bex1210
 
Posts: 95
Joined: April 17th, 2006, 11:10 am

Post Posted November 7th, 2019, 11:20 am

Any thoughts on the email provider information I submitted?

I also am noticing that there are two copies placed in my Sent folder, rather than just one. Both copies are identical, including the time.


Harry

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted November 7th, 2019, 12:14 pm

I've lost track of AOL's quirks but they have a history of imposing a number of restrictions.

"In any case, What is want is this:
1. When I am replying to a message, place my reply ONLY in the folder of the message being replied to.
2. When I initiate the message, place it ONLY in the Sent folder.
"

I assume you already tried checking both "place a copy in" AND "place replies in the folder of the message being replied to" and Thunderbird wasn't smart enough to ignore "place replies in the folder of the message being replied to" when sending and vice versa.

A) If you're configured to do that and it stopped working try running in safe mode (help -> restart with add-ons disabled) to see if its not your version of Thunderbird thats the culprit, but a mis-behaving add-on. If that doesn't help try a slightly older version of Thunderbird to see if there is a regression bug. You can use custom setup and install it in a different directory, so that it reuses your existing profile. See http://kb.mozillazine.org/Go_back_to_an ... hunderbird if you want to try that. You don't need to uninstall your current version, the two versions can be installed at the same time as long as you use different directories.

B) If checking both doesn't work then I suggest not checking "place a copy in" and check "place replies in the folder of the message being replied to". Then create a multiple identity for the same email address where you uncheck that setting, and check "place a copy in". When you send a message you will need to select that multiple identity from the From: drop down list. The multiple identity would have the same email address, but you could change the display name for that address to something different so that you can tell them apart in the From: dropdown list.

See http://kb.mozillazine.org/Multiple_iden ... il_account . When you initially create the multiple identity it clones the account settings, so you only need to make whatever modifications you need.

C) It would be more convenient if you used a message filter for sending instead. If you want to experiment with that uncheck "place a copy in". and then create two rules. One checks if you are replying and the other checks if you are sending. You'd need to check the Mozilla-Status header to see if you had already replied to it, and create a custom header for it so that the filters can check that header. The drawback is that if you had already replied to a message (and that message is currently selected) its not going to be able to distinguish between you replying again and sending a new message. That why using a multiple identity seems a better solution.

http://kb.mozillazine.org/Custom_headers
https://web.archive.org/web/20160121110 ... tatus.html
https://web.archive.org/web/20180503152 ... eFlags.idl

bex1210
 
Posts: 95
Joined: April 17th, 2006, 11:10 am

Post Posted November 7th, 2019, 11:05 pm

tanstaafl wrote:I've lost track of AOL's quirks but they have a history of imposing a number of restrictions.

"In any case, What is want is this:
1. When I am replying to a message, place my reply ONLY in the folder of the message being replied to.
2. When I initiate the message, place it ONLY in the Sent folder.
"

I assume you already tried checking both "place a copy in" AND "place replies in the folder of the message being replied to" and Thunderbird wasn't smart enough to ignore "place replies in the folder of the message being replied to" when sending and vice versa.

A) If you're configured to do that and it stopped working try running in safe mode (help -> restart with add-ons disabled) to see if its not your version of Thunderbird thats the culprit, but a mis-behaving add-on. If that doesn't help try a slightly older version of Thunderbird to see if there is a regression bug. You can use custom setup and install it in a different directory, so that it reuses your existing profile. See http://kb.mozillazine.org/Go_back_to_an ... hunderbird if you want to try that. You don't need to uninstall your current version, the two versions can be installed at the same time as long as you use different directories.


Easy stuff first.
My basic settings are to check both "place a copy in" AND "place replies in the folder of the message being replied to". And Thunderbird wasn't smart enough to ignore "place replies in the folder of the message being replied to" when sending and vice versa.

I compacted all the applicable folders. No change. I then ran T'bird with the Add-ons disabled. No change.

I also have Tbird 60.9 on my laptop. so I went there to run extensive 'what if' tests. Initially I was able to get rid of having two copies places in my Sent folder if I set the 'Sent' Folder to my compuserve account. I previously had my compuserve account selected as 'Other'.

For a while I thought that the problem of always putting a copy in my Sent folder only occurred if I was using AT&T as my Mail & Outbound servers, but I found I still has the problem with compuserve servers.

I re-installed TB60 on my desktop. That did not help the problem. I tried the Profile from my laptop. That didn't help. I then tried to 'Place a copy in:' then chose Other, and chose Junk on Local Folders. That did not work in either Tbird 60.0 or 60.9. The copy was still placed in the Compuserve Sent folder. I then created a 'Sent' folder in local folders and selected 'Place a copy in "Sent" folder on Local Folders. It placed nothing there, and put it in the Send folder in compuserve instead.

I have Tbird 58 also, but even if one of these different versions works, no one is going to fix it since Tbird is now at 68.

I thought about creating a whole new profile, but that takes an awful lot of time.

So my current plan is to do two things:
Log into both my Compuserve and ATT accounts, and see if there is any setting I might have missed that would affect this problem.

Then I will try your Multiple Identity suggestion.

Let me know if my lack of success leads to any other ideas. I was really surprised that I could not place a copy in my Local Folders.


Harry

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted November 8th, 2019, 1:52 am

If you check "place a copy in" and select the "other" radio button you can choose a folder in Local Folders.

I doubt creating a new profile would help since all of the relevant settings are account settings. You can have both a POP and a IMAP account for the same mailbox/email address (in the same profile), at the same time. So you could create a second account that you used just to experiment on, in your existing profile.

bex1210
 
Posts: 95
Joined: April 17th, 2006, 11:10 am

Post Posted November 8th, 2019, 11:37 am

tanstaafl wrote:If you check "place a copy in" and select the "other" radio button you can choose a folder in Local Folders.


I can't get this to work. I tried both 'Junk on Local Folders' and 'Trash on Local Folders' I tried both my laptop and my desktop. Both for my Compuserve account.

In all cases, the copy is placed in the 'Sent' folder of my Compuserve account, and nothing is placed in the Junk ((or Trash) folder in Local Folders.


Harry

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted November 8th, 2019, 6:42 pm

You were able to select a different destination, but it wasn't used? That sounds like your smtp server is hardcoded to save a copy (like the gmail smtp server does) except I'd expect you to get two copies (in different folders) if that was the case.

Did you try the AT&T account? Its possible AOL has impose some restrictions that are causing your problem.

bex1210
 
Posts: 95
Joined: April 17th, 2006, 11:10 am

Post Posted November 9th, 2019, 11:48 am

tanstaafl wrote:You were able to select a different destination, but it wasn't used? That sounds like your smtp server is hardcoded to save a copy (like the gmail smtp server does) except I'd expect you to get two copies (in different folders) if that was the case.

Did you try the AT&T account? Its possible AOL has impose some restrictions that are causing your problem.


I do get two copies. One in my Inbox (I checked "in the folder of the message being replied to"), and one in my Sent folder.

I looked at both my AT&T and my Compuserve/AOL accounts. I don't see any settings that affect my copies or where they are placed. But I may not know exactly what I am looking for.

I can try asking their Support folks about hard coding, but I never have a lot of confidence in their answers.


Harry

tanstaafl
Moderator

User avatar
 
Posts: 45784
Joined: July 30th, 2003, 5:06 pm

Post Posted November 9th, 2019, 1:54 pm

If you're getting duplicates then the simplest option would be to use a SMTP server from another email account (with those two troublesome accounts) that works normally, instead of the ones from Compuserve and AT&T. However, you apparently don't have one.

You could sign up for a free outlook.com account and configure it (via webmail settings) to automatically fetch mail from your Compuserve and AT&T inboxs. You could then add a Outlook account in Thunderbird with multiple identities for your AT&T and Compuserve email addresses. That would let you delete your two accounts in Thunderbird (after moving any old messages to the Outlook account) and use just the Outlook account. With multiple identities Thunderbird will automatically default to the address a message was sent to when replying. You can also choose those From addresses from the From: drop down list when sending a new message. Probably more hassle than its worth, but something to think about.

http://kb.mozillazine.org/Multiple_iden ... il_account

bex1210
 
Posts: 95
Joined: April 17th, 2006, 11:10 am

Post Posted November 9th, 2019, 3:45 pm

tanstaafl wrote: You could sign up for a free outlook.com account and configure it (via webmail settings) to automatically fetch mail from your Compuserve and AT&T inboxs. You could then add a Outlook account in Thunderbird with multiple identities for your AT&T and Compuserve email addresses.


It is not worth that effort to set up an Outlook account.

I have tried several things. I set up multiple identities. If the identity is the default, then it automatically duplicates the setting in 'Copies & Folders'. So I set another identity as the default. I could then set it so Copies and Folders settings had NOTHING checked, and my chosen identity had only placing a copy in Other (which was my inbox).

In these cases I always got the message 'Copying to inbox folder' just kept running and running. A Retry would get it to work. but still a copy was also placed in the Sent folder.

So I guess I will go to an AOL forum and see if anyone there knows how to stop the automatic placing in the Sent folder.


Harry

Ed1
 
Posts: 944
Joined: January 30th, 2005, 2:33 pm

Post Posted November 11th, 2019, 6:49 am

I also have an AOL IMAP email account and just a few days ago, for the first time, I've started receiving 2 copies of each email I send. One is listed in bold text, the other is not. This is very curious. I will start a separate thread looking for a solution. This may have started when I updated to TB 68.2.2, not sure exactly.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 6 guests