MozillaZine

How to set font display sizes

User Help for Mozilla Thunderbird
scuffer
 
Posts: 7
Joined: July 19th, 2007, 6:01 pm

Post Posted November 5th, 2019, 11:00 pm

In the past couple of weeks, all of a sudden some emails and newsgroup postings have started displaying with different font sizes, one of which is too tiny for me. I've tried changing the font sizes in the options (including the advanced tab) to no avail.

After looking at the message headers, I've found that

Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 8bit

is too tiny and unresponsive to changing the font size while

Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

is large enough. I've tried switching out these headers in messages and I know this is the problem.

My question is how do I get Thunderbird to set the font sizes for the first content-type? An old posting here mentioned extensions which are no longer supported. And is there something that changed in the last couple of weeks that caused this? If so, why?

tanstaafl
Moderator

User avatar
 
Posts: 45904
Joined: July 30th, 2003, 5:06 pm

Post Posted November 6th, 2019, 7:14 am

See the various posts in viewtopic.php?p=14845003#p14845003 , especially the ones from Frank Lion.

Your problem might be that "allow messages to use other fonts" in tools -> options -> display -> formatting -> advanced is checked. Uncheck it, so that only your font settings are used. Setting "fonts for" to "other writing systems" also works around the problem of the font settings in tools -> options -> display -> formatting only effecting HTML messages due to their using CSS.

"I modified font.size.variable.x-unicode from 17 to 24 and ordinary plain text messages now look great. I modified font.minimum-size.x-unicode from 0 to 24". I tried but decided against using the CSS code Frank suggested for userContent.css

The themes and font sizer add-on doesn't support version 68, but its designed to effect the fonts used in the user interface, not the messages. You can do the same thing by setting a global font in userChrome.css per http://kb.mozillazine.org/Pane_and_menu_fonts . The userContent.css file is used to modify fonts in messages (aka content) but the other changes mentioned above are a easier alternative.

scuffer
 
Posts: 7
Joined: July 19th, 2007, 6:01 pm

Post Posted November 7th, 2019, 3:56 am

tanstaafl wrote:See the various posts in viewtopic.php?p=14845003#p14845003 , especially the ones from Frank Lion.

Your problem might be that "allow messages to use other fonts" in tools -> options -> display -> formatting -> advanced is checked. Uncheck it, so that only your font settings are used. Setting "fonts for" to "other writing systems" also works around the problem of the font settings in tools -> options -> display -> formatting only effecting HTML messages due to their using CSS.


That, plus increasing the default font size higher worked for UTF-8, which was giving me the too small font size. However, it still had no effect on messages with us-ascii charsets. But while that charset has a different font and size than UTF-8, its size is large enough for me. I can live with this.

Somewhere deep in the bowels of Thunderbird there must be some sort of default fonts and sizes for each charset that apparently can't be reached from the user options.

tanstaafl wrote:You can do the same thing by setting a global font in userChrome.css per http://kb.mozillazine.org/Pane_and_menu_fonts . The userContent.css file is used to modify fonts in messages (aka content) but the other changes mentioned above are a easier alternative.


That also worked. It's nice since the original display size of the pane and menu fonts was a bit small to me, though not as bad as the message body problem I had with UTF-8.

Thanks!

scuffer
 
Posts: 7
Joined: July 19th, 2007, 6:01 pm

Post Posted November 18th, 2019, 10:00 am

scuffer wrote:That, plus increasing the default font size higher worked for UTF-8, which was giving me the too small font size. However, it still had no effect on messages with us-ascii charsets.


I found a way around this. If you right-click on a folder name in the left pane and then on the "Properties" entry, one of the options is "Fallback Text Encoding:" which lets you choose the default text encoding. Underneath that is a checkbox "Apply encoding to all messages in the folder". By ticking the checkbox and then setting the font and font size for the chosen fallback text encoding in the Options menu, I can override and control the font and font size in all my messages so that they have an uniform appearance.

nalag46
 
Posts: 31
Joined: November 26th, 2011, 12:19 pm

Post Posted December 10th, 2019, 11:25 am

I also need help with this topic.
I have just updated to 68.3 and now all my messages "Subject names", but not the texts, are too small to read and I do not seem to be able to change the font. I have tried : tanstaafl wrote:
See the various posts in viewtopic.php?p=14845003#p14845003 , especially the ones from Frank Lion.

Your problem might be that "allow messages to use other fonts" in tools -> options -> display -> formatting -> advanced is checked. Uncheck it, so that only your font settings are used. Setting "fonts for" to "other writing systems" also works around the problem of the font settings in tools -> options -> display -> formatting only effecting HTML messages due to their using CSS.

But this does not make any difference. This is the first time this has happened so I take it is due to the latest update and what or how do I sort it out?
Any advise would be much appreciated.

tanstaafl
Moderator

User avatar
 
Posts: 45904
Joined: July 30th, 2003, 5:06 pm

Post Posted December 10th, 2019, 11:38 am

Are the fonts also too small in the menus/toolbars? Then see http://webcache.googleusercontent.com/s ... menu_fonts . Not mentioned in the KB article (since the wiki is in read-only mode) is that you need to set toolkit.legacyUserProfileCustomizations.stylesheets to true using the config editor if you are using version 68 or later.

An example:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* Global UI font - the leading '*' is not a typo*/
* { font-size: 17pt !important;
font-family: Verdana !important;
}

nalag46
 
Posts: 31
Joined: November 26th, 2011, 12:19 pm

Post Posted December 10th, 2019, 11:58 am

All the fonts in the menus and toolbars are ridiculously tiny as well.
I am sorry but I don't know how to set toolkit.legacy mentioned above and I do not have a userChrome.css file in my profiles folder either.
Is there a way to go back to an earlier update version when things were working normally?

tanstaafl
Moderator

User avatar
 
Posts: 45904
Joined: July 30th, 2003, 5:06 pm

Post Posted December 10th, 2019, 12:06 pm

See http://webcache.googleusercontent.com/s ... hunderbird . Before you do that see if the problem still occurs if you use help -> restart with add-ons disabled.

userChrome.css is an optional file in the chrome subdirectory in your profile. You might also need to create the chrome subdirectory.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests