MozillaZine

How to reply in html to a plain-text message?

User Help for Mozilla Thunderbird
coffent
 
Posts: 74
Joined: December 29th, 2005, 1:59 pm

Post Posted May 14th, 2020, 10:23 am

I can forward a plain-text message in html by shift-clicking Forward, but this doesn't work for Reply. Is there some way to force a reply to be in html?

DanRaisch
Moderator

User avatar
 
Posts: 123082
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 14th, 2020, 1:46 pm

Is your default composition mode HTML? If so, try just replying to see if you have access to the HTML formatting tool bar, just above the text entry area.

coffent
 
Posts: 74
Joined: December 29th, 2005, 1:59 pm

Post Posted May 14th, 2020, 2:42 pm

No, my default mode is plain text. However I set it temporally to HTML for testing. The problem remains the same. With default HTML, clicking Forward to a plain-text message opens the composition window in HTML, shift-clicking opens it in plain text (opposite as before, as expected). However whether clicking or shift-clicking Reply to a plain-text message, the composition window is always plain-text.

DanRaisch
Moderator

User avatar
 
Posts: 123082
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 14th, 2020, 3:27 pm

I can't replicate that here. Does the same thing occur if you launch the application in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode

morat
 
Posts: 3763
Joined: February 3rd, 2009, 6:29 pm

Post Posted May 14th, 2020, 4:39 pm

It works here.

I tested with a simple plain text message.

* select message, hold shift key and click reply button to compose in plain text mode
* select message, click reply button to compose in html mode

coffent
 
Posts: 74
Joined: December 29th, 2005, 1:59 pm

Post Posted May 14th, 2020, 5:19 pm

Dan & Morat - thanks for your replies. Yes, it turns out it was an Add-on. I ran TBird in Safe mode and Reply worked as expected. I then resumed normal mode and disabled the Add-ons until I found the problem. It was with one called ChangeQuote. It had a setting that I'd overlooked that was causing the problem. I should have checked this first, but thanks for the help!

DanRaisch
Moderator

User avatar
 
Posts: 123082
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 15th, 2020, 4:19 am

No problem. Extensions are often at issue and sometimes it is a specific setting/option in that extension, making Safe Mode one of the first things to be tried when diagnosing problems.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests