MozillaZine

Messages stuck in outbox + paragraph break. [Mac.]

User Help for Mozilla Thunderbird
JoeHalpern
 
Posts: 6
Joined: May 18th, 2020, 6:07 am

Post Posted May 18th, 2020, 6:21 am

I started using Thunderbird version 68.8.0 (on a Mac Air) about two weeks ago (after using earlier versions for decades), and have had two serious problems since then:

- Messages occasionally get stuck in my outbox without being sent. Note that this happens after several hours of use of Thunderbird, when all earlier messages have been sent without problem. The "send unsent messages" line is grayed out. The only way that I seem to be able to send them is by quitting Thunderbird and then restarting.

- When I do restart Thunderbird, hitting return gives me a paragraph break. I know how to fix this problem (going to composition->global account settings -> general and then unticking the box that says "use paragraph format instead of body text by default"), but I have to do this every time that I restart Thunderbird (which I now do often to solve the outbox problem mentioned above). I can't seem to get Thunderbird to remember my settings.

Both issues are driving me up a wall, so I hope that someone can help.

Thanks,
Joe
Last edited by LIMPET235 on May 18th, 2020, 6:32 am, edited 1 time in total.
Reason: Added [Mac] to the Title.

DanRaisch
Moderator

User avatar
 
Posts: 123691
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 18th, 2020, 11:34 am

A) Make sure that all current outbound messages have been sent. Then close Thunderbird and navigate to the profile folder. http://kb.mozillazine.org/Profile_folder_-_Thunderbird
In the Local Folder sub-directory, locate and delete the files Outbox and Outbox.msf
Restart Thunderbird and use normally. See if the issue arises again.

B) Confirm that the file prefs.js in the profile folder is not set to "Read Only" status. If Thunderbird is unable to save changes to that file you will see issues of changes to settings not be saved.

JoeHalpern
 
Posts: 6
Joined: May 18th, 2020, 6:07 am

Post Posted May 19th, 2020, 7:35 am

Thanks.

With regard to (A), I didn't see folders names Outbox or Outbox.msf; I did see folders named "Unsent" and "Unsent.msf". In the hopes that they're essentially the same, I deleted them. I'll let you know how it goes.

With regard to (B), according to the sharing permissions on my Mac, I can read and write pref.js. I checked, whenever I update my preferences, pref.js does get updated. That makes sense, since when I just the preferences, the line spacing works fine until I quite Thunderbird. But it seems that they get updated again (probably to the default) when I close Thunderbird. So I have to reset my preferences every time I re-open Thunderbird.

JoeHalpern
 
Posts: 6
Joined: May 18th, 2020, 6:07 am

Post Posted May 19th, 2020, 7:49 am

An update on (B): the last suggestion here (from Toad-Hall) seems to have solved the problem (which was indeed related to pref.js).

DanRaisch
Moderator

User avatar
 
Posts: 123691
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 19th, 2020, 8:14 am

It might help others is you posted the actual solution to that issue.

JoeHalpern
 
Posts: 6
Joined: May 18th, 2020, 6:07 am

Post Posted May 23rd, 2020, 10:19 am

Sorry; I thought that the link was in my message; it's https://support.mozilla.org/en-US/questions/1271057. Here is the complete solution:

click on 'Open folder' button.
Exit Thunderbird - this is important.
delete 'permissions.sqlite' - read comment 10 in bug report.
Open 'prefs.js' file using eg: Notepad or similar text editor program. Note: you could create a copy of 'prefs.js' on desktop as a temp backup in case you make a mistake.
look for preference: mail.ui-rdf.version
Set the value to 14, so it looks like the line below - Note in Bug report they set Value to 14 and it successfully then upgraded to 17 .
user_pref("mail.ui-rdf.version", 14);
Save the 'prefs.js' file.
Start Thunderbird.

Reset preference: Windows OS:

Menu icon > Options > Composition > 'General' tab
MAC OS:

Thunderbird > Preferences > Composition > 'General' tab
Linux OS :

Edit > Preferences > Composition > 'General' tab
Then...

uncheck "Use Paragraph format instead of Body Text by default".
click on OK

JoeHalpern
 
Posts: 6
Joined: May 18th, 2020, 6:07 am

Post Posted June 2nd, 2020, 4:32 am

My main problem (messages stuck in the outbox) is still happening. I'm pretty much ready to give up on Firefox unless I can find a reasonable solution.

DanRaisch
Moderator

User avatar
 
Posts: 123691
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted June 2nd, 2020, 5:17 am

You speak of giving up on Firefox but the issue you reported here was in regard to Thunderbird. I'm guessing that is the program you actually mean.

You said "With regard to (A), I didn't see folders names Outbox or Outbox.msf; I did see folders named "Unsent" and "Unsent.msf". In the hopes that they're essentially the same, I deleted them. I'll let you know how it goes" but never reported back on any results. Did you, with Thunderbird closed, delete the files Unsent and Unsent.msf?

JoeHalpern
 
Posts: 6
Joined: May 18th, 2020, 6:07 am

Post Posted June 11th, 2020, 4:56 am

Sorry, I did mean Thunderbird, and yes, i did delete Unsent and Unsent.msf

DanRaisch
Moderator

User avatar
 
Posts: 123691
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted June 11th, 2020, 5:20 am

Just to be certain, do you have more than one Thunderbird profile? Check that using menu path Help->Troubleshooting Information->at the bottom of the block titled "Application Basics" click on the button reading "about:profiles". How many profiles are listed there?

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 7 guests