MozillaZine

Can I eliminate automatic file downloads?

User Help for Mozilla Thunderbird
bex1210
 
Posts: 126
Joined: April 17th, 2006, 11:10 am

Post Posted June 29th, 2020, 8:31 am

DanRaisch wrote:How are you determining that the attachment was downloaded?


Two ways:
1. it took T'bird 'forever' to get the Email and attachment loaded. That is what usually happens when someone is attaching a large file.
2. The file size was listed on the header bar of the Email. As I discovered yesterday, when the attachment is not downloaded, no size information is given.


Harry

bex1210
 
Posts: 126
Joined: April 17th, 2006, 11:10 am

Post Posted July 31st, 2020, 2:11 pm

DanRaisch wrote:How are you determining that the attachment was downloaded?


On the header with each Email received, the items listed are:
From
Subject
To
Attachment

If the attachment was downloaded, it will print the size of the attachment after the attachment name. If it was not downloaded, it will say 'size unknown'. That appears to be the way it works. I am testing it by sending from an account I have with a different ISP to my main ISP.

Here is what I have found so far.
These types of files will provide a 'size unknown' designation:
.mp3, .pdf, .docx, .xlsx, .pptx, .csv, and .rtf.

These types of files will always print the size of the attachment (never a 'size unknown'):
.mp4, .aup, .jpg, .png, .gif, .tif, .txt, .html.

My sending ISP will NOT sent an .exe file. I guess that is for security reasons.

The people who send me large files are primarily .mp4. Over the last couple of months no one has sent me a file of the type that will provide a 'size unknown' designation, so I haven't been able to test that. Now that I have a fairly complete list, I will have someone send me some large .mp3 or .pdf files to provide a better test.


Harry

bex1210
 
Posts: 126
Joined: April 17th, 2006, 11:10 am

Post Posted October 2nd, 2020, 1:07 pm

Dan: Sorry to be so long away, but have been on other projects.

As I said earlier, the .mp4 files are the primary issue. Let me give you a recent example that may help diagnose the problem. As I mentioned before, my primary Email address is with AOL. So before I even open Thunderbird (IMAP) for the 1st time each day, I go to AOL's rudimentary email program, and view what it there. My initial reason for doing that was to delete all the spam/unwanted Emails that I get before I ever open Thunderbird.

But when I found an Email that contained a .mp4 attachment, I would open it. They open immediately, and like Thunderbird, then give me the option to open the .mp4 file (which also opens within 1 or 2 seconds).

I then marked that Email as 'unread', closed my AOL account, and opened Thunderbird. As soon as I tried to open the Email with the .mp4 attachment, it took about 3.5 minutes to open the Email!

This same situation has occurred each time I am sent an .mp4 attachment. The actual time varies with the size of the attachment, but the Thunderbird opening time is always minutes, not seconds.

Does this give you any better idea of what the problem might be? If you never get .mp4 files sent to you, I would be more than happy to send you one to see if you experience the same problem.

Harry

tanstaafl
Moderator

User avatar
 
Posts: 46955
Joined: July 30th, 2003, 5:06 pm

Post Posted October 2nd, 2020, 7:39 pm

How large is that email message that took 3.5 minutes to open? How large is the MP4 attachment?

http://kb.mozillazine.org/Entire_messag ... AP_message

I think initially there are two mechanisms limiting what gets downloaded. One is the disk space settings in synchronization & storage or disk space (depending upon the account type). However if you are using a IMAP account the MIME Parts on Demand settings kicks in first. It will fetch all of a message up to 30KB by default. After that whether you open the attachment kicks in.

However, if Tools -> Account Settings -> Junk Settings -> "Enable adaptive junk mail controls for this account" is checked the junk mail controls will want to fetch the entire message in order to test it. If you have a message filter that test the "body" it actually tests the entire message, so that fetches the entire message.

View -> display attachments inline should be UNchecked. Otherwise you automatically open all attachments when possible. Doing that is also a major security risk.

Check the status of your junk mail controls. If they're off, check mail.imap.mime_parts_on_demand is true , and mail.imap.mime_parts_on_demand_threshold is 30000 using the config editor.

Its confusing :)

With version 78.3.1 I have several messages with PDF or MP3 attachments over 15MB that it takes less than a second to open the message because its not fetching the attachment. I'm skeptical your problem is due to it being a MP4 attachment, you probably just haven't figured out what setting is forcing it to automatically open the attachment.

If none of this helps please use control->U to look at the raw source for one of the messages and copy&paste the headers for the attachment. They will be below the actual message body. An example:

--------------090507090005010603010600
Content-Type: application/pdf;
name="LuceneinAction,SecondEdition.pdf"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename="LuceneinAction,SecondEdition.pdf"

JVBERi0xLjYKJeLjz9MKMSAwIG9iajw8L1R5cGUvRm9udC9CYXNlRm9udC9IZWx2ZXRpY2Ev
followed by more gibberish like that for many pages (the base64 encoded contents). I don't need that, just the three headers.

bex1210
 
Posts: 126
Joined: April 17th, 2006, 11:10 am

Post Posted October 3rd, 2020, 10:05 pm

tanstaafl wrote:How large is that email message that took 3.5 minutes to open? How large is the MP4 attachment?


I just got an Email with an .mp4 attachment today. It took 3 minutes, 48 seconds before the message text appeared on the screen. The .mp4 file was 10.9 MB. I have rearranged your suggestion order, so they are listed in the order I tried things.

If none of this helps please use control->U to look at the raw source for one of the messages and copy&paste the headers for the attachment. They will be below the actual message body. An example:

--------------090507090005010603010600
Content-Type: application/pdf;
name="LuceneinAction,SecondEdition.pdf"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename="LuceneinAction,SecondEdition.pdf"


I could not find those exact type of entries. I was planning to attach a copy of the complete file, but I could not figure out how to add an attachment. How do I do that?

I think initially there are two mechanisms limiting what gets downloaded. One is the disk space settings in synchronization & storage or disk space (depending upon the account type). However if you are using a IMAP account the MIME Parts on Demand settings kicks in first. It will fetch all of a message up to 30KB by default. After that whether you open the attachment kicks in.


On Synchronizing & Storage, I have 'Keep messages in all folders for this account on this computer' checked. Under Disk Space, I have 'Synchronize all messages locally regardless of age' selected, and 'Don't download messages larger than 50 KB' checked. I think in an earlier thread you suggested moving from 30 KB to a larger number. I don't know the exact KB of the text that displayed after the message I just received was opened, but it was only 5 words, although each were in color and stylized in some way.

Check the status of your junk mail controls. If they're off, check mail.imap.mime_parts_on_demand is true , and mail.imap.mime_parts_on_demand_threshold is 30000 using the config editor.


I wasn't sure exactly sure where to find my junk mail controls, but I went to about:config, and the first Preference Name has a value of 'true', and the 2nd a value of 30000; just as you indicated.

However, if Tools -> Account Settings -> Junk Settings -> "Enable adaptive junk mail controls for this account" is checked the junk mail controls will want to fetch the entire message in order to test it. If you have a message filter that test the "body" it actually tests the entire message, so that fetches the entire message.


'Enable adaptive junk mail controls for this account' was checked. Unchecking it made no difference. I was not sure where to look to see if I have a message filter that tests the 'body'.

View -> display attachments inline should be UNchecked. Otherwise you automatically open all attachments when possible. Doing that is also a major security risk.


That was checked. I unchecked it, and the problem is SOLVED! Now the message opens almost immediately, and then I can click to open the .mp4 file, which also opens immediately.

Its confusing :)


No kidding!

I'm skeptical your problem is due to it being a MP4 attachment.


It certainly might have happened with other types of attachments, because I didn't test everything. But it doesn't seem to happen with .pdf files, and I have received some as large as 8 MB.


Thanks for all your help, and patience.


Harry

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 4 guests