MozillaZine

Missing account folders

User Help for Mozilla Thunderbird
Philip Rayment
 
Posts: 6
Joined: June 28th, 2020, 2:58 am

Post Posted June 28th, 2020, 3:47 am

Hello, I'm hoping someone can help. I've had Thunderbird for several years now, with little in the way of problems. I have one main account that I use (a Yahoo one), but do have several other accounts, all set up in Thunderbird, and (I think) all set up as pop accounts (certainly my main one is). I also have a gmail account that I needed to get for my smartphone, but which I don't really use and don't have set up in Thunderbird.
I recently (a few months ago) installed the add-in QuickFolders. Under my Yahoo account folder, I had perhaps 30 sub-folders (I have 30 .msf folders in the Yahoo profile folder), and quite a few of them had their own sub-folders.

I also compile a newsletter for a non-profit organisation, and I've set up a rule that any e-mails with the name of the newsletter (I'll call it 'Bulletin' in this post) in the subject go into a sub-folder (of my main account) with that name. That Bulletin sub-folder also has a few sub-folders of its own. The rule is so that people sending me items for the Bulletin have their emails go straight into that folder.

That's all background, and it''s been working okay.

The organisation recently created a special email address (Bulletin@organisation) for the newsletter, so I needed to add that account to Thunderbird, with the intention that those emails go straight into the Bulletin sub-folder.

So I added the new account, but for some reason the process took me to the sign-in page for my gmail account. I have no idea why, but I signed into it. Anyway, it all worked, in that the Bulletin@organisation account was added, and I was able to download the test and other e-mails that had already been sent to it.

However...

I then noticed that my main (Yahoo account) folders had disappeared! The other (little used) accounts are still there, but not my main one. Except that my original sub-folders of the original Bulletin sub-folder are still there!

I've Googled for answers, but so far all I've found are solutions to somewhat-different issues, and although I've tried one or two things, nothing has solved it. I tried disabling QuickFolders but that didn't changing anything.

One other thing I tried was renaming my Inbox.msf file (to inbox.msf.bad) to get Thunderbird to recreate it, but at first it wouldn't do so. So I deleted the new Bulletin@organisation account and tried again. It then did recreate it, and my Yahoo account has reappeared, but empty.

Can anyone help?

tanstaafl
Moderator

User avatar
 
Posts: 46573
Joined: July 30th, 2003, 5:06 pm

Post Posted June 29th, 2020, 9:46 am

Does tools -> account settings still list the existence of the yahoo account?

Was the yahoo account a POP or IMAP account? I'm wondering if it was a POP account it was somehow converted to using a global inbox (that hides the accounts folders in the folder pane and uses folders inside the "Local Folders" special account instead).

Does Bulletin@organisation use the commercial version of Gmail (GSuite) as their mail host? The commercial version lets them use their own domain name.

Its usually better to use the repair folder button in a folders properties (right click on the folder name to get the context menu) to rebuild a folder listing, than deleting the *.msf file.

Philip Rayment
 
Posts: 6
Joined: June 28th, 2020, 2:58 am

Post Posted July 1st, 2020, 2:24 am

Thank you. My Yahoo folders have been restored. Your comments gave me a better idea where to look and how things are structured, so I was able to figure it out.

For the benefit of others who this might help...

Yes, the Yahoo account was still there.
Yes, the Yahoo account is POP.
I have no idea if Bulletin@organisation is a GSuite account, but it's quite possible, and sounds like it would explain the GMail login that I had to do.

I hadn't deleted the inbox.msf file, but renamed it so that Thunderbird couldn't find it, so I was able rename it back to inbox.msf. Repair Folder did nothing, but it showed where the folder was pointing, which helped me track down the problem.

Your thought that it was using a global inbox was probably correct. I'm not quite sure what that means, but it fits with what I found.

I had the following folders (most not their real names) under Profiles\molk20np.default\Mail
  • Feeds
  • Local Folders (containing all my Yahoo account folders)
  • mail.isp.com
  • mail.isp.com-1
  • mail.isp.com-2
  • mail.url
  • mail.BulletinOrganisation.com
  • pop.mail.yahoo.com (somehow created by trying to restore the Yahoo account; essentially empty)
  • pop3.isp.net.

In Windows, I took a copy of the (empty) pop.mail.yahoo.com folder and renamed it to Temp Folders.
Also in Windows, I restored the Local Folders>Inbox.msf file (that I had renamed as mentioned above)
In Thunderbird, I went to Account Settings>Local Folders.bad (created as part of the repair attempt)>Server Settings>Local Directory and pointed it to Temp Folders. (I had to do this before the next step.) (Thunderbird had to restart)
I then went to Account Settings>Yahoo account>Server Settings>Local Directory and pointed it to Local Folders. Thunderbird had to restart, and having done so, my Yahoo folders were back! Yay!

I then closed Thunderbird.

In Windows, I renamed the pop.mail.yahoo.com account to pop.mail.yahoo.com.bad, then renamed Local Folders to pop.mail.yahoo.com.

Restarting Thunderbird I went to Account Settings>Yahoo account>Server Settings>Local Directory and pointed it to pop.mail.yahoo.com (the renamed Local Folders).

I was then able to re-add the Bulletin@organisation account, without upsetting the Yahoo one.

Philip Rayment
 
Posts: 6
Joined: June 28th, 2020, 2:58 am

Post Posted July 1st, 2020, 5:03 am

Well, it isn't quite fixed.

My folder structure is (something like) this:
  • @Yahoo
    • Inbox
    • Draft
    • Templates
    • Sent
    • Trash
    • Outbox
    • Folder A
    • Folder B
      • Folder B1
        • Inbox
        • Sent
        • Trash
        • Outbox
        • Folder B1a
        • Folder B12
    • Folder C

All the ones shown in black existed before, and are as expected. The ones shown in red are new.
I can't delete them (the red ones), and when e-mails are downloaded, they go to the red Inbox, not the black one where they should.

The Yahoo account's Inbox is set to "Inbox for this account". So apparently Thunderbird thinks that the red inbox is the Yahoo account's inbox, and I can't find any way to tell it otherwise.
(The black Inbox has all the emails that were in the Yahoo inbox before I had these problems).

Note that Folder B1 is where I originally intended e-mails from Bulletin@organisation to go, so may have done something at that time to cause this.

In doing the steps described in my previous post, I've managed to create an account "Local folders", which Thunderbird now describes as follows: "The following is a special account. There are no identities associated with it." I can rename it, but I'm unable to delete it.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 4 guests