MozillaZine

TB 78.4: Can't email (Peers certificate) and color panes?

User Help for Mozilla Thunderbird
Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 8th, 2020, 9:43 am

Just updated to TB 78.4 and taking Valium as I try to handle all the changes and lost goodies. So, for starters, I have two questions:
1. When trying to email, I get an alert that says that "Peers certificate issuer not recognized...." Selecting OK bring up the Add Security Exception dropdown. This is all new territory for me and I would appreciate knowing how to handle this so that I can get me email to work. BTW, have a MAP setup.
2. I have found that being able to color various elements of TB (like the pane backgrounds and icons) has been very helpful with organization (and aesthetics, I might add). Colors are all gone now. Are there any coloring tweaks that can be applied to 78.4?
Thanks for your help.

EDIT: Just noticed that if i disable my Avast, emails are working. But this is really unacceptable as one does need Avast. So, how can I get.send emails with an active Avast Internet Security?
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

DanRaisch
Moderator

User avatar
 
Posts: 123857
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 8th, 2020, 10:53 am

this is really unacceptable as one does need Avast.

You may not have to totally disable Avast. Try switching off just Avast's Mail Shield as a test.

tanstaafl
Moderator

User avatar
 
Posts: 47156
Joined: July 30th, 2003, 5:06 pm

Post Posted November 8th, 2020, 1:46 pm

1. Its not complaining about the certificate it got from the mail server, per se. Its complaining about the signing certificate (certificate authority) used to authenticate that certificate. You can try setting a security exception (a way to say ignore this security loophole) but I suggest you start by first looking at the SSL certificate (there should be a button in the popup error window to let you see it)and see who the CA is. Then see if its listed by Thunderbird in tools -> options -> privacy & security -> certificates.

Avast roots your certificates. Its possible an automated upgrade to it caused this problem.

2. If you browse the forum you should see threads about how to color things using userChrome.css and/or by installing the colored Folders add-on. There are also some threads about using userChrome.css with the Phoenity icons add-on. Morat has made numerous suggestions such as viewtopic.php?p=14872734#p14872734

One of the latest comments in viewtopic.php?f=39&t=3041329 mentions that the Colored Folders add-on is supposed to be updated to support version 78 within 2 weeks.

3. You should be able to configure Avast to ignore any files in your profile. See https://support.avast.com/en-ww/article ... exclusions

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 9th, 2020, 7:59 am

DanRaisch wrote:
this is really unacceptable as one does need Avast.

You may not have to totally disable Avast. Try switching off just Avast's Mail Shield as a test.


Good try, but didn't work.
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 9th, 2020, 9:12 am

tanstaafl wrote:1. Its not complaining about the certificate it got from the mail server, per se. Its complaining about the signing certificate (certificate authority) used to authenticate that certificate. You can try setting a security exception (a way to say ignore this security loophole) but I suggest you start by first looking at the SSL certificate (there should be a button in the popup error window to let you see it)and see who the CA is. Then see if its listed by Thunderbird in tools -> options -> privacy & security -> certificates.

Setting an exception for TB didn't work. But I may have done it wrong. I chose the pathway Program File (86)>Mozilla Thunderbird. Perhaps I should have chosen thunderbird.exe or maybe the TB profile? Would appreciate knowing just what should be entered as the exception. Furthermore, the alert did say that I had to get smtp.comcast.net:465 and when I clicked Confirm (and yes, it was already in TB's Certificates) I was then able to send email...BUT, the email couldn't be saved into the sending folder's account, but rather it had to go into Local folder. This was due to "...network or file access error." How can this be fixed?

OK, got things sort of working, but not fully the way it should. Hope you can direct me to getting things back to normal.

As for coloring panes and such, I'm going to hold off for a while until this email issue is solved. But, I think I may have enough info on the coloring to go forward when ready.


Avast roots your certificates. Its possible an automated upgrade to it caused this problem.

2. If you browse the forum you should see threads about how to color things using userChrome.css and/or by installing the colored Folders add-on. There are also some threads about using userChrome.css with the Phoenity icons add-on. Morat has made numerous suggestions such as viewtopic.php?p=14872734#p14872734

One of the latest comments in viewtopic.php?f=39&t=3041329 mentions that the Colored Folders add-on is supposed to be updated to support version 78 within 2 weeks.

3. You should be able to configure Avast to ignore any files in your profile. See https://support.avast.com/en-ww/article ... exclusions
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 9th, 2020, 11:49 am

More information. At present I am able to send email out to others and I can send and receive email between my own two TB accounts. But, the emails that I send are being stored in the Local Folder's folders (Sent-acct 1 name and Sent-Acct 2 name...I did not set up these folders, but they appeared automatically) and not in their acct Sent folders. Also of note, is when I click on either accts' In or Sent folders, the hour icon appears everywhere in the screen except when in the Message pane. Hour icon does not appear when selecting anything in the Local folders. Hope some of this new info help towards a solution.
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

tanstaafl
Moderator

User avatar
 
Posts: 47156
Joined: July 30th, 2003, 5:06 pm

Post Posted November 9th, 2020, 1:03 pm

If your new mail is showing up in Local Folders either you are using message filters to move it there or you are actually using POP accounts configured to use a global inbox despite thinking you are using IMAP accounts.

I suggest you copy & paste JUST the mail & news accounts section from help -> troubleshooting information to clarify what your setup is.

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 10th, 2020, 7:02 am

tanstaafl wrote:If your new mail is showing up in Local Folders either you are using message filters to move it there or you are actually using POP accounts configured to use a global inbox despite thinking you are using IMAP accounts.

I suggest you copy & paste JUST the mail & news accounts section from help -> troubleshooting information to clarify what your setup is.


Sorry Tanstaafl, but I have to disagree with you. Double checking my two accts, they are both IMAP. Also, for both of these accts, Connection Security=STARTTLS, Port=143, Authentication=Normal; and for outgoing SMTP, Port=465, Connection Security=SSL/TLS, Authentication=Normal. All these setting were working flawlessly until I upgraded to TB v 78.4.

Also, I just noticed that in there is a tab in TB labeled "Certificate for smtp.comcast.net" that does contain such certificate. I'm not sure how it got to to be there, but I think I may have downloaded it. However, I don't know what to do with it , now?
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

tanstaafl
Moderator

User avatar
 
Posts: 47156
Joined: July 30th, 2003, 5:06 pm

Post Posted November 10th, 2020, 8:35 am

I have a Comcast IMAP account and have no problem reading new mail in it or sending mail from it using TB 78.4.*. It uses imap.comcast.net and smtp.comcast.net . I think they use certificates issued by Comodo.

Where do you see the "tab in TB labeled "Certificate for smtp.comcast.net""?

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 10th, 2020, 10:41 am

tanstaafl wrote:I have a Comcast IMAP account and have no problem reading new mail in it or sending mail from it using TB 78.4.*. It uses imap.comcast.net and smtp.comcast.net . I think they use certificates issued by Comodo.

Where do you see the "tab in TB labeled "Certificate for smtp.comcast.net""?

The tab is on top,following my Inbox tab. Certainly would like to know more about it.
Good news! Everything is working properly, now. I'm not sure what happened, but here's what I think (remember):
The posted problem may not have been with TB 78.4, but with TB 78.2 as I just updated to 78.4 (sorry about that). As you know, when I was trying to send an email, I was getting an alert that a certificate was not being recognized. After clicking OK on that alert, another dropdown appeared that was directing me to confirm a certificate. Initially, I was not correctly answering that dropdown. But, I think I just did, and now all is working properly.
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 21st, 2020, 2:20 pm

Just updated to TB 78.5 and now having the same problem with certificates, got the dropdown asking about certificates. This time I clicked "confirm the certificate" and the email was sent. However, the copy was again being saved in Local Sent(under sender's name) and not in the regular Sent box of the sender ("Your message was sent but a copy was not placed in your sent folder (Sent) due to network or file access errors.") As far as I know, nothing has been changed (not the network or file settings) other than the update. So, how should this be handled? Thanks.
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

tanstaafl
Moderator

User avatar
 
Posts: 47156
Joined: July 30th, 2003, 5:06 pm

Post Posted November 21st, 2020, 6:37 pm

I just sent myself another message from my comcast account to my fastmail account using 78.5 with no problems. I suspect you're running into problems due to smtp.comcast.net getting remapped to a different local server (due to your being in Florida while I'm in NH). I appeared to use

IP='96.114.154.171', Host='resqmta-po-12v.sys.comcast.net'

I figured that out by looking at some custom headers that the email provider added for the account I sent the message to. https://postmaster.comcast.net/outbound ... rvers.html lists Comcast's smtp servers. I suggest you try a different one. Have you tried calling comcast and asking them to identify what smtp server you would use and to check the certificate for it?

Occasional account specific problems uploading a saved copy of a sent message is probably not a Thunderbird bug, its probably a problem with the IMAP server (overloaded, poor connection or whatever). I used to have that problem frequently with just my fastmail account. My workaround was to disable copies& folders saving a copy and logging into webmail and configuring it to have the smtp server save a copy for me. Not only did that solve the problem it was quicker since it cut the amount of data Thunderbird sent in half. Browse the webmail settings and see if you can find something like that.

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 22nd, 2020, 7:22 am

tanstaafl wrote:I just sent myself another message from my comcast account to my fastmail account using 78.5 with no problems. I suspect you're running into problems due to smtp.comcast.net getting remapped to a different local server (due to your being in Florida while I'm in NH). I appeared to use

IP='96.114.154.171', Host='resqmta-po-12v.sys.comcast.net'

I figured that out by looking at some custom headers that the email provider added for the account I sent the message to. https://postmaster.comcast.net/outbound ... rvers.html lists Comcast's smtp servers. I suggest you try a different one. Have you tried calling comcast and asking them to identify what smtp server you would use and to check the certificate for it?

Occasional account specific problems uploading a saved copy of a sent message is probably not a Thunderbird bug, its probably a problem with the IMAP server (overloaded, poor connection or whatever). I used to have that problem frequently with just my fastmail account. My workaround was to disable copies& folders saving a copy and logging into webmail and configuring it to have the smtp server save a copy for me. Not only did that solve the problem it was quicker since it cut the amount of data Thunderbird sent in half. Browse the webmail settings and see if you can find something like that.


Ah, yes, living in Floridah could be part of the problem.
Good suggestion about calling Comcast...will do.
Interestingly, this morning when I opened TB, there were no new messages. But, when I ran a test sending myself messages and having my wife send me messages, things sort of returned to normal. Specifically, I had to again confirm a certificate when sending out, but this seemed to give the OK for my receiving email that had apparently been blocked until the certificate was confirmed? Furthermore, your pointing out possible problems with IMAP server being overloaded may have been right as copies of the emails I send were directly sent to their appropriate Sent Boxes.

How about this to handle the recurring certificates issue: Options>Privacy & Security>Certificates>Select one automatically? At present, it is set to "Ask me every time." I really don't know much about certificates, so this is just a guess and I haven't done it yet. What do you think?
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

tanstaafl
Moderator

User avatar
 
Posts: 47156
Joined: July 30th, 2003, 5:06 pm

Post Posted November 22nd, 2020, 12:46 pm

You don't need a personal certificate to make a SSL connection. You use a SSL certificate fetched from the mail server instead. Its unclear exactly what that menu item is referring to but I'd suspect it involves either S/MIME or OpenPGP , neither of which you appear to be using.

Flycaster

User avatar
 
Posts: 996
Joined: November 19th, 2008, 12:13 pm
Location: Boynton Beach, FL

Post Posted November 22nd, 2020, 2:32 pm

tanstaafl wrote:You don't need a personal certificate to make a SSL connection. You use a SSL certificate fetched from the mail server instead. Its unclear exactly what that menu item is referring to but I'd suspect it involves either S/MIME or OpenPGP , neither of which you appear to be using.


Correct, not only don't I know what they are, but of course, I don't use them. Don't really know anything about certificate, nor about SSL; but, what does this mean in terms of what I am supposed to be doing?
Windows 10 H 64-bit, Quantum The Latest, Chrome v84, Edge v84, Thunderbird The Latest, Avast Premium Security v20.6

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 15 guests