MozillaZine

Why Gmail sent messages go to Thunderbird Inbox

User Help for Mozilla Thunderbird
martachka
 
Posts: 2
Joined: September 30th, 2005, 11:07 am

Post Posted September 30th, 2005, 11:13 am

I am downloading my gmail messages to thunderbird for the first time. why do the sent messages and drafts go to the inbox? How can i get them to go to their proper folders in THunderbird?

AquaDyne

User avatar
 
Posts: 229
Joined: August 14th, 2005, 1:36 pm
Location: Al Asad, Iraq

Post Posted September 30th, 2005, 11:59 am

Martachka,

As a gmail user, I'm experiencing the same frustration. Mail messages you send *from* the web-client end up in your in-box.

You can create a filter to look for messages sent "from" your gmail address, and have those get filed in the sent items while downloading from the POP client.
Firefox/2.0 RC1 (20060918)

tanstaafl
Moderator

User avatar
 
Posts: 45671
Joined: July 30th, 2003, 5:06 pm

Post Posted September 30th, 2005, 4:16 pm

I see the same problem when sending from gmail webmail. The POP server shouldn't see that message since its in the sent folder. I assume just like they replace whatever From: address you supply when sending mail using thier SMTP server this an another oddity of gmail. I don't see it with other POP servers.

If you send from a gmail account in Thunderbird it works as expected.

Guest
Guest
 

Post Posted February 10th, 2009, 3:03 am

The issue is here:

goto Thunderbird> Tools> Account Settings> Server Settings> Advanced>

"When downloading POP3 mail from this server, use the following folder for new email:"

the 3 choices are ALL inboxes...

"Inbox for this server's account
Global Inbox (Local Folders Account)
Inbox for different account

Thunderbird downloads all "incoming" email as "inbox" email, so after you have sent an email using (any) webmail service, Thunderbird sees this new email and says "hey i have to download that" and so sends it to an inbox as configured.


It is easilly fixed, much quicker than most email clients, just reconfigure the filter rules.....

goto Thunderbird>

goto the inbox and select an email you want moved

goto Message> Create Filter From Message>

"Filter Name:" is <email address>, if you have never setup a filter rule before then it may already be shown (it is for me as i write this article and discover the fix)

set:
"For incoming messages that:"

to
"Match any of the following"
From + is + <email address>


set:
"Perform these actions:"

to
"Move Message to" + set the second dropdown to your sent items folder

click OK


now to run it for the first time:

goto Tools> Run Filters on Folder

then next time you open Thunderbird the filter will work automatically.

to prove it, close Thunderbird, open gmail, or other webmail service :)
send a test email to a different email address (maybe a friend).
close or logout of webmail.
open Thunderbird, notice your sent items will show (1) new sent item :)

Daifne
Moderator

User avatar
 
Posts: 123056
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted February 10th, 2009, 8:13 am

1. Er, did you look at the date of this topic? 2005 is rather a long time ago.

2. This solution doesn't work for GMail, at least not for me. Those GMail sent messages simply won't move.

3. Because this is so ancient, I'm locking this.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests