Importing mbox file

User Help for Mozilla Thunderbird

Post Posted December 8th, 2003, 4:28 am

I have Ximian evolution on my Linux machine and use Outlook Express on the WIndows machine and decided to install Thunderbird on the Windows machine and put ALL my mail there. I.e. I don't want to use Evolution anymore.

Installing Thunderbird on the Windows machine and importing the OE mail was a breeze. But I have been trying for hours to import the Evolution mail and still no luck.

Here's what I've done so far:
- the evolution mail is in a file that's in mbox format. It is called 'mbox' and has no extension.
- I mailed this file to the Windows machine and saved 'mbox' someplace convenient.
- I copied this file to the Profiles\default\somethingorother.slt\Mail\local folders, just like it says here: ... ml#oh-yeah
- Sure enough, it showed up as a folder in the local folders in Thunderbird after that. But there is nothing in it. I can clearly see that there IS someting in the file when I open it in a text editor.

I would be very grateful for any suggestions.

Regards, Iris


User avatar
Posts: 225
Joined: May 27th, 2003, 5:58 pm

Post Posted December 8th, 2003, 8:46 am

Check that the folder is set to View - All firstly
User-Agent: Thunderbird/2.0 Alpha 1 0808



Post Posted December 8th, 2003, 1:40 pm

I checked, it's set to 'All'.


Post Posted December 17th, 2003, 2:53 am

I have finally found the solution to this problem and I thought I'd share it with you all. Seems kind of weird though, so maybe someone has a better solution still.

Do all of this while Thunderbird is not running.

I discovered that in the mbox file I mailed to myself from the Linux machine, every message is preceded by a '>'. Once you delete that, your mail is visible again. You can use 'Search and replace' in any old text editor, but DON'T press 'replace all' or whatever, because forwards inside a message might start with something like <FONT SIZE=3D2 FACE=3D"Tahoma">From:</FONT> and in that case you don't want to delete the '>' because obviously you'll mess up the whole file.

When you're done, save the file again. My editor gave it a .txt extension but you need to delete that. Paste the file into your C:\Documents and Settings\[yourprofile]\Application Data\Thunderbird\Profiles\default\[somethingorother.slt]\Mail\[youaccount] folder, open Thunderbird and voilá.

Return to Thunderbird Support

Who is online

Users browsing this forum: No registered users and 4 guests