MozillaZine

Messages suddenly disapeared.

User Help for Mozilla Thunderbird
pesoliv
 
Posts: 4
Joined: November 11th, 2006, 3:49 pm

Post Posted November 11th, 2006, 7:05 pm

I tried deleting the msf's and compacting all folders, but junk is still empty (though the file is not).
In response to the original question from Zackkkk, could it have something to do with "disk space" under "account settings"? There are options for deleting old messages, maybe you have it enabled.

Matt Johnson
Guest
 

Post Posted November 12th, 2006, 6:13 am

Yes, I am having exactly this problem with 1.5.0.8 as well. Messages are being collected, and, in my case, filtered off to other local folders. However, in some cases (which I cannot identify), the appropriate folder in the 'Folders' pane is being emboldened, but without a number to indicate the number of new messages in the folder. Going into the folder in TB does not show new messages, but examining the raw folder file in a text editor shows that messages do exist in the file with X-Mozilla-Status: 0000, as one would expect of a new/unread message.

Matt Johnson
Guest
 

Post Posted November 12th, 2006, 6:14 am

To add:

- this only happens to newly-delivered messages
- I have tried deleting/rebuilding the MSFs and compacting the folders (several times)

Kab
 
Posts: 1095
Joined: April 17th, 2006, 11:52 pm

Post Posted November 12th, 2006, 6:23 am

Easy way would be to uninstall Thunderbird the program and remove the Program Files folder of it completely, then download a new version and install it. Thunderbird will automatically pick up your old profile and its settings and nothing can be deleted there as its kept far away.

This way one could tell if its something with the program files, MTA or your profile/inbox itself.

Matt Johnson
Guest
 

Post Posted November 12th, 2006, 6:41 am

Afraid I've already been through this dance (uninstall / reinstall / new profile) and no changes. It also permeates multiple ISP mailboxes.

Therefore I think it is a bug in 1.5.0.8. So I'm downgrading to 1.5.0.7... folks in #thunderbird agree with me at the moment...

Matt Johnson
Guest
 

Post Posted November 12th, 2006, 6:47 am

Downgrading to 1.5.0.7, deleting the MSF of a folder with "hidden messages" and having 1.5.0.7 rebuild the MSF caused the hidden messages to appear.

So I think there is a bug in MSF generation in 1.5.0.8.

RedCardinal
 
Posts: 14
Joined: November 12th, 2006, 8:22 am

Post Posted November 12th, 2006, 8:27 am

Having the same issues.

To me this must be an absolutely critical flaw - I am losing confidence in the integrity of my data because I am seeing countess alerts to new mail, yet finding nothing displayed in the folders.

I compact my folders regularly (~ every 2weeks) and have done so today. I have also deleted the .msf files and rebuilt the indices.

I am particularly concerned that compacting may actually have deleted any new mails that were afflicted by this issue.

Unfortunately for me downgrading hasn't fixed the issue, which leads me to believe that compacting may have made issues worse.

ub-net
Guest
 

Post Posted November 12th, 2006, 8:35 am

RedCardinal, I completely share your feelings about the integrity of the inbox. I just downloaded 7 messages, but only 3 were shown. As Matt suggested, I downgraded to 1.5.0.7 and deleted the msf, and all messages reappeared. Sorry to say, but 1.5.0.8 is really unusable for me :-(

Uwe

Kab
 
Posts: 1095
Joined: April 17th, 2006, 11:52 pm

Post Posted November 12th, 2006, 8:48 am

Firstly when you uninstalled and reinstalled did you delete the old folder in Program Files?

If you didn't you haven't done it properly and you would need to do another reinstall.

Why would you downgrade and be able to see them all if your profile is corrupt?

If the rebuilding .msf's was the problem it would have been sorted out in the version you have, its independent of versions and relies on your profile.

Do you compact your folders regularly i.e. near enough every use?

Do you keep your inbox empty after viewing the emails and save them in other folders so that it doesn't become corrupted and hence you don't loose all?

This is exactly whats recommended everyday here and in the KB instructions.

I think your profiles maybe corrupt. The .msf are "mail summary files" only and carry no data. They are specific to your profiles.

ub-net
Guest
 

Post Posted November 12th, 2006, 9:00 am

Deleting and rebuilding the msf in 1.5.0.8 will not help, the messages stay hidden. With a text editor, I have created a small inbox test file. If you feed it to 1.5.0.8 (without msf file), it will show only 2 out of 3 messages, whereas 1.5.0.7 will show all of them. That has nothing to do with the profile, it must be a severe bug in the msf generation of 1.5.0.8!

Uwe

Lost User 32452
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 12th, 2006, 9:14 am

I seem to have a similar problem. I get an alert that I have mail, but when I check my accounts, no new mail is shown. However, the last time it happened I was able to check the my webmail for that account there were two junk emails that would normally have been downloaded by Thunderbird. Since it was junk mail, I checked my Junk Mail Controls and the only recent change I can recall making was to check the "Check junk mail headers sent by: -- SpamAssassin" I believe this is a recent addition to Thunderbird, i.e., 1.5.0.8, and although one would think it should handle junk mail according to the "Handling" instructions, may be it just deletes them. I have now unchecked the "Check junk mail headers sent by: -- SpamAssassin" and will see if that makes a difference.

RedCardinal
 
Posts: 14
Joined: November 12th, 2006, 8:22 am

Post Posted November 12th, 2006, 10:26 am

The 'Check junk mail headers' function - does anybody know the default behaviour?

Could this be causing the problems?

ub-net
Guest
 

Post Posted November 12th, 2006, 10:39 am

I had that function unchecked in the settings, but maybe the default behavior is to hide messages it thinks are spam.

mbenitez
 
Posts: 2
Joined: November 11th, 2006, 9:31 pm

Post Posted November 12th, 2006, 12:31 pm

Hi, I accidentally deleted a profile AFTER I had downloaded my emails from yahoo. I am using tbird 1.5.0.8. I d/l or rather looked to d/l mozbackup but can't find working link for d/l. I thought I had set up tbird to keep messages on server. apparently not as no email at yahoo. :( I tried to d/l prog that would allow me to bounce? emails back to yahoo but to no avail... I've managed to find my mailboxes in comp but none have the missing emails. If I have posted at incorrect forum I am so sorry .. thanik you for your help in acvance

pesoliv
 
Posts: 4
Joined: November 11th, 2006, 3:49 pm

Post Posted November 12th, 2006, 1:53 pm

Downgraded to 1.5.0.7 and the problem is solved. Must be a bug in 1.5.0.8
Turns out the messages were not being sent to junk, the missing messages all appeared in my inbox. But my junk folder had become corrupted as well - perhaps also due to the bug in 1.5.0.8 - so I just deleted it (hopefully it was all actually junk). I've now turned off automatic updates so as not to run into another problem like this.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 6 guests