MozillaZine

Mozilla Thunderbird 2 Beta 2 Feedback Thread

User Help for Mozilla Thunderbird
Hobbsee
 
Posts: 19
Joined: February 21st, 2005, 4:41 am

Post Posted January 26th, 2007, 9:14 pm

The one bug i've spotted is that you cant drag and drop a mail from one folder to another anymore. (in imap mail, may be in pop3 too).

I'll have to find my login to bugzilla at some point...

christos

User avatar
 
Posts: 126
Joined: September 5th, 2003, 5:42 pm
Location: Geneva

Post Posted January 27th, 2007, 3:18 pm

Ldz_blade wrote:I'm French canadian, and everytime I post a message (even though I have Thunderbird in French and my Hotmail is in french, my french accents become weird characters or, other times, juste don't show.

Please fix this!

Simon


Did you try View->Characted encoding-> Your favorite option?

You can even set this property for individual folders.

mkmelin
 
Posts: 291
Joined: October 13th, 2003, 1:30 pm
Location: Finland

Post Posted January 28th, 2007, 9:03 am

tomgally wrote:And there's a new problem. According to the announcement for Beta 2, the IMAP quota is supposed to appear in the status bar. I didn't see anything for a couple of days, and then this morning it appeared for a while together with messages, which had to be repeatedly dismissed before they would go away for good, telling me that I was at 94% of my quota. (Which seemed strange, as I had been at 55% the day before and hadn't received or sent any huge mail that I can recall.) In any case, I cleared out some my e-mail boxes and reduced the quota, as shown in the Properties window, to 64%. But now the quota no longer appears in the status bar.

That's expected, the quota is only shown when you are over a threshold, you can adjust the threshold using the mail.quota.mainwindow_threshold.<xxx> values.

Jestre

User avatar
 
Posts: 48
Joined: December 8th, 2003, 9:39 am
Location: Detroit

Post Posted January 28th, 2007, 9:08 am

Hobbsee wrote:The one bug i've spotted is that you cant drag and drop a mail from one folder to another anymore. (in imap mail, may be in pop3 too).

I'll have to find my login to bugzilla at some point...


I can confirm this as well.
It will work initially but after several manual moves and/or the spam & message filters running and moving, it will stop allowing additional move or file commands of any sort.
This means any of the moves stop working here is a list of the ones I tested:
- the 'junk mail filter' 'move to Junk' setting
- the configurable 'message filters', 'move to' command
- 'drag and drop' with mouse
- 'move' from the menu
- and 'file to' from the toolbar

A restart seems to correct this however, at least for a while.
It appears to be sensitive to the quantity of moves and especially multiple simultaneous moves occurring.
A group of under 50 emails usually won't cause this problem but 300+ new emails almost always will inhibit further move commands.

A 'get all new messages' for multiple accounts with 'move to' message filters present is a good test case.

Jestre
Don't kick the monster!
Program a robot to smash it, Shoot it, Spear it or even Throw something at it (preferably a grenade), but NEVER kick the monster!
NOTE: does not apply to BLACK BELTS.

ScannerDesk

User avatar
 
Posts: 22
Joined: June 27th, 2004, 7:20 am

Post Posted January 28th, 2007, 12:30 pm

I installed the release and now the messages I tag as spam don't move to the spam folder.

Is it just me or is anyone lese having this isse???

johann_p

User avatar
 
Posts: 8479
Joined: November 5th, 2002, 3:05 am
Location: Sheffield, UK

Post Posted January 28th, 2007, 12:51 pm

johann_p wrote:
johann_p wrote:
Thanks for that, but I am especially interested in the other part -- how to "store custom fields in the mail database" -- I had been looking for a proper metadata-API for some time now and would be interested to see if this is what I was missing.
So, what is this "custom fields in the mail database" feature and is there a documentation for this too?


Sorry to repeat myself here, but I could not find anything about the backend for storing arbitrary metadata with messages, as the release notes say is possible now.

Is there information somewhere about how to do this and what data can be stored? Is this the right place to ask this question (since the OP was signed by "Team Thunderbird" I assumed they would read this forum ...)


I'd be grateful if anyone (maybe one of those who told about this in the release notes) could either give a bit of information or say that no such information exists. Or maybe tell where else to ask.

How are (future) extension developers supposed to use a feature if nothing can be found out about it?
“Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe.”

NickJH
 
Posts: 415
Joined: November 4th, 2003, 7:28 am
Location: Hampshire, England

Post Posted January 28th, 2007, 1:03 pm

ScannerDesk wrote:I installed the release and now the messages I tag as spam don't move to the spam folder.

Is it just me or is anyone else having this issue???
Tag in what way? I reported an issue with message filters not working correctly when setting the Junk status to Junk earlier on in this thread here, and I filed a bug report accordingly. The bug still remains unconfirmed.

Snowball2050
 
Posts: 1
Joined: January 28th, 2007, 7:57 pm

Post Posted January 28th, 2007, 8:00 pm

Visualcode wrote:I thought they would put this feature back! I am REALLY missing the feature from TB 1.5 which allowed for me to click the notification of new mail to go to my mailbox and view the message. It seems pointless to me to have it pop-up when I can't click to view. Since it goes away fast, it is really only good if you want to view the message right away. If you want to view the message later, I am sure the mail-icon would suffice.

I am curious, why was this feature removed? If users do not want to view the message(s), it is no more in the way to have the link than not. But, if they do want to view them, it is quite annoying having to locate TB in the taskbar, or wait for the notification to leave, so we can click on the mail-icon.


I would love it if this feature came back. I too have been missing it and getting ticked when i click the notification repeatedly and nothing happens. While i know i could wait the 3 seconds for it to disappear and then click on the new mail tray icon, i would prefer to be able to open thunderbird as soon as i get the email.

cityfan

User avatar
 
Posts: 272
Joined: August 11th, 2003, 1:04 pm
Location: Ventura County, California

Post Posted January 28th, 2007, 10:34 pm

NickJH wrote:
ScannerDesk wrote:I installed the release and now the messages I tag as spam don't move to the spam folder.

Is it just me or is anyone else having this issue???
Tag in what way? I reported an issue with message filters not working correctly when setting the Junk status to Junk earlier on in this thread here, and I filed a bug report accordingly. The bug still remains unconfirmed.


I confirm that I too get this problem this problem in beta 2.
Also, I have a filter set up to move the message, mark it as junk and mark is as read.
If I remove the mark as read, then the message does not get moved to the junk.

There seems to be a few things wrong in this area of marking messages as junk

matp75
 
Posts: 8
Joined: January 29th, 2007, 10:47 am

Post Posted January 29th, 2007, 11:01 am

I'm using multiple identities with the same account.
With thunderbird 1.5, when I replied to an email, it was using the correct email when replying.
With 2.0b2, it no longer works. I have to manually choose the right from.

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted January 29th, 2007, 1:22 pm

matp75 wrote:I'm using multiple identities with the same account.
With thunderbird 1.5, when I replied to an email, it was using the correct email when replying.
With 2.0b2, it no longer works. I have to manually choose the right from.


I use multiple identities on the same account too and this seems to still be working for me. I'm on Windows for what it is worth.
Thunderbirds are Go!

elart

User avatar
 
Posts: 50
Joined: July 30th, 2005, 7:03 am
Location: Italy

Post Posted January 29th, 2007, 3:02 pm

Thunderbird message list alternate color
On bright lcd monitors default alternate colors are too similar, with default setting there is not a good visual difference for messages rows.
Can you put a new, better, alternate color defaults...?

I'm little tired of customize them via userChrome.css

Go Thunderbird Go

matp75
 
Posts: 8
Joined: January 29th, 2007, 10:47 am

Post Posted January 29th, 2007, 3:55 pm

mscott wrote:
matp75 wrote:I'm using multiple identities with the same account.
With thunderbird 1.5, when I replied to an email, it was using the correct email when replying.
With 2.0b2, it no longer works. I have to manually choose the right from.


I use multiple identities on the same account too and this seems to still be working for me. I'm on Windows for what it is worth.

that's very strange.
it works now and I'm pretty sure it didn't work a few hours ago...
the only case it still doesn't work is answering a yahoo list but I'm not sure this case worked with thunderbird 1.5
Does thunderbird use X-Original-To: when it replies ?

volsungs
 
Posts: 4
Joined: January 25th, 2005, 9:42 am
Location: NY

Post Posted January 29th, 2007, 5:36 pm

I continue to have a problem using LDAP over SSL in the address book in Thunderbird 2 Beta 2. Specifically, after using the address book, I close the program and receive this error: "The operation cannot be completed because of an internal failure. A secure network communication has not been cleaned up correctly." This bug is detailed in Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=206018. It is marked as fixed in trunk 1.8.1. Maybe I don't understand the trunk system, but shouldn't this bug be fixed in the latest beta, particularly since there is a patch?

Thanks.

Beta 2 is otherwise looking great. I've had no problems with it so far.

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted January 29th, 2007, 6:16 pm

johann_p wrote:
Sorry to repeat myself here, but I could not find anything about the backend for storing arbitrary metadata with messages, as the release notes say is possible now.

Is there information somewhere about how to do this and what data can be stored? Is this the right place to ask this question (since the OP was signed by "Team Thunderbird" I assumed they would read this forum ...)


Johann, we need someone to help write the documentation for this feature. It should be really short and it would be awesome if you could write a small page and then cite it in the document that talks about creating custom columns in the message list pane.

Here's the bug that talks about how this feature works:

https://bugzilla.mozilla.org/show_bug.cgi?id=356860

it's pretty easy, the extension just needs to set a space delimited of headers (all in lower case) that the extension wants stored in the database.

The details are in the bug. If you could help get that started it would be greatly appreciated!

Thanks.
Thunderbirds are Go!

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 8 guests