MozillaZine

Mail link doesn't open to browser

User Help for Mozilla Thunderbird
neekole
Guest
 

Post Posted February 10th, 2004, 11:03 pm

Whenever I click on a link in Thunderbird, it treats the .htm like an attachment. When I select it to launch the .htm in my browser (FireFox), it doesn't go to the site, but instead goes to the local file (file://blabla/nameofsite.htm").

I don't know if this is a FireFox issue, or a ThunderBird issue. Help?


Nicole

mscott

User avatar
 
Posts: 2516
Joined: April 2nd, 2003, 4:10 pm
Location: Thunderbird Research Center, CA

Post Posted February 11th, 2004, 12:12 am

In firefox:

Tools / Options / Make default browser

this happens when the OS no longer knows what your default browser is. This is also mentioned in the thunderbird release notes under Known Issues with this tip.
Thunderbirds are Go!

d00gs
 
Posts: 467
Joined: December 15th, 2003, 6:17 pm

Post Posted February 11th, 2004, 11:48 am

I have the same problem, and that doesn't help. I couldn't find that in the release notes, either.

I'm under WinXP, and my "Internet" shortcut in the start bar does show Firefox...
The sooner you fall behind, the longer you have to catch up.

muhKuh
 
Posts: 47
Joined: November 27th, 2003, 9:46 pm

Post Posted February 11th, 2004, 2:55 pm

thx for the help ... i personally dont like to hit this "make it my standard app"-button coz i hate every page and image showing the FF logo or whatever app is registering some extensions ... but Zaknafein47 id also recommend u to go into Explorer >> Extras >> Folder Options >> Filtetypes and change the registered app for http urls and of cause for htm(l) since this make-standard-button seems to refuse to work for you

muuuu

d00gs
 
Posts: 467
Joined: December 15th, 2003, 6:17 pm

Post Posted February 11th, 2004, 5:52 pm

Done that too...or, at least out of contral panel -> folder options -> file types
The sooner you fall behind, the longer you have to catch up.

muhKuh
 
Posts: 47
Joined: November 27th, 2003, 9:46 pm

Post Posted February 11th, 2004, 11:47 pm

open InternetExplorer and save a bookmark of some page to the desktop then click it ... whats happening?
or click on a link inside OutlookExress [if its installed]

in booth cases FF should take over control

PeterR
 
Posts: 51
Joined: February 12th, 2004, 12:29 am
Location: USA

Post Posted February 12th, 2004, 2:12 pm

I'm running TB and FF on RedHat 8 and have the same problem. However, I don't see a "Make default browser" option in FF.

PeterR
 
Posts: 51
Joined: February 12th, 2004, 12:29 am
Location: USA

Post Posted February 12th, 2004, 2:32 pm

Ah, found the Linux solution:

http://www.mozilla.org/projects/thunder ... xurls.html

Works great and you can still have some other browser as default if you want.

d00gs
 
Posts: 467
Joined: December 15th, 2003, 6:17 pm

Post Posted February 12th, 2004, 6:15 pm

Yeah, but that doesn't work on WinXP :(
The sooner you fall behind, the longer you have to catch up.

muhKuh
 
Posts: 47
Joined: November 27th, 2003, 9:46 pm

Post Posted February 12th, 2004, 11:43 pm

did u try what i told ya to do?

jgross
 
Posts: 7
Joined: February 11th, 2004, 11:34 am
Location: Pennsylvania, USA

Post Posted February 13th, 2004, 12:07 am

I have almost identical problem on TB 0.5. Did Clean install, no profile migration. FF 0.8 works beautifully and ONLY problem w/TB is when I click e-mail links that appear to first require confirmation I'm an authorized user for the target webpage. This happens on New York Times site (www.nyt.com). FF launches when link is clicked but loads a login page as a file:/// in my tmp directory. Authorization fails cause system tries to search my /tmp for NYT database. I've been able to confirm that the link format first initiates an authorization confirmation which fails w/TB (I think because there is no cookie access?). If I enter the link directly into FF it works perfectly. This didn't happen w/Moz 1.6. And the reference from PeterR above doesn't solve the problem, already tried it. In my case, I'm thinking that TB has been disconnected from whatever the old way of allowing access to cookies was. I'm open to any suggestions and will help debug if anybody has ideas.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Mozilla Thunderbird 0.5 (20040208)
Asus A7N8X-X, Athlon 2800+, 512M, Leadtek A350TDH,
Logitech MX-700, Viewsonic VX900, Mandrake 9.1, Fluxbox


KevinC
 
Posts: 48
Joined: July 23rd, 2003, 8:38 am

Post Posted February 13th, 2004, 5:55 am

Dunderklumpen, thanks for those links, but I'm having the same problem and none of those address the issue.

Note: I only noticed this problem when I installed FireFox.

If you chose the open this with default application(htmlfile) nothing happens.
If you chose to open it with another application, it actually opens a cached file of the page on your computer.

This is pretty annoying. :(

jgross
 
Posts: 7
Joined: February 11th, 2004, 11:34 am
Location: Pennsylvania, USA

Post Posted February 13th, 2004, 9:45 am

Dunderklumpen's links didn't help me either under Linux. SO, I cleared all caches, shut down my DSL and ran dialup, which was slow and let me capture some info. When this link clicked from a TB e-mail:
http://www.nytimes.com/2004/02/11/polit ... EC.html?th

This page appears to download:
http://www.nytimes.com/auth/login?URI=h ... html&OQ=th

Then FF loads it with this path:
file:///home/john/tmp/login (I confirmed w/script capture this is actually the url passed to FF)

Which is a NYT registration/login page which is downloaded and cached. Clicking on login fails because links have apparently been rereferenced to my temp directory which of course won't work. Subsequent error message again mentions a path to my /tmp directory. I might consider this an NYT html problem EXCEPT:

When first link is entered into FF location bar AND I'm logged into NYT site then I go directly to webpage. When entered into location bar AND not logged into site then I get the registration/login webpage, BUT THE PATH IS CORRECTLY THE NYT LINK above and clicking on login produces success and you go to webpage. Means to me that FF and the NYT code is probably OK.

Second case is when I received an e-mail from MozillaZine this morn indicating activity on this thread. When I clicked:
http://forums.mozillazine.org/viewtopic ... 808#376808

The following page was loaded:
file:///home/john/tmp/viewtopic.php

The links on the MozillaZine page are rereferenced, eg, the "MozillaZine Forum Index" link in top left corner of page is now:
file:///home/john/tmp/index.php?sid=4350ecd519fb3bc0f94e23b18da38f8f

I never get prompted to tell TB how to handle the php file (which is opened by FF) BUT I DID GET PROMPTED on how to handle html file. The attachments config option in TB doesn't allow manual entry of helper apps only editing of ones already in list. The problem here doesn't appear to be passing a url to FF and launching it, that works. The problem seems to be that "under certain conditions" the wrong urls are being passed. I'm thinking that the initial request for a page is correctly sent to the website but "under certain conditions" TB is altering the url passed to FF.

Do you guys think this is a problem/bug or do you think my head is in a dark place? I can handle suggestions, criticism, whatever. I'm about ready to submit to Bugzilla.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Mozilla Thunderbird 0.5 (20040208)
Asus A7N8X-X, Athlon 2800+, 512M, Leadtek A350TDH,
Logitech MX-700, Viewsonic VX900, Mandrake 9.1, Fluxbox

lefiii
 
Posts: 5
Joined: February 15th, 2004, 8:15 am

Post Posted February 15th, 2004, 8:56 am

Does anyone know how to do this for the MAC OSX???

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 7 guests