MozillaZine

How to change thunderbird language to english?

User Help for Mozilla Thunderbird
kramer65
 
Posts: 14
Joined: December 16th, 2004, 4:13 pm

Post Posted April 10th, 2007, 12:41 am

Hi,

I have ubuntu with thunderbird running smoothly. But it is (like my whoile system) iinstalled in Dutch. This is my mother language, so not a problem there. But when I reply to email it says something like "the other person SCHREEF (= "wrote" in Dutch). Since I mainly use it for my website I have the majority of my emails in English. How do I change this back to english so I don't have to constantly change it back manually?

I hope somebody can help me!

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted April 10th, 2007, 12:56 am

Rod

kramer65
 
Posts: 14
Joined: December 16th, 2004, 4:13 pm

Post Posted April 10th, 2007, 1:04 am

Alright thanks. I can find the preferences menu, but where do I change this "mailnews.reply_header_authorwrote" to what I want? I can't find where to change it..? I also tried to search for the userContent.css file but I can't find it..

Any suggestions?

Freee!!

User avatar
 
Posts: 15562
Joined: January 28th, 2005, 5:52 am
Location: Home, with my son!

Post Posted April 10th, 2007, 3:16 am

I suggest you try the Chromedit2 extension. I don't know if it works under Linux, but under Windows it will create the optional files userContent.css, userChrome.css and user.js in the correct location when necessary.

As for the header, insert the following code into the (optional) user.js file:
Code: Select all
// Change the reply header
// 0 - No Reply-Text
// 1 - "[Author] wrote:"
// 2 - "On [date] [author] wrote:"
// 3 - User-defined reply header. Use the prefs below in conjuction with this:
user_pref("mailnews.reply_header_type", 3);

// If you set 3 for the pref above then you may set the following prefs.
user_pref("mailnews.reply_header_authorwrote", "%s wrote the following");
user_pref("mailnews.reply_header_ondate", "on %s");
user_pref("mailnews.reply_header_separator", " ");
user_pref("mailnews.reply_header_colon", ":");
// The end result will be [authorwrote][separator][ondate][colon]

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted April 10th, 2007, 6:08 am

You do not need any extension just to change a preference. In the article I referred you to, follow one of the links near the top—preference settings or about:config.

This topic has nothing to do with userContent.css, but if you want to work with it for some other purpose, see its article in the knowledge base: http://kb.mozillazine.org/UserContent.css
Rod

Freee!!

User avatar
 
Posts: 15562
Joined: January 28th, 2005, 5:52 am
Location: Home, with my son!

Post Posted April 10th, 2007, 6:19 am

Rod Whiteley wrote:You do not need any extension just to change a preference.
True, but it sometimes is easier.
And I prefer to change a couple of settings through user.js for which that extension is very convenient.

kramer65
 
Posts: 14
Joined: December 16th, 2004, 4:13 pm

Post Posted April 10th, 2007, 11:32 am

Alright thanks! I just didn't click on about:config! There I found exectly what I needed!

Thanks a lot!


udosoft
Guest
 

Post Posted November 10th, 2009, 11:42 am

Hi,

I have the same problem. (Hungarian->Englisch)

It works for reply, but I have no option by forwarding.
I cannot change the hungarian header by forwarding to Original Message.
I havent find any option.

Do somebody know, how to change it for forwarding mails?

DanRaisch
Moderator

User avatar
 
Posts: 108276
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted November 10th, 2009, 1:07 pm

You have posted to a thread that died out two years ago. Please start a new topic and provide details of the problem you are having, including the version of Thunderbird that you are now using.

Locking this due to the age of the original posts.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 8 guests