MozillaZine

Message Filters not Taging Messages automatically? TB 2.0

User Help for Mozilla Thunderbird
M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted April 23rd, 2007, 7:22 am

I agree, there are obviously some serious problems with the Message Filtering in Thunderbird 2.0. I'm very surprised the software was released. I'm sorry to say, but this feels more like a Beta than a software release... I have never had a problem with Mozilla software like this before, so I'm sure they will correct it pronto, but it almost makes me wonder if they didn't accidentally release the wrong version of the software... The bugs in bugzilla referencing a similar issue with the message filtering are all closed as they were apparently fixed, but I don't see that they were fixed.

This is very frustrating to me, as I really came to rely on the Message Filters in Thunderbird. I may end up going back to 1.5 until the kinks are worked out of 2.0 (Though I would prefer to use a working release of 2.0).

:(

printmkr
 
Posts: 2
Joined: April 23rd, 2007, 10:10 am

Post Posted April 23rd, 2007, 10:14 am

Yes, this filter problem is happening to me also (Mac OSX). It DOES feel like a beta. Is there an easy way to revert to 1.5? I pulled the trigger way too quick on upgrading Thunderbird. I usually never have a problem with Mozilla stuff, either. I guess the testers dropped the ball on this one, or, I have to learn to be more wary of Mozilla upgrades (or both!).

OPaul
 
Posts: 94
Joined: July 31st, 2003, 6:01 pm
Location: Raleigh, NC

Post Posted April 23rd, 2007, 10:21 am

1.5 will install over 2.0.
I have always wished for a computer that would be as easy to use as my telephone. My wish came true. I no longer know how to use my telephone.
--Bjarne Stroustrup

%
Guest
 

Post Posted April 23rd, 2007, 5:10 pm

I went back to 1.5 couple of times; lost 40% of my filters each time, but I don't have very many filters.

catester

User avatar
 
Posts: 24
Joined: December 9th, 2004, 11:06 pm
Location: North of 49

Post Posted April 23rd, 2007, 7:17 pm

Here's something interesting: http://forums.mozillazine.org/viewtopic ... 29#2855529. I tried the suggested workaround, and now my filters run properly. This has been kicking around since 1.5? I thought I had that box checked in 1.5 and I never had this problem.
Cate Eales

"But the coolest part is that the documentation will be delivered by flying pigs!" ~ Dilbert's pointy-haired boss ~

M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted April 24th, 2007, 6:00 am

Thanks for the post, I had that checkbox checked in 1.5 as well, and am aware of that workaround. The reason it is not an acceptable workaround for me is that with quarantining of individual messages disabled, should a virus be found in your incoming mail (And lets face it, in this day and age that is quite likely), you risk losing your ENTIRE mail database. Every message received. Every message sent. Everything.

The risk in this instance is simply not worth the benefit to me. I hope Mozilla fixes this pronto and gets an update out with working Message Filters.

I have installed every .0 version of the various Mozilla Softwares and have never had a problem like this. In fact, I started using Firefox on a Preview Release. No problems... This is simply not up to Mozilla's high standards... This feels like a MS product...lol

OPaul
 
Posts: 94
Joined: July 31st, 2003, 6:01 pm
Location: Raleigh, NC

Post Posted April 24th, 2007, 9:08 am

The date on the release (in Help-->About) was from March, not April. Did that just not get updated?
I have always wished for a computer that would be as easy to use as my telephone. My wish came true. I no longer know how to use my telephone.
--Bjarne Stroustrup

M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted April 24th, 2007, 9:28 am

Yeah, I'm really beginning to wonder if they didn't accidentally release one of the Beta's and not the final release...

It's kind of a funny "Oops" if you think about it, and it would also mean the fix is (hopefully) already ready...

Does anyone from Mozilla visit these forums that would be able to chime in? I'm very curious at this point (And really missing my message tags / filters...).

RDL
 
Posts: 1258
Joined: August 22nd, 2004, 1:39 am

Post Posted April 27th, 2007, 11:23 am

M_Lyons10 wrote:Thanks for the post, I had that checkbox checked in 1.5 as well, and am aware of that workaround. The reason it is not an acceptable workaround for me is that with quarantining of individual messages disabled, should a virus be found in your incoming mail (And lets face it, in this day and age that is quite likely), you risk losing your ENTIRE mail database. Every message received. Every message sent. Everything.

The risk in this instance is simply not worth the benefit to me. I hope Mozilla fixes this pronto and gets an update out with working Message Filters.

I have installed every .0 version of the various Mozilla Softwares and have never had a problem like this. In fact, I started using Firefox on a Preview Release. No problems... This is simply not up to Mozilla's high standards... This feels like a MS product...lol

I quite agree. TB used to have 'label' (tag) problems at every release but they seemed to have been mainly fixed until 2.0.0.0.

I tried upgrading yesterday, hit this problem and, rather than risk having a whole mail file quarantined, reverted to 1.5.0.10. I shall try to avoid 2.x until this problem is fixed.

To try to encourage an early fix, please vote for both these two bugs on Mozilla Bugzilla

377541

and

324467

Don't bother to add any posts there - that just gets called spam.

Instead, first make sure you're registered with them ("New Account" at top or bottom of the bug page there)

then re-display the bug if needed and you will see a link near the top right hand corner

"Votes" (which leads to some partly out of date instructions).

To the right of that, see "(vote)" and click on that.

You will see a list including the one for which you wish to vote.

Check (tick) that one

and, at the bottom, click "Change My Votes"

If you don't click "Change My Votes", it won't count yours.

If tens or, better, hundreds or, even better, thousands of us vote for these bugs, they might even, unusually, get fixed at the next security update. They should be, because, for people used to and requiring use of tags/labels they impinge on the use of anti virus software.

VOTE for an early solution!

Guest
Guest
 

Post Posted April 27th, 2007, 3:07 pm

Thanks for the instructions. I've voted for both. Can I vote more than once? ;-)

catester

User avatar
 
Posts: 24
Joined: December 9th, 2004, 11:06 pm
Location: North of 49

Post Posted April 27th, 2007, 3:12 pm

Anonymous wrote:Thanks for the instructions. I've voted for both. Can I vote more than once? ;-)
Sorry....thought I was logged in but I wasn't.
Cate Eales

"But the coolest part is that the documentation will be delivered by flying pigs!" ~ Dilbert's pointy-haired boss ~

RDL
 
Posts: 1258
Joined: August 22nd, 2004, 1:39 am

Post Posted April 27th, 2007, 5:14 pm

Anonymous wrote:Thanks for the instructions. I've voted for both. Can I vote more than once? ;-)


No but if you know anyone else who finds the bug a problem..

M_Lyons10
 
Posts: 220
Joined: November 4th, 2004, 4:37 pm

Post Posted April 29th, 2007, 5:14 pm

I voted. I really hope they fix this pronto...

RDL
 
Posts: 1258
Joined: August 22nd, 2004, 1:39 am

Post Posted April 29th, 2007, 5:22 pm

M_Lyons10 wrote:I voted. I really hope they fix this pronto...

Well done. Let's also hope some more people get fired up to put their vote where their frustration is!

RDL
 
Posts: 1258
Joined: August 22nd, 2004, 1:39 am

Post Posted April 30th, 2007, 4:58 pm

M_Lyons10 wrote:I voted. I really hope they fix this pronto...

Bug 377541 has now been marked as a duplicate of Bug 355537 for which The Creators have made a hopeful fix.

By heroic sprinting, they managed to land that fix on the outbound train for TB 2.0.0.4 which is the next projected possible release and would appear around late May if things work out.

I truly hope we do see TB 2.0.0.4, with that fix working, particularly since I have this pressing update urge triggered by the appearance of TB 2.0.0.0 but still unfulfilled!

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 8 guests