MozillaZine

Annoying Line Breaks in Email Messages Sent from Thunderbird

User Help for Mozilla Thunderbird
mary72728
Guest
 

Post Posted June 7th, 2007, 3:06 pm

When I send messages from thunderbird to my yahoo account, when I look at the received messages in yahoo there are strange line breaks that seem to appear for no reason. I have noticed this in my yahoo account when others send messages from thunderbird too.

I have tried copying and pasting the text of messages into notebook, and pasting them back into thunderbird to try to get rid of any strange formatting, but it hasn't worked.

I took this latin text, which had no line breaks and looked fine in my thunderbird compose screen, and then when I receive it in yahoo, this is what it looks like (!). Both with plain text emails set to wrap at 0 characters and set to wrap at 60 characters, as well as with html set to use "fixed width" (looked *exactly* like this each time, line breaks showed up in exactly the same spots):

<a href="http://photobucket.com" target="_blank"><img src="http://i82.photobucket.com/albums/j271/mary_mercedes_photos/emailwithlinebreaks.jpg" border="0" alt="Photo Sharing and Video Hosting at Photobucket"></a>

The emails I'm sending are for my business - I need to find a solution for this formatting problem because it is making my emails look unprofessional and very difficult to read! It's kind of making me crazy, so if anyone knows how to fix this, I would really appreciate the help. Thanks


I am using version 1.5.0.12 (20070509)
The only extension I am using is Quicktext 0.9.9.9

As for my thunderbird settings:
Composition: I have checked Compose Messages in HTML format (and it is set to automatically quote the original message)
I'm using the pop bizmail yahoo server, and the sbcglobal outgoing server

rsx11m
Moderator
 
Posts: 13622
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted June 7th, 2007, 3:27 pm

This can be modified for plain-text e-mails using the "flowed" preference parameters. There are two of them, one for sending an outgoing e-mail, the other for displaying an e-mail that you received. In a non-flowed display, line breaks will be sent or shown as they where entered, potentially causing inappropriate line wraps as you describe them on the receiving end. Note that, for this to work properly, both sender and receiver have to activate the "flowed" setting, thus the wrapping is performed according to the window with where the message is displayed.
http://kb.mozillazine.org/Plain_text_e- ... t.3Dflowed

The only way that I found how to modify this behavior in Thunderbird is in the configuration editor, and it's preferable over editing the user.js file. Go to Tools > Options > Advanced > Config Editor and type "flowed" (without quotes) into the search bar. Then set the entries as follows:
  • mailnews.send_plaintext_flowed = true
  • mailnews.display.disable_format_flowed_support = false
This should do it. Again, this only works if the other end (i.e., Yahoo) has similar options available.

Guest
Guest
 

Post Posted June 7th, 2007, 3:52 pm

Ok, thank you.

I had sort of checked out those flowed options before, and I checked again, and they are set in the way that you mentioned.

Re: "Again, this only works if the other end (i.e., Yahoo) has similar options available."

This made me decide to check my yahoo settings and I think I found part of the problem. Somehow I had set it up so that in my prefs I had the Screen Width on 60, instead of 72, the default value.

Mail Options> General preferences > Screen Width: (viewing plain text mail)> 60

I set it to 72, and that seemed to take care of most of the problem:

<a href="http://photobucket.com" target="_blank"><img src="http://i82.photobucket.com/albums/j271/mary_mercedes_photos/emaillesslinebreaks.jpg" border="0" alt="Photo Sharing and Video Hosting at Photobucket"></a>

I can live with the way this email looks now. I guess it wasn't thunderbird, but was yahoo after all.

Thanks for your help. :-)

rsx11m
Moderator
 
Posts: 13622
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted June 7th, 2007, 4:08 pm

You are welcome. Yes, Thunderbird will still wrap the lines for outgoing e-mails even if they are in flowed format, but this is done in a way to distinguish those line breaks from any "hard" ones manually entered. The mail client at the receiving end is supposed to reconnect and rewrap the continuous lines. Obviously, this doesn't work with Yahoo then, thus matching the line lengths should be a good workaround.

Florie
Guest
 

Post Posted January 27th, 2009, 11:46 am

These answers are really non-answers. There's nowhere on Yahoo to change a setting to wrap incoming mails, or replies.

rsx11m
Moderator
 
Posts: 13622
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted January 27th, 2009, 12:02 pm

Well, then it's a problem in Yahoo, isn't it? With flowed format enabled, a standard-compliant e-mail client would reconnect the lines as intended...

LIMPET235
Moderator

User avatar
 
Posts: 34198
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted January 27th, 2009, 12:29 pm

Hi,
Have you tried, Options > Mail > Contact Options > Mail > General Prefs > "Messages" section?
Seems to be a few screen width/font selections there.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-30.0-36.0.1/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.5.0.
RadioYachting. Conficker Test.

rsx11m
Moderator
 
Posts: 13622
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted January 27th, 2009, 12:45 pm

The underlying problem is that many webmail systems don't seem to handle such flowed format of plain-text messages correctly (also given that popular e-mail clients like Outlook and Lotus Notes ignore RFC3676 completely, came up with their own proprietary encoding, and this may serve as "standard" for such other implementations then).

If Yahoo's interface doesn't offer flowed-format support, you can guess the line length which would still be acceptable by the recipient (as it worked for the original poster), or let Yahoo know that they are missing something and should do it correctly (which in the long run would certainly be the better solution). I have no problems with the display of Thunderbird's messages in the Gmail web interface, for example.

LIMPET235
Moderator

User avatar
 
Posts: 34198
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted January 27th, 2009, 1:19 pm

rsx11m,
As I don't use Thunderbird much...(don't receive much email),
do the following options under "Messages" not cover the Q?
[q]
"Messages"...
Headers: [] Show brief headers on incoming messages (recommended)
[] Show all headers on incoming messages
Font Size: [ Normal ] (plain text only)
Screen Width: [ 72 ](viewing plain text mail) characters (range: 50 - 99 chars.) This is the maximum line length of your incoming messages.
The default value is 72.
Screen Width: [ 55 ] (composing plain text mail)
characters (range: 50 - 99 chars.)
This is the maximum line length of your outgoing messages. The default value is 55.
Security: []
Block HTML graphics in email messages from being downloaded [What's This?]
[] Warn me about sending information outside Yahoo!7
[/q]
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-30.0-36.0.1/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.5.0.
RadioYachting. Conficker Test.

rsx11m
Moderator
 
Posts: 13622
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted January 27th, 2009, 3:17 pm

LIMPET235 wrote:Screen Width: [ 72 ](viewing plain text mail) characters (range: 50 - 99 chars.)
This is the maximum line length of your incoming messages.
The default value is 72.
Actually, the default for Thunderbird sending plain-text messages is 72 as well, thus if both sending and receiving side leave it at their defaults of 72, there should not be a line wrap unless Yahoo interprets the trailing space indicating a "soft" line break as a character (you should see just a single word in the next line then). Anyway, increasing that value should resolve most of the problems. The lines would be still disconnected though as the web interface does not recognize that the soft line breaks are indicators to connect and rewrap those lines to the actual window width.
Screen Width: [ 55 ] (composing plain text mail) characters (range: 50 - 99 chars.)
This is the maximum line length of your outgoing messages.
The default value is 55.
This appears to be quite narrow as a default, 72-80 is commonly used.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 7 guests