MozillaZine

How can I reload a message from IMAP server?

User Help for Mozilla Thunderbird
1062ringwood
 
Posts: 5
Joined: November 20th, 2007, 4:08 pm

Post Posted November 29th, 2007, 6:38 pm

Once in a while I only get the headers and not the body. I'd like to tell it to just reload the message as if it never had but every thing I try doesn't seem to work. Is there a way to say down load the entire messsage again from the imap server.

In the same vane sometimes an attachment doesn't come down correctly, the attachment is smaller than it should be. I'd like to tell it to just download the message again.

It seems like with both these, the download process gets interrupted and stops yet it thinks it has the entire message and attachments. I haven't figure out what causes the issue. It seems like if I click on the message just after the header shows up but before it has finished downloading the body that this sometimes causes the problem, but that may just be by chance. It could maybe be a timeout issue. In general I have fast ethernet; though, sometimes the imap server gets overwhelmed or something.

(I have the folders set for off line and I have restricted the size of things it can download)

I apologize if this question has been asked and answered before. I didn't find anything with the searches I tried.

DanRaisch
Moderator

User avatar
 
Posts: 119897
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 29th, 2007, 6:54 pm

I have restricted the size of things it can download)


Could that be part of the problem? Have you tried removing that setting for a while to see if things clear up?

See this link for information on increasing the timeout value in Thunderbird -- http://kb.mozillazine.org/Modify_Thunderbird_settings

1062ringwood
 
Posts: 5
Joined: November 20th, 2007, 4:08 pm

Post Posted November 29th, 2007, 6:58 pm

Darn it all. I left the word not out. I have NOT restricted the size of things it can down load.

bkennelly
 
Posts: 2177
Joined: June 26th, 2005, 4:36 pm
Location: Mesa, AZ

Post Posted November 29th, 2007, 7:44 pm

If you view the message source (Ctrl-U), does it look like it was truncated?

Who is the provider? There is a know bug in GImap, MS-Exchange and a few others that causes TB to truncate the message or attachments. The workaround is to disable 'fetch_by_chunks' through the 'Config Editor'

1062ringwood
 
Posts: 5
Joined: November 20th, 2007, 4:08 pm

Post Posted November 29th, 2007, 7:59 pm

microsuck exchange.

I've changed it. It was a little bit of an adventure to find the extension for config editory and then to find the right thing to edit. We'll have to see if that fixes.

Still it seems like there should be a way to say compare what I've got locally with what's on the imap server for this message or others and the have it make them match. Or is that what all the sync and get stuff is under off line?

bkennelly
 
Posts: 2177
Joined: June 26th, 2005, 4:36 pm
Location: Mesa, AZ

Post Posted November 29th, 2007, 8:09 pm

The problem is that the server gives the wrong length, so the message does match up to that length. Thunderbird doesn't know to check for additional data. Disabling 'fetch_by_chunks' has the side effect of ignoring the reported size, which actually solves the problem.

You didn't need to install an extension. The 'Config Editor' is available on the Advanced page of the Thunderbird preferences. After clicking 'Config Editor', enter 'fetch_by_chunks' in the filter box, then double click on 'mail.server.default.fetch_by_chunks' to toggle it to false.

(I should have posted the instructions, but I was in a hurry. I figured I could post them, if you needed, after I came back.)

Jens1972
Guest
 

Post Posted December 13th, 2010, 9:30 am

I had the same problem with a truncated attachment.

This worked for me:

- Right click the containing folder and select "Properties..."
- On the "General Information" Tab click on "Repair Folder"
- Switch to "Synchronization" Tab and click on "Download now"

All messages were reloaded from the server with full attachments.

LIMPET235
Moderator

User avatar
 
Posts: 38336
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted December 13th, 2010, 9:45 am

Thanks for the reply but after 3 years, I doubt that anyone is interested anymore. ;)

Locking.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. (Always choose the "Custom" Install.)

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 12 guests