MozillaZine

Thunderbird reindexing problem

User Help for Mozilla Thunderbird
mtnrnr
 
Posts: 4
Joined: December 3rd, 2007, 10:28 am

Post Posted December 3rd, 2007, 12:12 pm

Hello

I am using Thunderbird 2.0.0.9 in XP on an 18-month old Acer laptop. I newly installed Thunderbird and migrated my mail from Eudora...one problem I am having which causes undue headaches is that I have several pretty large mailboxes (2000 msgs); which, when I click on the icon for a particular mailbox to see emails within it, has its "indexes" rebuilt. This happens even if the box has been indexed the day before. There is a message on the status line, (building summary file for...<boxname>), a moving blue status bar indicates the status, and after a time, the box is accessible, and all the messages are indicated as unread; even if I've read them before.

There are several problems associated with this.

1. This takes several seconds, so if I need to peruse several mailboxes in the morning it can take quite a bit of time to get to the actual emails in them.
2. New messages in the supposed "unindexed" boxes are not indicated, in that the box is not bold-faced in the mailbox "tree". So, a new mail can come in, but I don't know it. I have several dozen boxes, so I can't go through all of them every time I get mail.
3. It appears that this process occasionally "loses" some mails. I read an email, then want to go back and re-read it, and it's not there (I delete very, very few emails, so it didn't get into that cycle) and when I search all of my boxes, it isn't there - anywhere.

What I'd like:
1. Turn this feature off - no 'auto-indexing' or whatever the appropriate term is. But I can't find it in a menu, and can't find it in help.
2. At the same time, keep the "new message" indicator functional - the bold-faced mailbox name when a new mail comes in to it.

I can use google desktop or the like to find mails, but this indexing rebuild (and a couple of other things which are frustrating me) is causing me enough problems to consider sending all my recent mails back to Eudora (whose filtering process is a nightmare) and "leaving" Thunderbird, even though my boss is pressing it as a standard.

Thanks to all for any insights on this!

Daifne
Moderator

User avatar
 
Posts: 123038
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted December 3rd, 2007, 3:32 pm

You can't disable "auto-indexing". It is necessary to display your messages. Try this to fix the "index" files:

Close Thunderbird. Find and delete all of the files with the .msf file extension in your profile folder/Mail http://kb.mozillazine.org/Profile_folder_-_Thunderbird including your Local Folders, especially if you are using the global inbox. You must have "View hidden files and folders" on http://spywarewarrior.com/viewtopic.php?t=272 and you need to set "hide extensions for known file types" off (just below View Hidden) if you are using Windows. These are your mail summary files and do not hold any messages themselves. They will be rebuilt the next time you open each folder in Thunderbird. Compact all your folders when you have completed this. http://kb.mozillazine.org/Compacting_folders

To avoid this happening again, see the tips in these articles:
http://kb.mozillazine.org/Keep_it_worki ... derbird%29
http://kb.mozillazine.org/Performance_%28Thunderbird%29

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 8 guests