MozillaZine

Exclude Account(s) when checking for new mail

User Help for Mozilla Thunderbird
HopkinsProg

User avatar
 
Posts: 2
Joined: May 12th, 2008, 5:42 pm
Location: Virginia

Post Posted May 12th, 2008, 5:47 pm

Is there an easy way to disable email checking for multiple accounts? I've tried going in and un-ticking the "Check for messages at startup" and "Check for new messages every __ minutes," but Thunderbird continues to check the accounts for new mail automatically and when I click on the Send/Receive button.

In Outlook Express, there is a option labeled "Include this account when receiving mail or synchronizing". Is there such an option in Thunderbird that works and is perhaps easier than going through and un-ticking two separate options for multiple accounts, that would remove them from the mail-checking process?

I've seen this question asked before, and was unable to find an answer or an extension to perform this action.

Thank you!

DanRaisch
Moderator

User avatar
 
Posts: 116139
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 12th, 2008, 6:04 pm

POP or IMAP accounts?

HopkinsProg

User avatar
 
Posts: 2
Joined: May 12th, 2008, 5:42 pm
Location: Virginia

Post Posted May 12th, 2008, 6:16 pm

There are both IMAP and POP accounts involved.

sebrame
 
Posts: 16
Joined: March 17th, 2005, 2:06 pm

Post Posted May 15th, 2008, 5:35 pm

Unfortunately, there isn't a way to do this as easily as in Outlook. In an earlier discussion, it was suggested to "change the entered value for the server name, perhaps by replacing periods in the name with commas" for the accounts you wish to exclude. This does work...however, you'll get the 'Failed to connect to server...' error dialog for every account that is excluded every time you click 'Get Mail'. The only other option is to just delete the accounts and recreate them when needed...a hassle either method.

xxsmith
Guest
 

Post Posted March 4th, 2010, 9:45 am

The issue still stands.
Any update on that since 2008?
Thank you.

DanRaisch
Moderator

User avatar
 
Posts: 116139
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 4th, 2010, 11:14 am

Here's how to maintain an account in Thunderbird, but "disable" it so that it does not fetch messages when you click "Get Mail" (or when mail is retrieved at startup or periodically):

Tools >> Options >> Advanced >>General>> Config Editor...

In the Filter bar, enter "server.server". Thunderbird apparently stores properties for each account under config items that have names like "server.server1", "server.server2", etc. So filtering on "server.server" will show you ALL of your accounts.

In the list, look for an item named something similar to this:
mail.server.serverX.name
...where X above is actually a number (1,2,3,...), depending on how many accounts you have.
...now browse through the list and look at the values of the items named "mail.server.serverX.name"...find the value name that corresponds to the email account you want to disable.
For example, if you discover that "mail.server.server6.name" has the email address for the account you want to disable, then...
...in the list, look for (or filter) "mail.server.server6.defer_get_new_mail" ... set this to false.

Thunderbird will no longer check that account for email.

This is obscure...but it looks like it works.

xxsmith
Guest
 

Post Posted March 4th, 2010, 12:19 pm

Obscure, maybe... But your directives were pretty clear.
And they worked!!!
Thanks a bunch. :D :D :D

DanRaisch
Moderator

User avatar
 
Posts: 116139
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 4th, 2010, 12:31 pm

You're welcome.

GudgeonPin

User avatar
 
Posts: 391
Joined: March 8th, 2008, 4:10 pm

Post Posted March 4th, 2010, 12:32 pm

WOW, thanks Dan,

I am trying it now.

The first whine is that the Server numbers should have been preceded by a couple of zeroes. It is bunching them as in

Server1.Name
Server10.Name
Server11.Name
...
...
Server19.Name
Server2.Name
Server20.Name
...
...
Server29.Name
Server3.Name
Server30.Name

Never a perfect world eh? :)

Great work on your part figuring it out.
Cary G.

DanRaisch
Moderator

User avatar
 
Posts: 116139
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 4th, 2010, 9:44 pm

Thanks but that wasn't my discovery. One of the forum members did the research on it and posted their findings as the solution to a problem they were having.

FritsKuijk
 
Posts: 1
Joined: July 30th, 2015, 2:18 am

Post Posted July 30th, 2015, 3:15 am

I tried to apply the suggested solution, in the about:config editor, but it already shows this settings, while thunderbird (v38.1.0) still reports that the acct connection cannot be made at startup or new mail check:
all boolean flags: false
mail.server.serverx.defer_get_new_mail seems to be replaced by mail.server.serverx.get_new_mail(:false btw)
Please help

LIMPET235
Moderator

User avatar
 
Posts: 37234
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted July 30th, 2015, 3:33 am

FritsKuijk,
Please check the date before posting.
This thread died in 2010.

Start a new thread, stating your problem.

Locking.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-50.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. Conficker Test. (Always choose the "Custom" Install.)

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 6 guests