MozillaZine

Gmail IMAP setup

User Help for Mozilla Thunderbird
flyingdp
 
Posts: 1
Joined: August 5th, 2007, 9:30 am
Location: New York

Post Posted July 23rd, 2008, 6:28 am

Using Thunderbird 2.0.0.14 and trying to set it up for my Gmail IMAP account. I set the accounts selecting 'email' (rather then then gmail option) but (a) it won't collect any email from my Gmail account and (b) when I try to send it asks for my password to xxx@gmail.com@imap.gmail.com Note the multiple "@"'s and T-bird's automatic adding of the "imap.gmail.com". Naturally any attempt to send fails.

I have looked through the account settings and FAQs but cannot find answers. Is Thunderbird just no good for Gmail IMAP accounts at this time or is there a workaround I haven't found?

tanstaafl
Moderator

User avatar
 
Posts: 45577
Joined: July 30th, 2003, 5:06 pm

Post Posted July 23rd, 2008, 6:37 am


DanRaisch
Moderator

User avatar
 
Posts: 121910
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 23rd, 2008, 6:47 am

Thunderbird has absolutely no problem accessing Gmail as an IMAP server. I have such an account working well in my Thunderbird installation at this moment.

Under Tools->Account Settings->Server Settings, be certain that you have imap.gmail.com entered as the Server Name. For User Name enter your full Gmail email address. For Secure Connection, select SSL. Do NOT select "Use secure authentication".

Under Tools->Account Settings->Outgoing Server (SMTP)->click on the Gmail account name in the right hand pane->click on the "Edit" button, be certain that you have entered smtp.gmail.com as the server name and have entered 587 as the port number. For secure connection, select "Use name and password" and "TLS, if available" for Use secure connection.

Guest
Guest
 

Post Posted July 23rd, 2008, 12:27 pm

I have all of these things set correctly, but I am getting issues as well. Didn't have them in previous versions of gmail. I do have about 12000 messages in one of my labels... But I think the problem might be thunderbird not remembering my username correctly for smtp connections? or something...
It says site: "smtp://username%40gmail.com@gmail.com" and username: "not specified" but it does show my password correctly.

Another possibility is that Pidgin access to gtalk or lightening access to gcal server is causing too many connections to google?

Just guesses though

DanRaisch
Moderator

User avatar
 
Posts: 121910
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 23rd, 2008, 12:44 pm

It looks from your post as though the entries for username may be incorrect in Thunderbird for that account. Double check them under Tools->Account Settings->Server Settings.

iabulka
Guest
 

Post Posted July 29th, 2008, 2:58 pm

I have the same problem as flyingdp (post No. 1 above). I have set a Gmail-account in Thunderbird six months ago according to the descriptions, and it was working perfectly until last week. What happened last week - when I try to receive new mail, the mail server asks me for password for e-mail account username@gmail.com@imap.gmail.com. The name of the server is added after my e-mail account. When I enter my password, a note appears which says "Invalid Credentials (Failure)". The only option is to chose OK, and then another note appears - "Login to server imap.gmail.com failed".
How can I deal with this issue?

bkennelly
 
Posts: 2177
Joined: June 26th, 2005, 4:36 pm
Location: Mesa, AZ

Post Posted July 29th, 2008, 7:17 pm

Log in to your Gmail account in the browser, and unlock the CAPTCHA.

http://mail.google.com/support/bin/answ ... swer=14257

taxilian
 
Posts: 5
Joined: August 8th, 2008, 1:25 pm

Post Posted August 8th, 2008, 1:32 pm

there are a couple other things to be cleared up here:

first, when thunderbird shows that it needs a password for "username@gmail.com@imap.gmail.com" that just means that it needs a password for the user "username@gmail.com" on the imap server "imap.gmail.com". It doesn't mean that it's changing your username. I have been using GMail since last November with imap support both from my telephone and from thunderbird. Here are my suggestions for setting up an account:

to make sure your server settings all get set up right, use the GMail IMAP thunderbird extension: https://addons.mozilla.org/en-US/thunderbird/addon/6381 this sets up everything correctly -- including the smtp server.

if you aren't doing that, make sure that you have the connection type set to SSL and secure password authentication off
if you can't log in from thunderbird, try logging into the web interface; sometimes you have to do something, like go through a CAPTCHA, to make it work right, and it's usually pretty obvious. Also, make sure you have IMAP support turned on in your Gmail account settings (on the web interface).

I really like the Google Contacts extension, which lets you use gmail contacts in your thunderbird address book. it's experimental, but working great for me. you can find it here: https://addons.mozilla.org/en-US/thunderbird/addon/7307

If you've done all this and it still isn't working, chances are good there is a problem with your ISP config or something you have set weird in gmail.

good luck!

Taxilian

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 3 guests