MozillaZine


Getting rid of colored quote bars...

User Help for Mozilla Thunderbird
Diana.Artemis

User avatar
 
Posts: 7
Joined: March 24th, 2007, 12:29 am

Post Posted March 24th, 2007, 9:13 am

Many apologies - shouted before hurt! On restart, TB behaved in the entirely proper classic manner, and inserted '> ' before quoted lines (when set to 'Start reply above quote'). Phew!

(Note that the change to '> ' for quoting only seems to apply to e-mail received *after* the modifications have been made and TB restarted - so don't be fooled as I was into thinking that nothing has happened!)

Diana.Artemis

User avatar
 
Posts: 7
Joined: March 24th, 2007, 12:29 am

Post Posted March 25th, 2007, 1:55 am

...and it also seems you must turn off HTML for writing email:
in Account Settings / Composition & Addressing, deselect 'Compose messages in HTML format'
(If your '> ' marks disappear, just check 'HTML' has not got turned back on again unaccountably!)

(I do hope this is of some use to all those struggling to sort this out!)

unsympatico
 
Posts: 4
Joined: March 20th, 2007, 10:03 am

Post Posted March 28th, 2007, 8:45 am

It appears to me that the ">"'s int he replies are a display problem in TB. I removed the colour bars, and turned off HTML as Diana suggested, and when I replied to a message, the ">"'s appeared in the message while I was writing it (and it was all in blue btw). I have two accounts set up in TB so I sent a message from account 1 to account 2. In account 2 I replied, and the ">"'s appeared so I thought all was well, but when I received that mail in account 1, the ">"'s did not appear. And they do not appear in the account 2 reply in my sent folder.

So I tried sending from a yahoo account to account 1. I replied to yahoo and the ">"'s showed while composing but not in the sent folder. When I received the mail in yahoo, the ">"'s appeared as expected. I replied back to account 1 and the ">"'s were not there (but they did show in the sent folder in yahoo). I replied again to yahoo and the ">"'s appeared, but only one level of indent, when there should have been three. It looks like TB is sending out the ">"'s but not displaying them in TB, and is also erasing any ">"'s that arrive in TB.

This is just an observation, unfortunately I have no idea what to do about it.
cheers

Diana.Artemis

User avatar
 
Posts: 7
Joined: March 24th, 2007, 12:29 am

Post Posted March 28th, 2007, 11:12 am

Unsympatico >>> Did you check that HTML is 'off' for all your accounts and for the message reader and composer? And I think there are options for using HTML in replies to HTML that you have to turn off, too. I noticed I had to go through all my settings a couple of times before I was sure everything was using plain text only. Best wishes: Diana

BruceWMoore
Guest
 

Post Posted April 10th, 2007, 8:55 pm

Yes, to cause TB to show angle brackets (">"s) instead of blue bars in replies, "Text-Only" reply mode is definitely the way to go. And yes, be sure to leave TB after you set it, and before you try it. This is fairly easy to set, compared to what I went through. Just drill down through [Tools]-[Options]-[Advanced]-[Config Editor]. Then you can mouse it "On" or "Off". But I didn't want to limit myself to text-only replies.

One thing to be aware of here, is that according to my research, the onscreen edits are handled by a different engine than the one that actually generates the email text to send out. They struggled a bit with making sure that WYSIWYG during the onscreen edit, vs what gets put together and sent out to the user on the other end.

However, to the best of my knowledge, if you see angle brackets in text-only mode on your end while doing the edit in preparation to send out, the angle brackets should also appear on the other end in the email that user receives.

BruceWMoore
Guest
 

Post Posted April 10th, 2007, 9:11 pm

I don't think they are being "erased". The way this works is that TB puts an HTML tag around the "quoted" text.

While it takes the ChromEdit2 extension to be able to control what you see during edit of the reply, I find that the Quote Colors extension does a pretty good job of controlling what you see during most displays of the email messages. The HTML tag that marks the text as a reply is probably still there, but is probably not getting interpreted properly for display.

The Quote Colors extension has an easy checkbox option to "Enable graphical quoting for plain text messages". You can check it or uncheck it, just like we ought to be able to do for any of these things. For alteration of what shows in most displays of email messages (and not necessarily the edit screen for replies) try Quote Colors, mentioned previously in this thread.

BruceWMoore
Guest
 

Post Posted April 10th, 2007, 9:49 pm

I am also using another helpful extension called "Change_quote_and_reply_format" by a fellow named "Paolo Kaosmos". The combination of all three extensions gives me Outlook style capabilities.

I quote:

"This extension modifies the reply header, inserting a header with this format:

---- Original message -----
From: email@provider.com
To: email@provider.com
Subject: something
Date: 01/01/2005

The extension works both with HTML messages and text plain ones."

This can be located at either:

KAOSMOS WEBSITE

or also at:

http://www.extensionsmirror.nl/index.php?showtopic=2626

dtobias
 
Posts: 2098
Joined: November 9th, 2002, 3:35 pm
Location: Boca Raton, FL

Post Posted April 11th, 2007, 4:42 pm

Being "Outlook style" is "helpful"? I guess in the same way a lobotomy would be "helpful" to your brain.
Dan's Web Tips: http://webtips.dan.info/
Dan's Domain Site: http://domains.dan.info/
Dan's Mail Format Site: http://mailformat.dan.info/

rgball99
 
Posts: 7
Joined: November 6th, 2004, 5:58 am

Post Posted April 14th, 2007, 8:48 am

"(Like many here, I'm astonished this is not a routine, standard option in TB.)"

Yes. I too want to have > as the quote mark in all replies containing quoted material.

These things are *glaring errors* in the UI. As is the inability to add helper apps for attachments, there's a dialog under advanced in the preferences but it isn't functional; WUWT?

AngryMozillaUser
 
Posts: 6
Joined: April 15th, 2007, 9:54 pm

Post Posted April 15th, 2007, 10:00 pm

Here is the latest summary, taken from BruceWMoore, unsympatico,and Diana.Artemis.

Go to
http://webdesigns.ms11.net/chromeditp.html#1
and save "ChromEdit Plus version 2.6.4 " to your desktop. In TB (=Thunderbird), click Tools>Extensions, and click Install in the box that appears. Find the chromeditplus file on your desktop and open. Restart TB after installation, click on Tools>ChromEdit Plus>ChromEdit, and choose the "userContent.css" tab. Copy the following into the userContent.css box:

Code: Select all
blockquote[type=cite] {
         padding-bottom: 0 ! important;
         padding-top: 0 ! important;
         padding-left: 0 ! important;
         border-left: none ! important;
         border-right: none ! important;
}


Click save, then Restart. Then, in Account Settings > Composition & Addressing, deselect 'Compose messages in HTML format' .

AngryMozillaUser
 
Posts: 6
Joined: April 15th, 2007, 9:54 pm

Post Posted April 15th, 2007, 10:08 pm

My only last complaint is that the indented replies are in blue text, rather than making everything one fixed color. I guess I can live with this one better than I can live with that stupid blue bar, but it would be nice if Mozilla didn't overdo it with the "Microsoft features."

AngryMozillaUser
 
Posts: 6
Joined: April 15th, 2007, 9:54 pm

Post Posted April 16th, 2007, 7:04 pm

Actually, one more final complaint. I'll just compare it to yahoo web based email. When I reply to a yahoo message, it wraps text that is too long to fit on the current line and indents it on the next line preceded by "> ". This is a normal text reply, not an html reply. But my Thunderbird is not doing this for the "> " reply indentation. I checked in the settings and did not see how to do it when I have "> " reply indentation. Is this another shortcoming of Thunderchicken?

Jim D
 
Posts: 1611
Joined: December 29th, 2004, 10:56 am

Post Posted April 21st, 2007, 10:31 am

AngryMozillaUser wrote:Actually, one more final complaint. I'll just compare it to yahoo web based email. When I reply to a yahoo message, it wraps text that is too long to fit on the current line and indents it on the next line preceded by "> ". This is a normal text reply, not an html reply. But my Thunderbird is not doing this for the "> " reply indentation. I checked in the settings and did not see how to do it when I have "> " reply indentation. Is this another shortcoming of Thunderchicken?

In your Compose window, select the text you want wrapped, then use Edit -> Rewrap.

AngryMozillaUser
 
Posts: 6
Joined: April 15th, 2007, 9:54 pm

Post Posted April 22nd, 2007, 10:42 pm

Thanks Jim D, but it is still not exactly what I want. In the rewrap, it doesn't indent the text that got wrapped to the new line with "> ", and that text gets converted to black color while the original indented text is blue. I don't want all these fancy "features" like I would be forced to get from Microsoft. I just want ordinary, old-fashioned unix style email replies. Unix had it right, and now everybody is trying to come up with a new way of doing email and forcing it upon on us, rather than just sticking with the basics that made people happy.

Jim D
 
Posts: 1611
Joined: December 29th, 2004, 10:56 am

Post Posted April 22nd, 2007, 11:54 pm

Hmm... You may be seeing something different from me.

For me, re-wrap does exactly what I want (which sounds like what you want).

Tb inserts linefeeds to shorten all lines to an appropriate length. All lines begin with ">", which Unix style for quoting. All lines remain blue (not black).

Now that I try it again, I notice that rewrap may do some strange things depending on what the current selection is. at the time rewrap is invoked. However, it always seems to work if I select all the quoted material to rewrap, which is the only way I have ever used it.

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests