MozillaZine

Getting rid of colored quote bars...

User Help for Mozilla Thunderbird
JohnSelden
 
Posts: 5
Joined: March 4th, 2009, 8:11 pm

Post Posted June 14th, 2009, 9:43 am

smsmith wrote:
Code: Select all
blockquote, blockquote[type=cite] {
   padding-bottom: 0 !important;
   padding-top: 0 !important;
   padding-left: 0 !important;
   margin-left: 0 !important;
   border-left: 0px !important;
   border-right: 0px !important;
}

I use that code in my userContent.css file coupled with the three preferences referenced here:
http://kb.mozillazine.org/Quote_bars

I think the addition of just "blockquote" is what makes it work. At least for me.

Adding the margin-left: 0 means that you won't be able to use an indented blockquote _at_all_ when you are composing a message.


Thanks for this! Adding the extra "blockquote" did the trick. I finally got rid of those darn blue bars (TB 3.0b2 on Mac OS 10.5.7).

jcassidento
Guest
 

Post Posted June 26th, 2009, 12:13 pm

A quick update. I now pretty much have things working the way I want. First, I have the QuoteAndComposeManager add-on, set to automatically hide borders. Better still, I have it remove all prefix characters in replies and delete brackets in the subject line for forwards. Then, I have the Change Quote and Reply Format add-on, set for a customized reply header (From, Sent, To, Cc, Subject). It took a little monkeying around to get the reply header font / size consistent with the rest of the email, but it looks fine now (Headers always with Arial 12 in QACM, and Compose in Helv/Arial small in TB). I am going to attempt to contact the creator of the Change Quote and Reply Format add-on to ask him about making the header fields bold (with following text non-bold, like From: jdoe@public.com), but basically, I think I am all set. I will also try smsmith's suggestion from June 11, though I actually prefer the more automated approach using the add-ons. Thank you all for your help and suggestions, I really do appreciate it.

RedFox1
Guest
 

Post Posted July 29th, 2009, 8:50 am

All the mentioned advices does not solve the problem of REMOVING the ">" signs, when SENDING an e-mail reply. It only hides the vertical bars when VIEWING a received message.
I have examined the source code of Mozilla (Netscape 7) and really did not find any settings or code parts, where the ">" sign is defined (and could be removed).
Well, as someone could say, it is the specification to include ">" in e-mail replies, but I need get rid of it. Why? I send e-mail confirmations from my web site to my Inbox, where I would like (after the client pays for our services) to click "Reply" and send the original message to the original e-mail address - it has to look as original message, not as a Reply.

I tried to filter incoming messages to the Drafts or Templates folders, which allows me to compose/send the message as new - but the Mozilla e-maiul client is unable to switch sender and receiver addresses - unlike the Reply function, it wants to send the e-mail to me instead of the customer.. pretty annoying to switch Reply-To: and To: manually, especially when there are more orders...

Well, if someone is able to perform a reverse engineering / or examine the entire source code more carefuly, if would be great.
In the meantime, there is no solution to the said problem in the whole Internet yet.

dtobias
 
Posts: 2098
Joined: November 9th, 2002, 3:35 pm
Location: Boca Raton, FL

Post Posted July 30th, 2009, 7:15 am

Why don't you use "Forward" instead of "Reply"?
Dan's Web Tips: http://webtips.dan.info/
Dan's Domain Site: http://domains.dan.info/
Dan's Mail Format Site: http://mailformat.dan.info/

rsx11m
Moderator
 
Posts: 14429
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted July 30th, 2009, 8:15 am

This extension has an option to remove the '>' for quotes, but works for Thunderbird only. I don't know if it has been ported anywhere to work with the Netscape 7.1 you are using (which by the way is no longer supported, thus you should either upgrade to SeaMonkey if you want to stay with the suite or use Thunderbird and Firefox instead).

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 11 guests