MozillaZine

Getting rid of colored quote bars...

User Help for Mozilla Thunderbird
GordMcFee
 
Posts: 13001
Joined: May 3rd, 2003, 4:18 pm
Location: Ottawa, Canada

Post Posted September 10th, 2005, 7:55 pm

Strange. Your link is obviously better.
Gord McFee

thunderbirdNewbie
Guest
 

Post Posted January 11th, 2006, 3:41 pm

I have the same problem with the quote bars. Will this solution work in 1.0.7?

GordMcFee
 
Posts: 13001
Joined: May 3rd, 2003, 4:18 pm
Location: Ottawa, Canada

Post Posted January 11th, 2006, 9:35 pm

Yes.
Gord McFee

drjhy
Guest
 

Post Posted February 19th, 2006, 3:19 pm

I am new to Thunderbird. I am using 1.5. I have trying for over a month to remove the quote bar. Nothing appears to work. Is there anything I can do?

Daifne
Moderator

User avatar
 
Posts: 123058
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted February 19th, 2006, 3:24 pm

Did you read the six pages of this topic?

JITR
Guest
 

Post Posted August 2nd, 2006, 1:42 pm

fallout84 wrote:What I want is to absolutely get rid of the brackets > when quoting a message.
When I click on reply TB should just copy the text from the original into a new message.


Strongly discouraged as it might be vialoation of standards and almost certainly it *is* a vialoation of netiquette. ;-)

At least it will completely disallow to reply to messages inline and force you to use top-posting or some other not-so-popular methods disliked by some people. You may, in fact, get flamed for top-posting. You might like to see this docuement.

JITR
Guest
 

Post Posted August 2nd, 2006, 2:27 pm

anowack wrote:That works! Again, my thanks.

For future reference, here's what I now have:

In userContent.css:
Code: Select all
 blockquote[type=cite] {
         padding-bottom: 0 ! important;
         padding-top: 0 ! important;
         padding-left: 0 ! important;
         border-left: none ! important;
         border-right: none ! important;
 }


{snip}


There's a little more tweaking possible: By changing the CSS selector in the above code, you can set separate styles for HTML and plain text mails. Actually there are 3 variants: (1) HTML, (2) plain text and (3) plain text in flowed format (hereinafter `f=f', which stands for `format=flowed' as used in the mail headers). To discriminate between styles for these three formats you simply prepend another selector separated with space:

`<code>.moz-text-plain</code>' for plain text
`<code>.moz-text-flowed</code>' for f=f plain text
`<code>.moz-text-html</code>' for HTML

Thus, in order to disable the bars for plain text (only non-f=f for simplicity) only, the selector line in the above quoted code becomes

Code: Select all
 .moz-text-plain blockquote[type=cite] {
         ...


To cover f=f as well, you would use

Code: Select all
 .moz-text-plain blockquote[type=cite],
         .moz-text-flowed blockquote[type=cite] {
         ...



Additonally, when you want to disable the bars, it is better to do this only for the case, when they are disabled by the preferences (this is controlled by the pref `<code>mail.quoted_graphical</code>'). This is probably not important whenever you change this only for yourself. But when your style applies to others, who might want the default behaviour (ie. bars shown), the above code creates quite confusing situation as it prevents bars from showing regardless of the mentioned pref setting. By resetting the pref to default, the old-school `<code>></code>' quoting characters disappear, but no bars are shown instead as the discussed CSS rule disabled them unconditionally.

As deduced (and successfully verified) from the source code, the following selector modification allows you to discriminate based on the pref value. The internal representation sets an attribute `<code>graphical-quote</code>' to the value of the pref, so in order to disable the quoting bars only when they should be disabled (as said by the pref, which also controls the `<code>></code>' characters) my first example changes to

Code: Select all
 .moz-text-plain[graphical-quote="false"] blockquote[type=cite] {
         ...


Should you prefer not to discriminate based on format (HTML, plain text, f=f), you just apply this modification to the code from the above quatation, which then becomes (warning: not tested, but follows from the CSS specification)

Code: Select all
 *[graphical-quote="false"] blockquote[type=cite] {
         ...


Hope someone will find this useful. Hope to increase the value of significant time spent on researching this by spending more time on writing an article about it. ;-)

JITR
Guest
 

Post Posted August 4th, 2006, 5:05 pm

Uh-oh. A mistake has slipped through which I noticed right now and so came back here to correct it. The following selector will not work:

Code: Select all
 .moz-text-html[graphical-quote="false"] blockquote[type=cite] {
         ...


Apparently, there's no element with class `<code>moz-text-html</code>' used in this context. I just don't know what made me think it is, probably didn't do some tests properly. I hereby apologize for the disinformation. :-(

So, the only way to affect HTML viewing (yes, this doesn't properly cover compose mode!) seems to declare style together for all formats by merely using the `<code>blockquote</code>' element in the selector this way:

Code: Select all
 blockquote[type=cite] {
         ...


This seems to work for me and is in fact the way how I fixed this error in my CSS files. Should you want to set different style for plain text or f=f plain text, you'll have to override the generic styles set by the above rule using the format-specific rules I described in my previous post. These do work, except of the HTML one, of course.

It's a pity there seems to be no way to declare styles for HTML only. Does anyone know of a way to do this?

mactac
Guest
 

Post Posted March 15th, 2007, 12:00 pm

I've put those 3 files (userContent.css, prefs.js & user.js) is every folder that even remotely resembles any of the folders referred to here. I have 14 copies of each of these files all over now & STILL it doesn't do anything.

I still have the blue & red lines when I reply.

this is just plain silly....

I'm starting to think that the only solution to all these problems is to go back to outlook....

Freee!!

User avatar
 
Posts: 15562
Joined: January 28th, 2005, 5:52 am
Location: Home, with my son!

Post Posted March 15th, 2007, 1:26 pm

If you download and install the Chromedit2 extension, it will make sure those files are in the correct location and with the correct name. And unless you really know what you are doing, you shouldn't edit prefs.js which certainly is present in the correct location.

BruceWMoore
Guest
 

Post Posted March 20th, 2007, 11:14 pm

JITR wrote:
fallout84 wrote:What I want is to absolutely get rid of the brackets > when quoting a message.
When I click on reply TB should just copy the text from the original into a new message.


Strongly discouraged as it might be vialoation of standards and almost certainly it *is* a vialoation of netiquette. ;-)


We are discussing email here . . . not discussion groups, or any such.

JITR wrote: . . . You may, in fact, get flamed for top-posting. You might like to see this docuement.


I checked this link, and it is primarily concerned with what people are posting on Usenet, and in discussion groups like this one.

While I agree that interleaved quotes are a good method for conveying your message to people sometimes, when discussing email, a full and complete record of the conversations between business parties is a necessity.

And when you have several emails back and forth between those parties, any kind of indented quote of any sort quickly becomes a real liability. We need no blue bars, no ">"s, just text that snugs up to the left side of the page, if the author wrote it that way. If they indented something, then that could possibly stay indented without hurting anything.

Sure, I've been copy/pasting original emails into web-mail replies for years, but I shouldn't have to. After the umpteenth level of indention, this becomes a matter of common sense.

I have only recently begun using Thunderbird in place of MS Outlook, and was summarily disappointed to find it putting blue bars on the left side of the quotes in my HTML replies, and ">"s on the left side of text-only replies. And then, to make things worse, there was no easy option to turn that part off!

Having located this thread and waded through literally years worth of posts, I <i>might</i> be able to turn them off, especially since I am a computer programmer, but with Firefox beginning to convert many users who previously used MS IE, and Thunderbird beginning to come way up in the ranks, this really should just be an option on the menu somewhere.

BruceWMoore
Guest
 

Post Posted March 21st, 2007, 5:55 am

I have spent a long eight hours or so researching this topic, and have gone so far as to read entire bugzilla threads on the subject. Even perused some of the code involved at one site . . .

Of all the files mentioned in this thread, the only one that already existed on my computer was prefs.js, located under "Mozilla Thunderbird\defaults\profile" in my "Program Files" folder.

If you open prefs.js for edit, you get a message informing you that you should not edit that file, and that changes will be overwritten each time Thunderbird starts. In that file, you are referred to a link:

http://www.mozilla.org/unix/customizing.html#prefs

This link has helpful information, and the content is authored by Akkana Peck, who, apparently, has been instrumental in solving some problems with Thunderbird in the past.

The info there steers the user away from doing edits on prefs.js, but instead suggests putting changes into "a file called user.js in the same directory, which is under the user's control and is read but never written by Mozilla".

Another item of information contained at that link is that "A menu option ([Tools]-[Advanced Preferences]) brings up a similar editor in thunderbird as well."

I went looking for this, and while the information is slightly out of date for my Thunderbird version 1.5.0.10 (20070221), I did find that this option exists and can be used. In my version, it is located in:

[Tools][Options][Advanced][General][Config Editor]

When you bring that up, there are point-and-click options for a very long list of features, including the:

user_pref("mail.quoted_graphical", false);
user_pref("mailnews.display.disable_format_flowed_support"

options mentioned earlier in this thread.

He further goes on to give examples such as putting:

// Turn off graphical reply style in the message window
user_pref("mail.quoted_graphical", false);

// use HTML-style quoting for quoting plain text (during HTML replies)
user_pref("mail.quoteasblock", true);

into user.js.

Having read this thread fairly carefully, and having seen that various things did not work for everybody here, I have tried several approaches to solving this problem. Per Gord McFee's post about the Quote Colors extension, I tried that first. I see options to "Enable Graphical Quoting" (or disable it). Options to "Collapse Borders", which looks promising, but seems to do nothing. "Enable quote coloring for HTML messages" (or disable).

I tried setting quote level color to white, no effect. Still has blue level bar. "Enable graphical quoting for plain text messages" seems to have no effect at all. Setting static color for borders to white seems to have no effect. Setting border position to the bottom has no effect. Matter of fact, none of the options that I tried in this extension seemed to affect the blue bar in the "reply to" message in any way.

I tried doing searches for the files mentioned in the thread, with very little success. Not being too sure just where the files should be created, I downloaded the ChromEdit2 extension, as mentioned by Freee!!.

The Chromedit2 extension

This was helpful, in that it both opens the folders where these things "should" be located, and also allows the user to right-click on the filename located there and edit the zero-length file presented on the screen, hence adding text mentioned in this thread and/or the text mentioned on other web pages.

In that extension, one has the option to "Open The Chrome Folder", and there is also an option to "Customize" which looked like a good place to add the style sheet code mentioned previously. Tried that, no change.

The Chrome program also adds a new menu to the Tools menu "ChromEdit Plus" which has four choices on it. Those choices are "ChromEdit" (which I did not immediately recognize as a menu choice), "Profile Folder", "Chrome Folder", and "Install Folder".

Based on everything I had read so far, I tried pulling up the "Profile Folder" and the "Chrome Folder". These looked promising, and tried edit of user.js in the profile folder, placing the user pref lines there with no luck. The settings took effect, but did not change the blue bar.

Tried putting the style sheet code into a new file in the Chrome folder, no luck.

Finally, while verifying information for this post, I managed to hit the "ChromEdit" option on the "Tools" menu. This immediately brings up a window with tabs for "UserChrome.css", "UserContent.css", and "user.js". Tried placing the style sheet text into the UserChrome.css tab, with little or no effect. I thought maybe the bars looked a little smaller.

Through all of this, I had been careful to try a reply immediately, and also to try exit of Thunderbird, as I had noticed in my reading that some settings do not take effect until you exit.

When I placed the style sheet code into the "UserContent.css" tab, there was no immediate effect, but after I left the program and came back, lo and behold, the blue bar was gone!

The code snippet that I am referring to as style sheet code is as follows:

Code: Select all
blockquote[type=cite] {
         padding-bottom: 0 ! important;
         padding-top: 0 ! important;
         padding-left: 0 ! important;
         border-left: none ! important;
         border-right: none ! important;


I repeat it again here for clarity, since I have not seen any one post so far which contained all the elements that I needed to get this done.

After this worked, went back and took the style sheet code out of the UserChrome.css tab, and at this point also noticed a "Restart" button at the bottom of the window. Tried that out too, and result was that rather than having to exit the Thunderbird program and restart the program from the icon, I was automatically taken out and back in. Nice!

After taking the code out of the UserChrome.css tab, the reply still had no blue bar, so I am very happy to have muddled through this maze of information to finally get this result, even if it did take approximately eight hours.

I am well aware that the average user would have given up after maybe thirty minutes, so I hope this post will help others get it set up without the major effort that it took for me. One user stated that he had been trying for over a month with no success. So for all you frustrated folks out there, this post may be the definitive answer to the question, "How can I reply to email in Mozilla Thunderbird without the quoted text from the email I am replying to having a blue bar and an indentation on the left side of the text?"

Other useful information that I have located during this odyssey is located at the following:

Thunderbird: Guide for the Perplexed

Hidden Mozilla/Firefox/Thunderbird Prefs

Bruce W. Moore
Moore Software Consultation And Design

mactac
Guest
 

Post Posted March 21st, 2007, 7:39 am

thank you SOOO much for that post. i tried what you did & it worked !! i've been trying for weeks to get rid of those bars.

now I'd like to replace them with > symbols... any ideas?

there is no way we should have to go through all of this to do something that should be as simple as a selection checkbox (like it is in outlook). PLUS, adding the code then taking it away leaves the effect... WHAT???? why is this? what kind of crazy program.....?

unsympatico
 
Posts: 4
Joined: March 20th, 2007, 10:03 am

Post Posted March 21st, 2007, 8:42 am

BruceWMoore, your eight hours I'm sure saved me 80 hours, thank you. It took me about 15 minutes to read your post and do the edit.

For those of you who want to do it in three minutes, I'll parse Bruce's post even more. In BruceWMoore's post click on the "The Chromedit2 extension" link, and save "ChromEdit Plus version 2.6.4 " to your desktop. In TB, click Tools>Extensions, and click Install in the box that appears. Find the chromeditplus file on your desktop and open. Restart TB after installation, click on Tools>ChromEdit Plus>ChromEdit, and choose the "userContent.css" tab. Copy the code snippet from Bruce's post, and paste into the userContent.css box. Click save, then Restart and you're good to go.

Thanks again Bruce for making it easy (but later versions should have this sort of thing as a selectable option).

Diana.Artemis

User avatar
 
Posts: 7
Joined: March 24th, 2007, 12:29 am

Post Posted March 24th, 2007, 8:56 am

mactac wrote:...i've been trying for weeks to get rid of those bars. now I'd like to replace them with > symbols... any ideas?...


I, too, have got rid of the awful bars, after hours of stuggle - when I realised you have to *create* the \Chrome folder yourself in

C:\Documents and Settings\username\Application Data\Thunderbird\Profiles\xxxxxxxxxxx.default\Chrome

so that you can put a userContent.css there. So that's got rid of the bars. But... I, too, would now really like to have the completely standard '> ' quote marks inserted automatically into my replies. I'd be *very* grateful for a simple explanation / script to do this.

(Like many here, I'm astonished this is not a routine, standard option in TB.)

Return to Thunderbird Support


Who is online

Users browsing this forum: Google [Bot] and 5 guests