MozillaZine

Smart card and Thunderbird

User Help for Mozilla Thunderbird
OIPPI
Guest
 

Post Posted November 14th, 2008, 2:22 pm

I recently added a smart card reader on my computer to be used when logging in some special web sites and to digitally sign and encrypt some of my emails. I managed to set up my card reader and certificates etc and technically everything works fine except one thing:

Thunderbird asks my PIN code just once wen I send my first email after the smart card is inserted. After that the PIN is not asked with the following emails as long as the smart card is not removed from the card reader.

For security reasons I would like Thunderbird ask the PIN code every time an email is being sent like Outlook does.

Does anybody know what setting I should change?

Card reader: CSR3310
Card reader software: mPolluxDigiSign Client v1.3.2

Thanks in advance!

newbee 27
Guest
 

Post Posted March 25th, 2009, 4:22 am

I d like to now the answer to that question too ...

I have the same problem with Print2PDF 8 --- i set it up to automatically digitally sign my documents printed to pdf BUT it asks me for my PIN or authentification code for using the digital signiture only the first time I use it :(

tanstaafl
Moderator

User avatar
 
Posts: 38932
Joined: July 30th, 2003, 5:06 pm
Location: Massachusetts

Post Posted March 25th, 2009, 6:08 am

Is the PIN being saved by the password wizard? Use tools -> options -> privacy -> passwords -> edit saved passwords -> show passwords to check that.

Ralphy
Guest
 

Post Posted July 1st, 2010, 7:52 am

I'm not sure that's a function of Thunderbird. Outlook 2007 behaves this way too depending on how you have the middleware for your card reader set up. There are options within Activcard/Activclient that can change whether a pin is requested every time.

Haven't really played with it, but just a thought.

DanRaisch
Moderator

User avatar
 
Posts: 106883
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted July 1st, 2010, 2:25 pm

Ralpy, you've posted to a thread that died out over a year ago. It's doubtful that any of the original posters are waiting for input on this topic.

Locking this due to the age of the original posts.
Vista Home Premium 64 - FX 37.0.1 & TB 31.6.0 Win 8.1 - FX 37.0.1 and TB 31.6.0

Return to Thunderbird Support


Who is online

Users browsing this forum: No registered users and 2 guests