MozillaZine

Thunderbird cannot send email in HTML format

User Help for Mozilla Thunderbird
Guest
Guest
 

Post Posted November 21st, 2008, 12:40 am

I've check compose message in html format and send option set to send the message in both plain text and HTML
but message only send in plain text format unless I change the format option from auto-detect to Plain and Rich (HTML) text every time I write a message.
Can anyone tell me what's wrong?
Do I need to re-install Thunderbird?
Thanks.

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted November 21st, 2008, 2:31 am

Reinstalling almost never helps. Choose: Tools – Options – Composition – General – Send Options... and ensure that the Text Format is set the way you want.
Rod

Guest
Guest
 

Post Posted November 21st, 2008, 2:58 am

Thanks Rod,

no matter the send options set to send message in HTML anyway or send message in both plain text and HTML, still not work :(

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted November 21st, 2008, 3:43 am

Sorry...an episode of acute caffeine deficiency syndrome made me forget the obvious. After a cup of coffee... Thunderbird only sends HTML if some of the message content actually requires HTML. See the knowledge base: http://kb.mozillazine.org/Mail_content_ ... g_messages
Rod

Guest
Guest
 

Post Posted November 21st, 2008, 9:27 pm

Hi Rod

I'm sure that the message content requires HTML, I've change the font color, size to emphasis something, but what the recipient got is a heaps of text without format.

DanRaisch
Moderator

User avatar
 
Posts: 106611
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted November 22nd, 2008, 8:32 pm

Does the recipient have their system set to display HTML formatted messages?
Vista Home Premium 64 - FX 37.0.1 & TB 31.6.0 Win 8.1 - FX 37.0.1 and TB 31.6.0

Guest
Guest
 

Post Posted November 24th, 2008, 12:14 am

Thanks Dan,

The recipient's machine setup is correct, he can see HTML mail sent from other.
I've open the message source and it show the content type is text/plain not text/HTML, it seen like that thunderbird auto-detect compose format option not function, if I set the format option to Rich (HTML) text only or Plain and Rich (HTML) text , it can delivery HTML mail.

DanRaisch
Moderator

User avatar
 
Posts: 106611
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted November 24th, 2008, 5:42 am

That is not normal behavior. Have you tried running in Mozilla Safe Mode to rule out issues from any installed extensions? http://kb.mozillazine.org/Safe_mode
Vista Home Premium 64 - FX 37.0.1 & TB 31.6.0 Win 8.1 - FX 37.0.1 and TB 31.6.0

ea6651
 
Posts: 6
Joined: July 8th, 2007, 9:15 am

Post Posted November 24th, 2008, 7:02 pm

I have the very same problem with Thunderbird 2.0.0.18, regardless of what I set my preferences to (mail.default_html_action in prefs.js, which is set to 2, which translates to "Send the message in HTML anyway" in Tools/Options/Composition/General/Send Options). I use the EditHTML add-on and it seems, while I do not have a reproducible case yet, that there are Thunderbird HTML parsing issues when it tries to determine whether the text is HTML or not (style sheets definitions in the header are not a problem, but parsing <p class=...> seems to cause the problem). No problem with my HTML, if I manually switch Thunderbird to HTML (Options/Format/Rich Text (HTML) only), but Auto-Detect sends it as Text. What would be great would be a command line parameter to force it to HTML, or a settings in Options that does the same.

Just in case you are interested, following is the HTML code that it struggles with (code was created in Dreamweaver 8):
<head>
<style type="text/css">
<!--
.style3 {font-size: 14px}
.style4 {font-size: 16px; font-weight: bold; }
-->
</style>
</head>

<body>
<p class="style4">Welcome to Acme Corp</span></p>
<p class="style3">Here are the details for your Acme personal account:</p>
<p class="style3">Personal Account Number: <span class="style4">8916020542517879</span><br />
User: <span class="style4">Joe Doe</span><br />
Email: <span class="style4">joedoe@joedoe.com</span><br />
Password: <span class="style4">CN46v46867</span></p>
<p class="style3">Please keep a copy of this email for your records. You will need the account details to log into your account at <a href="www.acme.com">www.acme.com</a> once we begin online bookings. At that time you will also be able to change the default password.</p>
<p class="style3">For reservations or inquiries
our call center can be reached at 1-877-1111111. It is open Monday through Friday from 6am to 9pm Pacific and on holidays and weekends from 9am to 6pm Pacific.</p>
<p class="style3">For more details on our service
please go to the following pages:<br />
Terms and Conditions of Acme's Service: www.acme.com/terms.php<br />
Privacy Policy: www.acme.com/privacy.php</p>
<p class="style3">Please add reservations@acme.com to the list of safe email addresses.</p>
<p class="style3">Thank You</p>
<p class="style3">Your Acme Team</p>
</body>

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted November 25th, 2008, 2:25 am

I copied that HTML and pasted it in a message. My signature is plain text, and I left the format as Auto-Detect. Thunderbird 2.0.0.18 sent both plain text and HTML. Then as a control I sent a message containing no HTML, and Thunderbird send only plain text. So I cannot reproduce any parsing issue.
Rod

ea6651
 
Posts: 6
Joined: July 8th, 2007, 9:15 am

Post Posted November 25th, 2008, 10:02 am

True - I used EditHTML rather than Insert/HTML, since EditHTML allows me to edit the header and not just the body. When using Insert/HTML, Auto Detect correctly identified it as HTML even although it put the style sheets into the body. I wonder why that's the case...

Interestingly, though, if you look at the following line:
"<p class="style3">Please keep a copy of this email for your records. You will need the account details to log into your account at <a href="www.acme.com">www.acme.com</a> once we begin online bookings. At that time you will also be able to change the default password.</p>"
The link to acme.com is not interpreted as a link at all, but just as plain text. Conversely, in the following line
"Terms and Conditions of Acme's Service: www.acme.com/terms.php<br />"
Thunderbird automatically changes the text www.acme.com/terms.php to a link. Why is that?

Rod Whiteley

User avatar
 
Posts: 11480
Joined: December 6th, 2004, 3:41 am
Location: UK

Post Posted November 25th, 2008, 11:05 am

I see them both as links in the sent message. Perhaps EditHTML is causing some strange things to happen for you.

By the way, mail clients differ in how they handle style tags. Some strip the entire head, so any style there will be lost. Others strip style tags from the body too.
Rod

ea6651
 
Posts: 6
Joined: July 8th, 2007, 9:15 am

Post Posted November 25th, 2008, 11:58 am

Rod, thanks for all your help and insights on this issue!

Deucalion

User avatar
 
Posts: 214
Joined: April 14th, 2003, 7:31 pm
Location: Grass hut on the Luna Sea

Post Posted November 26th, 2008, 12:54 pm

What I have found is if I am currently in a local folder and I compose or reply using HTML, it will only send in plain text unless I check off Options > format > plain and rich text regardless of the compose format setting I have for the identity. However if I am in a folder other than a local folder and I compose/reply in HTML, the message is created as a multipart alternative and is sent as expected.

It would be nice if "Options > format > plain and rich text" was a sticky setting or there was an extension to handle it.
You can't get here from there

Guest
Guest
 

Post Posted November 26th, 2008, 6:44 pm

Hi Rod,

I've sent a HTML message in safe mode, but the result still the same, nothing change, only plain text delivered.

Return to Thunderbird Support


Who is online

Users browsing this forum: Bing [Bot] and 13 guests