MozillaZine

Firefox & Thunderbird Add-on Converter for SeaMonkey

User Help for Seamonkey and Mozilla Suite
isaacschemm
 
Posts: 268
Joined: January 20th, 2015, 12:29 pm

Post Posted October 26th, 2017, 6:12 am



I've been working on this over the past week (thanks RrBd for suggesting it). This will get the extension working again.

Changes:
  • A workaround with setTimeout to make sure this script runs after Mozilla's, not before
  • For WebExtensions, it will show a message and suggest you look at old versions
  • Added converter links on the versions page
  • Very minimal support for the new AMO (https://blog.mozilla.org/addons/2017/10 ... zilla-org/)

I'll try to get this new version uploaded to AMO later today.

isaacschemm
 
Posts: 268
Joined: January 20th, 2015, 12:29 pm

Post Posted October 28th, 2017, 2:53 pm

I've uploaded version 0.9.16.1:
https://addons.mozilla.org/en-US/seamonkey/addon/amo-browsing-for-seamonkey/

(I also briefly uploaded a 0.9.16.2 by accident, but that wasn't any different from 0.9.16.1.)

There's also a beta version available. It adds support for the new version of the Firefox Add-ons site.
https://github.com/lemon-juice/AMO-Browsing-for-SeaMonkey/releases

RrBd
 
Posts: 21
Joined: February 25th, 2015, 1:21 am

Post Posted November 1st, 2017, 8:41 am

Hi all,

Isaac created a new version 0.9.17rc1 https://github.com/lemon-juice/AMO-Browsing-for-SeaMonkey/releases/tag/v0.9.17rc1 https://github.com/lemon-juice/AMO-Browsing-for-SeaMonkey/tree/new-amo with several improvements. I suggest to test it few days (until Weekend) before he uploads it to AMO.

CU

Rainer

js017
 
Posts: 7
Joined: April 11th, 2017, 8:04 am

Post Posted November 17th, 2017, 11:04 am

It seems that http://addonconverter.fotokraina.com/convert.php doesn't convert the newer WebExtensions .xpi Firefox add-ons to be compatible with SeaMonkey 2.48. It just says "install.rdf not found in installer". Is there a way to fix that? Thanks.

Frank Lion

User avatar
 
Posts: 20075
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted November 17th, 2017, 11:37 am

js017 wrote:Is there a way to fix that? Thanks.

Nope and even if it did then SeaMonkey wouldn't be able to use those WebExtensions.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

grahamperrin
 
Posts: 34
Joined: July 19th, 2009, 3:56 pm

Post Posted November 17th, 2017, 9:15 pm

Changes, please, to the list of converted extensions

One update, eight additions.

Copy Title 1.1.1 https://addons.mozilla.org/addon/copy-t ... d.1-signed


Copy Title and URL 1.0 https://addons.mozilla.org/addon/copy-t ... ersion-1.0

  • tested by me, not compatible.

FireTitle http://addonconverter.fotokraina.com/co ... :FireTitle


Minimap Scroller Sidebar https://github.com/diox/firefox-minimap ... structions

  • 0.2 tested by me, not compatible.

pdfit 1.15 https://addons.mozilla.org/addon/pdfit/ ... d.1-signed

  • tested by me, compatible.

Scroll Highlight 0.4 https://addons.mozilla.org/addon/scroll ... d.1-signed

  • tested by me, not compatible.

Scroll Position Highlight 1.9 https://addons.mozilla.org/addon/scroll ... ersion-1.9

  • tested by me, not compatible.

ScrollMap 0.9 https://addons.mozilla.org/addon/scroll ... d.1-signed


Tab Groups 2.1.4 https://addons.mozilla.org/addon/tab-gr ... sion-2.1.4

  • tested by me, not compatible – sorry.

smsmith
Moderator

User avatar
 
Posts: 19758
Joined: December 7th, 2004, 8:51 pm
Location: Indiana

Post Posted November 18th, 2017, 7:34 am

URL Tooltip 1.3 works with SM 2.49.1.
https://addons.mozilla.org/en-US/firefo ... l-tooltip/
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

akakima
 
Posts: 1
Joined: January 6th, 2018, 1:32 pm

Post Posted January 6th, 2018, 1:50 pm

Hi,

Tryed the converter to convert Firefox SuperStart add-on.
Everything seems ok. Except import/import.
Got the following message:
XML Parsing Error: undefined entity
Location: chrome://superstart/content/export-import.xul
Line Number 13, Column 1:<dialog title="&superstart.export; / &superstart.import;"
^

What is the undefined entity: dialog ?, title ? ???
Where is it supposed to be defined ?
How to correct this ?

Thanks

rfurb
 
Posts: 5
Joined: July 8th, 2009, 8:03 pm

Post Posted January 24th, 2018, 8:47 pm

Hello,


Does anybody know any bookmarks privacy/encryption add-on for Seamonkey ?

The two most known ones (Private Bookmarks and Link Passwords) are compatible with Firefox only.

Tried to convert them to SeaMonkey using this Add-on Converter
but the conversion fails saying they don't have an "install.rdf" file in their .xpi file packages.


Thanks in advance,


Rubens

isaacschemm
 
Posts: 268
Joined: January 20th, 2015, 12:29 pm

Post Posted January 25th, 2018, 7:05 am

rfurb wrote:Hello,


Does anybody know any bookmarks privacy/encryption add-on for Seamonkey ?

The two most known ones (Private Bookmarks and Link Passwords) are compatible with Firefox only.

Tried to convert them to SeaMonkey using this Add-on Converter
but the conversion fails saying they don't have an "install.rdf" file in their .xpi file packages.


Thanks in advance,


Rubens


If there's no install.rdf that just means it uses WebExtensions.

You could try converting the old version of Link Password. I don't know if it'll work, though.
https://addonconverter.fotokraina.com/?url=https%3A%2F%2Faddons.mozilla.org%2Fseamonkey%2Fdownloads%2Ffile%2F220768%2Flink_password-4.0.1.0-fx.xpi%3Fsrc%3Dversion-history

rfurb
 
Posts: 5
Joined: July 8th, 2009, 8:03 pm

Post Posted January 26th, 2018, 6:51 am

isaacschemm wrote:
rfurb wrote:Hello,


Does anybody know any bookmarks privacy/encryption add-on for Seamonkey ?

The two most known ones (Private Bookmarks and Link Passwords) are compatible with Firefox only.

Tried to convert them to SeaMonkey using this Add-on Converter
but the conversion fails saying they don't have an "install.rdf" file in their .xpi file packages.


Thanks in advance,


Rubens


If there's no install.rdf that just means it uses WebExtensions.

You could try converting the old version of Link Password. I don't know if it'll work, though.
https://addonconverter.fotokraina.com/?url=https%3A%2F%2Faddons.mozilla.org%2Fseamonkey%2Fdownloads%2Ffile%2F220768%2Flink_password-4.0.1.0-fx.xpi%3Fsrc%3Dversion-history


-----------------------------------------------------------------------------------------------------

@isaacschemm:

Thank you so much, the suggested "Link Password" conversion suceeded !

therube

User avatar
 
Posts: 19161
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 28th, 2018, 7:22 am

Shift + Scroll (Horizontal Scrolling), the older (from the /Versions/ page) v0.0.2 version looks to work in SeaMonkey.
(Its features are now a part of FF 58.)
(Newer versions are webex, so won't work in SeaMonkey.)

I'll note that the .xpi includes a copy of jquery-2.2.0.min.js, which was removed from the 0.1.1 version, & not that I know if it is good or bad that it is there (thinking in the realm of exploits)?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

edwardp
 
Posts: 1
Joined: February 18th, 2018, 10:28 am
Location: Boston

Post Posted February 18th, 2018, 10:32 am

The Manually Sort Folders add-on works for SeaMonkey 2.49.1, once it was run through the converter. Thank you.

Anonymosity
 
Posts: 8523
Joined: May 7th, 2007, 12:07 pm

Post Posted April 3rd, 2018, 9:59 am

edwardp wrote:The Manually Sort Folders add-on works for SeaMonkey 2.49.1, once it was run through the converter. Thank you.

That still does not work. It should move subscriptions or folders as well as accounts, but does not.

risk_reversal
 
Posts: 47
Joined: February 7th, 2005, 8:21 am

Post Posted June 8th, 2018, 1:42 am

Hi Guys,

Wonder if someone can help please and I hope it is ok to ask a question in this thread.

I am trying to install Windscribe VPN extension on SM 2.46.

https://addons.mozilla.org/en-GB/firefo ... src=search

I ran across the SM converter but am not sure which version of Windscribe I should try to convert in order to have the best chance of success.

The older versions are in link below. I am guessing that the v 2.x are for FF Quantum (> v57).

https://addons.mozilla.org/en-GB/firefo ... /versions/

FYG I have tried installing v 0.1.60 and v2.3.7 (without converting) but they both failed

Any help much appreciated.

Many thanks

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 7 guests