MozillaZine

[SOLVED] userContent.css only for email content

User Help for Seamonkey and Mozilla Suite
Diamanti
 
Posts: 700
Joined: June 12th, 2008, 9:02 am

Post Posted May 22nd, 2015, 3:56 am

I read here that "You can fix this by enclosing all the other style rules in"

@-moz-document url-prefix(mailbox:) {
/* all the other rules go here */
}

But when i add it in "userContent.css" nothing happens.
While if you do not use the styles are applied.
How to limit userContent.css rule to email client?
Last edited by Diamanti on May 22nd, 2015, 1:39 pm, edited 1 time in total.

barbaz
 
Posts: 1667
Joined: October 1st, 2014, 3:25 pm

Post Posted May 22nd, 2015, 8:57 am

Use DOM Inspector to determine the URL's of the documents you are trying to style? Most likely what you are trying to style does not have a mailbox:// URL...
*Always* check the changelogs BEFORE updating that important software!

Diamanti
 
Posts: 700
Joined: June 12th, 2008, 9:02 am

Post Posted May 22nd, 2015, 8:59 am

I tried also chrome://messenger/content/messenger.xul but not work

barbaz
 
Posts: 1667
Joined: October 1st, 2014, 3:25 pm

Post Posted May 22nd, 2015, 9:02 am

There's no need to guess somewhat blindly unless you went to Tools > Add-ons and disabled or removed "DOM Inspector". Open the window you want to style, then in that window's menu bar, go to Tools > Web Development > DOM Inspector. From there, File > Inspect (Content|Chrome) Document > Pick the one you want to re-style. You should now be able to see its URL in DOM Inspector's URL bar.

Does that help?
*Always* check the changelogs BEFORE updating that important software!

Diamanti
 
Posts: 700
Joined: June 12th, 2008, 9:02 am

Post Posted May 22nd, 2015, 9:05 am

I'm not going to guess, but I have already done so and I find as I wrote:
chrome://messenger/content/messenger.xul

barbaz
 
Posts: 1667
Joined: October 1st, 2014, 3:25 pm

Post Posted May 22nd, 2015, 9:22 am

Is this an IMAP email account? If so you need to use also url-prefix("imap:/")

Oh.. I see another problem. Try enclosing mailbox: in quotes
Code: Select all
url-prefix("mailbox:")
*Always* check the changelogs BEFORE updating that important software!

Diamanti
 
Posts: 700
Joined: June 12th, 2008, 9:02 am

Post Posted May 22nd, 2015, 10:22 am

OK!
it work :)
Ty.

But it was not with Dom Inspector

I have same problem with compose message windows body.
Do you know also to referer to it?

barbaz
 
Posts: 1667
Joined: October 1st, 2014, 3:25 pm

Post Posted May 22nd, 2015, 10:34 am

You're welcome.

Compose appears to be
Code: Select all
url("chrome://messenger/content/messengercompose/messengercompose.xul")
*Always* check the changelogs BEFORE updating that important software!

Diamanti
 
Posts: 700
Joined: June 12th, 2008, 9:02 am

Post Posted May 22nd, 2015, 10:59 am

This not work for me.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 2 guests