MozillaZine

Seamonkey no longer a valid browser for gmail?

User Help for Seamonkey and Mozilla Suite
cheyennemtnman
 
Posts: 3
Joined: January 21st, 2014, 5:17 pm

Post Posted October 16th, 2016, 1:38 pm

Getting this every time I go to my gmail account...
"This version of Firefox is no longer supported. Please upgrade to asupported browser. Dismiss"

http://hoosierconsole.com/images/Gmail_ ... _Gmail.png
Version 2.40
Build - http://hg.mozilla.org/releases/mozilla- ... 91a9154e93
Last edited by James on October 16th, 2016, 4:02 pm, edited 1 time in total.
Reason: image was too wide for img tags at 1,893px wide.

barbaz
 
Posts: 1650
Joined: October 1st, 2014, 3:25 pm

Post Posted October 16th, 2016, 3:42 pm

It's just browser sniffing not properly taking SeaMonkey into account.

Log out of any sites you're logged in to, then:

about:config
right-click > new > string
name:
Code: Select all
general.useragent.override

value:
Code: Select all
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0


Does that take care of it?

(Remember to remove this hack when upgrading to the next SeaMonkey release, when it comes out. To do that, right-click that preference in about:config and select Reset.)
*Always* check the changelogs BEFORE updating that important software!

rsx11m
Moderator
 
Posts: 14412
Joined: May 3rd, 2007, 7:40 am
Location: US

Post Posted October 17th, 2016, 3:00 pm

That's weird, I'm not seeing this message when logging into http://www.gmail.com
(maybe because I'm not showing the Firefox/43.0 token in my UA string?)

Edit: Heh, this is stupid. So, with Edit > Preferences > Advanced > HTTP Networking, "Advertise Firefox compatibility" unchecked, I'm not getting that notification; if I check it and reload, I get it!

So, easy fix for now, but it may break other websites that rely on the Firefox/43.0 token.

rodndtube
 
Posts: 5
Joined: November 25th, 2009, 6:28 pm

Post Posted November 16th, 2016, 3:36 pm

Both Barbaz and rsx11m solutions worked, however the changing of "HTTP Networking" resulted in something like a low-bandwidth version of gmail. The Barbaz change to "about:config" did the trick with no apparent changes in performance/display.

Thanks to both of you!

barbaz
 
Posts: 1650
Joined: October 1st, 2014, 3:25 pm

Post Posted November 16th, 2016, 7:44 pm

You're welcome, glad to help. :)
*Always* check the changelogs BEFORE updating that important software!

BillT52
 
Posts: 112
Joined: March 30th, 2008, 10:31 am
Location: New York

Post Posted November 17th, 2016, 10:44 am

I've noticed that some sites will pop up a warning when the version of the browser isn't recent enough, probably for security reasons. Since ewong is still working hard to get an updated build process completed and working, the FF version that current Seamonkey is based on may now be too old, but if you drop the FF version from the string entirely, gmail is OK. I guess they only keep track of updates and have minimum version checking for the major browsers.

vladmir
 
Posts: 315
Joined: October 18th, 2004, 9:47 am

Post Posted December 7th, 2016, 1:12 pm

about:config
right-click > new > string
Code: Select all
general.useragent.override.google.com

value:
Code: Select all
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.40

barbaz
 
Posts: 1650
Joined: October 1st, 2014, 3:25 pm

Post Posted December 7th, 2016, 1:41 pm

vladmir wrote:about:config
right-click > new > string
Code: Select all
general.useragent.override.google.com

For those using SeaMonkey 2.46 or later, site-specific UA overrides were broken last I checked - viewtopic.php?f=6&t=3021425

vladmir wrote:value:
Code: Select all
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.40

That UA is very obviously spoofed. Did you mean this?
Code: Select all
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49
*Always* check the changelogs BEFORE updating that important software!

vladmir
 
Posts: 315
Joined: October 18th, 2004, 9:47 am

Post Posted December 7th, 2016, 3:44 pm

barbaz

It works in SM 2.40 as I see.
And this is only for google. If they interested only in Fx - so I've changed only Fx part of ua.)))
... Firefox/100.0 also works.))


In my SM 2.46

With it's own ua
Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 SeaMonkey/2.46
- no yellow "This version of Firefox is no longer supported"

With ua
Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0 SeaMonkey/2.40
- gmail shows yellow "This version of Firefox is no longer supported".

With ua
Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/50.0 SeaMonkey/2.40
- no yellow "This version of Firefox is no longer supported"

It looks like site-specific UA works in:
http://ftp.mozilla.org/pub/seamonkey/candidates/2.46-candidates/build6/unsigned/win32/en-US/
seamonkey-2.46.zip 11-Oct-2016 06:44

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 3 guests