MozillaZine

sent e-mails show wrong sender

User Help for Seamonkey and Mozilla Suite
Assurbanipal
 
Posts: 5
Joined: December 2nd, 2016, 8:31 am

Post Posted December 2nd, 2016, 1:29 pm

I use SeaMonkley Mail with several different e-mail accounts, (a.o.) 3 Gmail accounts and 3 outlook.com accounts.
Outgoing mail servers used are smtp.gmail.com and smtp-mail.outlook.com.
When I compose a new mail from my second or third gmail account, or from my second or third outlook.com account, on my screen, the correct "sending" account is shown, but when the mails arrive, my contacts always get to see the name of my first gmail account or my first outlook.com account.
So my contacts get mail from xxx@gmail.com, when in fact it is sent by yyy@gmail.com or zzz@gmail.com.
Any solutions?

BruceAWittmeier

User avatar
 
Posts: 2567
Joined: June 9th, 2008, 10:53 am
Location: Near 37.501685 -80.147967

Post Posted December 5th, 2016, 8:52 am

~ I'm only here to Pay it Forward. ~

"I often take a very long windy road to my destination. When I arrive I often wonder how I missed the shortcut".

Assurbanipal
 
Posts: 5
Joined: December 2nd, 2016, 8:31 am

Post Posted December 12th, 2016, 9:45 am

This is a useful workaround in some cases, but it is rather "masking" the problem than solving it.
I did sent testmails to two newly created gmail.com and outlook.com identities, so at the addressee's side there is no way that incoming mail could be associated with senders already known in an address book. All mails arrive as being sent by first.added.account@gmail.com or first.added.account@outlook.com or first.added.account@myprovider.eu...

isaacschemm
 
Posts: 181
Joined: January 20th, 2015, 12:29 pm

Post Posted December 13th, 2016, 7:04 am

Do you have an "outgoing server (SMTP)" setting in Mail & Newsgroups Account Settings -> [account name]?
Make sure that it's set to the appropriate SMTP account for each incoming email account.

Assurbanipal
 
Posts: 5
Joined: December 2nd, 2016, 8:31 am

Post Posted December 13th, 2016, 4:50 pm

No doubt about that: the fact that my mails do arrive at destination shows that for each group of accounts (gmail, outlook.com and say xxx@myprovider.eu) the correct outgoing server has been set .

DanRaisch
Moderator

User avatar
 
Posts: 116643
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 14th, 2016, 6:23 am

...the fact that my mails do arrive at destination shows that for each group of accounts (gmail, outlook.com and say xxx@myprovider.eu) the correct outgoing server has been set .


No, it shows that an outgoing server has been set but doesn't say anything about whether that is the correct outgoing server selection.

Assurbanipal
 
Posts: 5
Joined: December 2nd, 2016, 8:31 am

Post Posted December 17th, 2016, 4:48 pm

> DanRaisch:
You're right of course - I should have been more precise there. I rephrase last post:

> Libertyernie:
Yes, I have the appropriate SMTP server set for each incoming email account, i.e.:
for [firstaccountname]@gmail.com = smtp.gmail.com, port 465, authentication: normal password, encryption SSL/TLS, - (tested and found working OK),
for [firstaccountname]@outlook.com = smtp-mail.outlook.com, port 587, authentication:normal password, encryption STARTTLS, - (tested and found working OK),
and for [myName]@myISprovider.eu = relay.[myISprovider].eu, port 587, normal password, STARTTLS,
(tested and found working OK)...
Last edited by Assurbanipal on December 18th, 2016, 5:51 pm, edited 1 time in total.

Assurbanipal
 
Posts: 5
Joined: December 2nd, 2016, 8:31 am

Post Posted December 18th, 2016, 5:49 pm

(continued)
Then, I start adding other gmail-accounts: [secondaccountname]@gmail.com, [thirdaccountname]@gmail.com and [fourthaccountname]@gmail.com, with incoming server pop.gmail.com, port 995, SSL/TLS, normal password, and outgoing server smtp.gmail.com, port 465, normal password, SSL/TLS.
As soon as actived, mails start arriving in the inbox of the different accounts. So far no problem.
But when I compose a new mail, and in the "From" section I select one of the newly added accounts from the drop-down list, Seamonkey (without telling me so) replaces this accountname with the name of the first account I configured. As said, I get no indication of this substitution - while sending, a message "connecting to smtp.gmail.com" appears, then a second message "delivering message(s)", and after sending, I find the mail in the "Sent messages" folder of the correct account - but all the mails arrive with the sender replaced with the [FIRSTaccountname].
So, maybe Seamonkey just is not capable of handling more than 1 accountname for any given smtp-server, or (probably) I am overlooking a setting somewhere - and I hope somebody out there knows which setting that would be.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 1 guest