My SM 2.40 will not update to 2.46. (Linux)

User Help for Seamonkey and Mozilla Suite
Posts: 5
Joined: August 29th, 2013, 10:15 am

Post Posted January 2nd, 2017, 8:02 am

I'm on Mageia 5 Linux with a Lenovo G580 (x86_64) newly installed. My Seamonkey 2.40 works no hitches. Got a note (YouTube?) that my browser is outdated and I did the Check for updates, but got the message that my browser is up to date. Looked at the Seamonkey project site and downloaded the 2.46 version under Contributory Builds and followed the guide as before.

Deleted the /usr/local/seamonkey2/seamonkey directory completely to avoid possible crashes.

Then did # tar jxvf seamonkey-2.46.en-US.linux-x86_64.tar.bz2 (copy, paste from CLI)

Got the normal reaction from the Command line and Seamonkey opens normally. So check the new version in Help > About and find that version 2.40 is still there.

Any ideas much appreciated, thanks.


User avatar
Posts: 11760
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted January 2nd, 2017, 12:26 pm

You might want to check in the repository for Mageia 5 since it's a port of Mandriva.
It may have a Red Hat version update which would install through the recommended channels.
It should show the version as SeaMonkey 2.46 under /help.


User avatar
Posts: 27209
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted January 2nd, 2017, 3:21 pm

The 64-bit SeaMonkey 2.40 for Linux was only in Contrib folder while there is now a 64-bit en-US build in Release folder (linux-x86_64).

Also make sure SeaMonkey 2.40 was not still running when you tried to start SeaMonkey 2.46

Posts: 5
Joined: August 29th, 2013, 10:15 am

Post Posted February 17th, 2017, 12:51 pm

Thank you James,

And apologies, I forgot about this post being busy with other things Linux. I left this and on coming back after about a week, I clicked Help > About as before. There she was! version 2.46! I suspect it to be some system update routine that may have been tardy or something.

Everything is fine, except that when I am in Google Earth and click on Google Maps icon, I get this error;

Failed to execute default Web Browser.
Failed to execute child process
"Seamonkey-2.40" (No such file or directory).

There are another two apps that give me this error,(don't remember them).

At first I installed 2.46 over 2.40 without deleting it, just being difficult and to see what happens. No good, as to be expected, but without really bad effects. Then deleted 2.40 and installed 2.46 with this topic as result.

This current child process error lead me to think it must be and environmental variable that was not set properly on the update. However; I tried everything from the manuals I read so far, but not making any headway.

The nearest I got was several files under cat and vi that warns one away from editing any such file. There are no references to Seamonkey to edit anyway.

On the command printenv or env the nearest remotely connected to browsers or mail is this;

All other commands regarding this in Linux textbooks just give me shell scripts or the like, so I cannot even find the thread to unravel the jersey. I'm still cutting teeth on Linux so am not too clued up on its tricks.

Then again, this could be a Linux question entirely.


User avatar
Posts: 18321
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 19th, 2017, 6:30 am

Maybe something here, Default browser?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to SeaMonkey Support

Who is online

Users browsing this forum: No registered users and 1 guest