Can't upgrade beyond SeaMonkey 2.30 (Windows 8.1)

User Help for Seamonkey and Mozilla Suite
Posts: 39
Joined: October 6th, 2004, 10:24 am

Post Posted February 10th, 2017, 5:59 am

For some reason, when I upgrade SeaMonkey from 2.30 to a later release, it will not start. As soon as I launch SeaMonkey, it crashes, and submits a crash report.
If I opt to restart SeaMonkey, the loop just repeats. The only way I can get it to run again is to downgrade to 2.30.

I've tried 2.31, 2.40 and the latest 2.46, and I get the same problem with all.

If I create a new profile in newer releases, everything works fine, but obviously I then lose all my emails and preferences. There is apparently something in my existing 2.30 profile that newer versions of SeaMonkey don't like.

I use SeaMonkey for Email, newsgroups and web browsing.

I have noticed that, after I upgrade to 2.4x, attempt to run SeaMonkey, then downgrade to 2.30 again, all my bookmarks have been removed and I have to restore them from my backup. Everything else seems intact.

Any ideas what might be causing the problem, or suggestions as to how I can upgrade while retaining my existing profile?

This hasn't really bothered me until recently, because some web sites (notably Facebook) have only recently stopped working properly in 2.30, so I really want to upgrade now.

Any help appreciated.

Posts: 39
Joined: October 6th, 2004, 10:24 am

Post Posted February 10th, 2017, 8:03 am

Apologies for answering my own question, but after some web searching I came upon this bug:

Ploughing though all the comments on that bug got me to the answer - I created an empty file named "xulstore.json" in the Profile directory prior to upgrade, then upgraded straight to 2.46. Everything worked fine, except all of my toolbar customisations were lost and I had to do them again (no big deal).

Strange that such an (on the face of it) easy-to-fix bug never was.

Return to SeaMonkey Support

Who is online

Users browsing this forum: No registered users and 4 guests