date formats?

User Help for Seamonkey and Mozilla Suite
Posts: 95
Joined: June 27th, 2005, 6:17 am

Post Posted September 22nd, 2017, 11:18 pm

Recently date formats in history and the like changed to american MDY. How do I change them back to DMY? I have LC_TIME=en_GB.UTF-8 and country is set to UK in GUI (KDE) settings, but it is not helping. Linux, 2.54
Last edited by lvm on September 23rd, 2017, 1:26 am, edited 1 time in total.


User avatar
Posts: 24
Joined: October 13th, 2015, 5:21 am

Post Posted September 23rd, 2017, 1:06 am

This might be related to an issue that affects Thunderbird (viewtopic.php?f=39&t=3031427) when using the en-US version rather than the en-GB version.

You could try manually downloading the en_GB version of SeaMonkey to see if that makes any difference.

Posts: 805
Joined: December 15th, 2015, 1:20 pm

Post Posted September 24th, 2017, 4:46 am

This would be fixed with but no one found the time yet to do it. You can set the pref manually.
See as a reference.

Posts: 95
Joined: June 27th, 2005, 6:17 am

Post Posted September 26th, 2017, 6:58 am

Thanks, setting intl.regional_prefs.use_os_locales helped. Strange thing though: judging by the bug description it should be OS-independent, but in my case it isn't - windows 2.54 uses OS locale even with intl.regional_prefs.use_os_locales=false but linux version needs it to be true.

Return to SeaMonkey Support

Who is online

Users browsing this forum: No registered users and 5 guests