MozillaZine

Error 403 at Some Sites

User Help for Seamonkey and Mozilla Suite
KentonS
 
Posts: 56
Joined: December 19th, 2008, 8:15 am

Post Posted February 19th, 2018, 3:26 pm

I've been encountering this problem for quite a while - at least since Seamonkey 2.46. It seems unrelated to the other Error 403 thread, as it doesn't seem related to Lightning.

Whenever I go to certain sites (the latest being http://www.MichiganBuddhist.com) I get the dreaded Error 403 - Forbidden. I tried running Seamonkey in Safe Mode, and the site came up OK. I created a new profile, and brought Seamonkey up normally with that profile, and site came up OK.

I'm guessing the problem is caused by some Preference setting. The trouble is, I have no idea which Preference it might be. Does anybody have any idea where I should look? Or whether it's even a Preference setting problem?

Thanks very much for any insights anyone is willing to provide.

Best,
Kenton

ndebord

User avatar
 
Posts: 762
Joined: December 7th, 2002, 9:53 am

Post Posted February 19th, 2018, 6:14 pm

KentonS wrote:
Whenever I go to certain sites (the latest being http://www.MichiganBuddhist.com) I get the dreaded Error 403 - Forbidden. I tried running Seamonkey in Safe Mode, and the site came up OK. I created a new profile, and brought Seamonkey up normally with that profile, and site came up OK.

Kenton


Kenton,

Got the same error. Loads fine in Chrome. the exact error message says:

If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.
Common reasons for this error are: Incorrect file/directory permissions: Below 644.

In order files to be read by the webserver, their permissions have to be equal or above 644. You can update file permissions with a FTP client or through cPanel's File Manager.
Restrictive Apache directives inside .htaccess file.

There are two Apache directives which can cause this error - 'Deny from' and 'Options -Indexes'.

Not a clue here.
-N-
Early Blue Theme, Dell D420, XP PRO SP3, Registry Hack, AvastFree, MalwareBytesPro and Scotty is on Patrol
Dulce bellum inexpertis

lvm
 
Posts: 84
Joined: June 27th, 2005, 6:17 am

Post Posted February 19th, 2018, 10:30 pm

WFM. When I run into 'works with a clean profile and I cannot figure out what option is to blame' situation I usually employ a good old bisection approach: stop seamonkey, back up prefs.js, delete half of the lines in prefs.js, start seamonkey, try to reproduce, repeat.

TPR75
 
Posts: 680
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted February 20th, 2018, 1:18 am

KentonS wrote:I tried running Seamonkey in Safe Mode, and the site came up OK.


Site opens without problems in my old profile. If it works for you in Safe Mode it could mean your ADB filters are blocking something. In my profile it works OK when Google related URL are blocked only.

EDIT: ... and I block all cookies by default. For this site too.

KentonS
 
Posts: 56
Joined: December 19th, 2008, 8:15 am

Post Posted February 20th, 2018, 5:07 am

TPR75 wrote:...If it works for you in Safe Mode it could mean your ADB filters are blocking something...


OK... I'm ignorant. What are ADB filters? (And yes, I tried googling it. ;-) )

TPR75
 
Posts: 680
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted February 20th, 2018, 5:21 am

KentonS wrote:
TPR75 wrote:...If it works for you in Safe Mode it could mean your ADB filters are blocking something...


OK... I'm ignorant. What are ADB filters? (And yes, I tried googling it. ;-) )


AdblockPlus:
https://adblockplus.org/
(you need older 2.9.1 version for SM)

Alternative is uBlock Origin:
https://addons.mozilla.org/en-us/firefo ... ck-origin/

Additional security is noScript:
https://addons.mozilla.org/en-us/firefo ... /noscript/

All above add-ons can block content from websites (e.g. ads). Do you have something like these above?

Did you check cookie permission? Try to block it (for test).

KentonS
 
Posts: 56
Joined: December 19th, 2008, 8:15 am

Post Posted February 20th, 2018, 5:46 am

AdBlock is installed. I've tried disabling it - both generally and for the site - and it has no effect; I still get the 403 error.

Neither uBlock nor noScript is installed.

Anonymosity
 
Posts: 8530
Joined: May 7th, 2007, 12:07 pm

Post Posted February 20th, 2018, 12:46 pm

When I tried that linked page, it loaded with no problem.

therube

User avatar
 
Posts: 19183
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 20th, 2018, 12:58 pm

I haven't looked, but is it a useragent issue?
...SeaMonkey/2.49.1 Lightning/5.4

I believe SeaMonkey has a preference to disable "advertising" of Lightning, or else manually modify your UA to test.

Yes, that looks to be it.

about:config, change the value of calendar.useragent.extra to an empty string.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

KentonS
 
Posts: 56
Joined: December 19th, 2008, 8:15 am

Post Posted February 20th, 2018, 3:52 pm

therube wrote:
I haven't looked, but is it a useragent issue?
...SeaMonkey/2.49.1 Lightning/5.4

I believe SeaMonkey has a preference to disable "advertising" of Lightning, or else manually modify your UA to test.

Yes, that looks to be it.

about:config, change the value of calendar.useragent.extra to an empty string.


Well, amazingly enough that was the problem. calendar.useragent.extra was set to "Lightning/5.4". Once I cleared it, the site came up like a champ.

Thanks very much to everyone who posted. This thing has been bugging me for a really long time!

Best,
Kenton

ndebord

User avatar
 
Posts: 762
Joined: December 7th, 2002, 9:53 am

Post Posted February 20th, 2018, 9:29 pm

therube wrote:


about:config, change the value of calendar.useragent.extra to an empty string.



therube,

That was it. Works just fine on my computer too.

Thanks
-N-
Early Blue Theme, Dell D420, XP PRO SP3, Registry Hack, AvastFree, MalwareBytesPro and Scotty is on Patrol
Dulce bellum inexpertis

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 1 guest