MozillaZine

Google Search SLOW in a Private Window

User Help for Seamonkey and Mozilla Suite
therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 24th, 2018, 4:42 am

(First instance, generally, of a) Google Search is SLOW in a Private Window

Haven't really looked into it, yet, but has anyone else noticed this?

Have google.com as your search engine
Open a new Private Window
Search for something, anything, say, 'basilisk'

SLOW, as in 126793 ms slow.

Code: Select all
Blocked:        0 ms
DNS resolution:   63028 ms
Connecting:       63283 ms
Sending:        0 ms
Waiting:       76 ms
Receiving:     406 ms


I do my searching from the Location (URL) bar.

?

Code: Select all
https://www.google.com/search?q=basilisk&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial

GET /search?q=basilisk&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial HTTP/1.1
Host: www.google.com
User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate, br
DNT: 1
Connection: keep-alive
Upgrade-Insecure-Requests: 1

HTTP/2.0 200 OK
Content-Type: text/html; charset=UTF-8
Date: Sun, 24 Jun 2018 11:32:58 GMT
Expires: -1
Cache-Control: private, max-age=0
p3p: CP="This is not a P3P policy! See g.co/p3phelp for more info."
Content-Encoding: gzip
Server: gws
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Set-Cookie: 1P_JAR=2018-06-24-11; expires=Tue, 24-Jul-2018 11:32:58 GMT; path=/; domain=.google.com
CGIC=Ij90ZXh0L2h0bWwsYXBwbGljYXRpb24veGh0bWwreG1sLGFwcGxpY2F0aW9uL3htbDtxPTAuOSwqLyo7cT0wLjg; expires=Mon, 24-Dec-2018 02:27:34 GMT; path=/complete/search; domain=.google.com; HttpOnly
CGIC=Ij90ZXh0L2h0bWwsYXBwbGljYXRpb24veGh0bWwreG1sLGFwcGxpY2F0aW9uL3htbDtxPTAuOSwqLyo7cT0wLjg; expires=Mon, 24-Dec-2018 02:27:34 GMT; path=/search; domain=.google.com; HttpOnly
NID=133=SpDxtZ6HEB1EyFCIVy9zCzneFeTT_eNGXHAD38OFUgCWRhmcro5YuzoPcQYsBpx1CQiCjmdexzj6xFDn6d5rv49shI9xWY8xwVUlyalpwgEt6l8R225rlSm7MkVrr2lj; expires=Mon, 24-Dec-2018 11:32:58 GMT; path=/; domain=.google.com; HttpOnly
Alt-Svc: quic=":443"; ma=2592000; v="43,42,41,39,35"
X-Firefox-Spdy: h2


This is a fairly new, oh I don't know, say week old, behavior.
No changes on my end, that I am aware of, to account for this.

New Profile does the same.

New Profile
Open SeaMonkey
Open a Private Window
Paste "https://www.google.com/search?q=basilisk&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial" into the Location bar & hit return


Ah, it is not Private Window specific.
It looks to be more, the first google search from opening your browser.


New Profile
Open SeaMonkey
Paste "https://www.google.com/search?q=basilisk&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial" into the Location bar & hit return


It does look to be SeaMonkey specific?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Wish You Were Here
 
Posts: 97
Joined: April 10th, 2010, 1:39 am

Post Posted June 25th, 2018, 1:53 am

Duck the G, use the Duck!

I simply do not trust G anymore.

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 25th, 2018, 8:45 am

Unable to duplicate on a different computer, different location, same ISP (Comcast), different OS (Win7 vs XP).
SeaMonkey 2.49.3 vs 2.49.4, x86 vs x64.
New Profiles in all cases.

Modem, no router.
Wired connection.

Suppose I could change DNS servers.
(Current, XP, 75.75.75.75.)

Image

GRC: Domain Name Speed Benchmark
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 26th, 2018, 3:37 am

Ideas?

Image

Changing DNS server made no difference.

Code: Select all
{
  "log": {
    "version": "1.1",
    "creator": {
      "name": "SeaMonkey",
      "version": "2.49.4"
      {
        "request": {
          "bodySize": 0,
          "method": "GET",
          "url": "https://www.google.com/search?q=ncmain&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial",
          "httpVersion": "HTTP/2.0",
          "headers": [
            {
              "name": "Host",
              "value": "www.google.com"
            },
            {
              "name": "User-Agent",
              "value": "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4"
            },
            {
              "name": "Accept",
              "value": "text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8"
            },
            {
              "name": "Accept-Language",
              "value": "en-US,en;q=0.5"
            },
            {
              "name": "Accept-Encoding",
              "value": "gzip, deflate, br"
            },
            {
          "queryString": [
            {
              "name": "q",
              "value": "ncmain"
          ],
        "response": {
          "status": 200,
          "statusText": "OK",
          "httpVersion": "HTTP/2.0",
        },
        "cache": {},
        "timings": {
          "blocked": 21132,
          "dns": 0,
          "connect": 0,
          "send": 0,
          "wait": 93,
          "receive": 302
        },
        "serverIPAddress": "173.194.68.106",
        "connection": "443"
      },
}
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 26th, 2018, 4:06 am

IPV6 it looks like.
Wonder why? Wonder why all of a sudden? And wonder why it is only (seemingly) SeaMonkey that is affected?

Disable IPV6 &... 550 ms total:

Code: Select all
Blocked:        192 ms
DNS resolution:   0 ms
Connecting:       0 ms
Sending:        0 ms
Waiting:       77 ms
Receiving:     281 ms



(Shush, FF60 ~100 ms total.)
(All the timings are of the initial GET.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Frank Lion

User avatar
 
Posts: 20072
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted June 26th, 2018, 7:37 am

therube wrote:(Shush, FF60 ~100 ms total.)
(All the timings are of the initial GET.)

You need to get out more. ;)
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 26th, 2018, 11:42 am

I would, but just I spent 450 ms more of my life then I could have, so now I'm upset, curled up, contemplating my next action?
(I think I'll go vote :-).)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 26th, 2018, 12:59 pm

It does look to be SeaMonkey specific?

No, actually not.

Current computer, XP, no IPV6.

So I tried a (cough) Win10 computer, on this line - with IPV6.
IPV6 & SeaMonkey (on Win7, akin to FF52) & also FF52 (on Win10, Gecko 52) are both SLOW, as described.

Disable IPV6 (in Control Panel in Win7, in about:config in SeaMonkey in Win10), & both are fast.
Likewise, FF57, Win10, with IPV6 is also fast.

So seems something with earlier Mozilla & IPV6.
I'll have to check other browsers (Pale Moon & Waterfox)...

---

Both work equally well in Win10:

ping -4 ipv4.google.com
ping -6 ipv6.google.com
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 26th, 2018, 5:32 pm

(Quickly....)

Pale Moon 27 & 28 (FF 38 & 52 based-ish) look to be unaffected.

(And that said PM 27 is slower then SeaMonkey - with IPV4, with PM 28 more in line with FF 60.
PM 27 ~1000 ms, PM 28 ~100 ms, give or take.
Last attempt SeaMonkey - with IPV6, 84,663 ms, wow!)

Waterfox 56.2.1 (x64, with e10s enabled, FF 56 based) looks to be unaffected.
Not seeing the same "requests" (the specific GET, maybe it has scrolled off the screen?) but 10 requests, various items loaded during the search is, oh, in the 600 ms range.

FF 38 looks to be unaffected.
~500 ms.

FF 52, getting mixed results.
Most are decent, ~200 - 300 ms, but every 5th or 6th attempt, I'll hit a longer one, ~6000 ms.
But still nowhere near as long as with SeaMonkey.
(And different from what I was seeing earlier on a Win10 system. Currently on Win7.)
(Figures, the attempt after writing the above ws 22000 ms.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

frg
 
Posts: 645
Joined: December 15th, 2015, 1:20 pm

Post Posted June 27th, 2018, 3:00 am

How is 2.53 doing here? Maybe just needs a backport and would be easier to spot if only between 52 and 56

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 27th, 2018, 3:14 am

dslreports thread: Slow IPV6 1st. time connections to google.com

-------

SeaMonkey 2.53

IPV4, rather slow, ~1000 ms.
IPV6, not seeing SLOW (like SeaMonkey 2.49), but still rather slow, ~1000 ms.

But then FF 61 is doing rather poorly at the moment, ~800 ms.
And FF 52 is doing rather well, ~250 ms.
Waterfox is doing 14 requests in ~850 ms.
PM 28, 100 ms, 14 requests in 1.19 s.
PM 28, immediately following... 42000 ms, 15 request in 22.14 s, go figure! (First time I've caught anything like this in PM.)
& then another 42000.
& Waterfox is still fine.
253 still ~1000.
& PM 28 pulls another 42000.

Now how is any of this making any sense?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 19157
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted June 27th, 2018, 11:53 am

On the Win10 units, 1 is on 1803, 1 is older, both exhibiting the same behavior.
Last edited by therube on June 27th, 2018, 12:45 pm, edited 1 time in total.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Frank Lion

User avatar
 
Posts: 20072
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted June 27th, 2018, 12:03 pm

therube wrote:On the Win10 units, 1 is on 1803, 1 is older.

You doing this thread for a bet or something?
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 4 guests