Unwanted    Symbols

User Help for Seamonkey and Mozilla Suite
Posts: 1096
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted October 27th, 2019, 3:19 am

Bluelead wrote:I am using Windows 7 Professional.

It is your Operating System:

Makaiguy was asking about application software:
... you're using to open message saved as a file.

If SeaMonkey is set as default application for e-mail messages and you're saving them as EML file then clicking on such file should open it in Browser (SeaMonkey part to view websites). Files' extension are hidden in Win7 by default so it's possible you can't see EML. Example: full name is "Unwanted    Symbols.eml" but you can see "Unwanted    Symbols" only.

How to show files' extensions:

Bluelead wrote:If I use "Copy" command in SeaMonkey to move an email within SeaMonkey I do not get those symbols. But, the "Save As" I will.
However, I cannot edit the subject line with "Save As." If I move that same email to a folder in Windows, the symbols appear.

Like it was described above:
... "Save As" will cause Windows 7 to create file with OS's default encoding. That's why you must check/change encoding view in Browser every time you'll open file with SeaMonkey.

When you'll save a message as EML file then you shouldn't mess with it's content. If you'll use e.g. Notepad to open such file then you'll see what's inside. Here's example for Draft (received e-mail message will have different/additional lines):
Code: Select all
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
FCC: mailbox://
X-Identity-Key: id1
From: John Smith <>
Subject: =?UTF-8?B?VW53YW50ZWQgw4Igw4Igw4IgU3ltYm9scw==?=
Message-ID: <>
Date: Sun, 27 Oct 2019 09:56:11 +0100
X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=1; DSN=0; uuencode=0;
 attachmentreminder=0; deliveryformat=4
User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101
 Firefox/52.0 SeaMonkey/2.49.5
MIME-Version: 1.0
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 8bit

It's header only:

As you can see "Subject" line is not user friendly. However there are some tools: ... he_message
Download extension (XPI file; save it somewhere and remember where). In SeaMonkey:
Menu -> Tools -> Add-ons Manager -> click on "Gear"/"Cogwheel" icon -> choose "Install Add-on From File..." -> search for downloaded "importexporttools-3.3.2.xpi" and choose it -> restart


To import EML message (if you did above) to your e-mail account:
Open "Mail & Newsgroups" window -> select folder where EML file should be imported (e.g. Inbox) -> Menu -> Tools -> ImportExportTools -> Import messages -> search for and choose EML file
I can not guarantee it will solve problem with strange/additional symbols.

I understand you have your own work method but IMHO you could consider multiple folder's option for e-mail account to arrange/organize received messages.

Return to SeaMonkey Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest