MozillaZine

Some sites failing on Seamonkey. [Linux.]

User Help for Seamonkey and Mozilla Suite
snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 6th, 2019, 4:06 am

I've been using Seamonkey for what seems to be 20 years. Lately I've noticed that more and more sites don't work while using Seamonkey. I have to honestly say that at least 10% of my normal bookmarked sites fail to operate properly. Links aren't able to be clicked, portions of pages don't show up, pages aren't displayed properly, etc.

It's getting frustrated. I'm now using Firefox more and more just to get these sites working again.

Has anyone else noticed this happening?

It looks like I'm finally going to have to stop using Seamonkey because of this. I REALLY hate to say that, but pretty soon, unless something drastic happens, I won't have a choice. More and more sites are saying that they won't support my browser.

Please, please, please get Seamonkey working with all these sites so I don't have to stop using it.
Last edited by LIMPET235 on December 6th, 2019, 4:18 am, edited 1 time in total.
Reason: Added [Linux] to the title.

LIMPET235
Moderator

User avatar
 
Posts: 39183
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted December 6th, 2019, 4:17 am

Ummm,
A "few" of those non-functioning sites may help people sort things out.
Bit hard poking around in the dark. :)

Moving this to SeaMonkey Support...
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

Frank Lion

User avatar
 
Posts: 20740
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted December 6th, 2019, 4:23 am

snorkelface wrote:Please, please, please get Seamonkey working with all these sites so I don't have to stop using it.

The old 'Help me or else' gambit doesn't tend to bring out the best in people around here.

Meantime - viewtopic.php?p=14835497#p14835497 and many other threads here.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 6th, 2019, 4:29 am

I can supply a list, but it's late and I was frustrated. Just before posting, I tried my bank "wheatlandbank.com", "mailchimp.com", and "https://www.chase.com/personal/credit-cards/amazon", to name a few.

Wheatlandbank - account detail pages don't display properly. Text overlapping. Hard to read. works in FF
Mailchimp.com - can't click link to start any campaign - doesn't even show it's a link, but works in FF
Chase.com - can't use Seamonkey at all. Must use FF.

Not sue how much that will help anyone, but thanks for taking the time to read and reply.

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 6th, 2019, 4:32 am

I've played around with user-agent strings over the years, and currently have 7 different strings for 7 specific sites. Other sites still don't work no matter what I try.

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 6th, 2019, 4:35 am

Frank,

"The old 'Help me or else' gambit doesn't tend to bring out the best in people around here."

You make it sound like I was making a threat. If you read it, I was begging for help so I don't have to give up my beloved Seamonkey.

LordOfTheBored
 
Posts: 305
Joined: December 7th, 2005, 8:36 pm

Post Posted December 6th, 2019, 4:38 am

snorkelface wrote:Has anyone else noticed this happening?

Nope.
I do know a lot of sites use improper user-agent sniffing to determine the browser used, then offer some variant of glitchy behavior when they see a browser they don't recognize. Modern web development is deeply flawed, and we are the victims.

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 6th, 2019, 4:50 am

LordOfTheBoard - Yeah, I blame it on the website developers. Too bad they don't know about SM.

frg
 
Posts: 944
Joined: December 15th, 2015, 1:20 pm

Post Posted December 6th, 2019, 3:48 pm

If you have serious problems back up your profile and try Bills 2.53.1 build: http://www.wg9s.com/comm-253/
It is not the eighth wonder of the world but should help. I only have problems with google search which is known to use bad user agent sniffing and some sites either optimized for Chrome or using some experimental features/bad design. For day to day browsing it works great for me.

I did the first official test build for Windows today and it worked out fine so the official is not that far away any longer:
https://imgur.com/a/za1O0hW

The pink border is the attrocious theme in my 8.1 vm. Since then corrected :)

I hope out new gitlab repos for it are ready at the end of next week and we can begin building then. Still needs some fine tuning.

The biggest hurdle is translation. Mozilla and most ofthe translators there no longer care about SeaMonkey so you initially might see some english settings and menu items in it. de and en-gb will be fine :)
If you want to help with translation please contact me. IanN and I will do l10n builds next to see what is missing and if we can fill some gap with strings from Firefox. But that is time consuming.

FRG

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 6th, 2019, 10:47 pm

Thanks, I'll give it a shot shortly.

Wish You Were Here
 
Posts: 118
Joined: April 10th, 2010, 1:39 am

Post Posted December 9th, 2019, 1:33 am

snorkelface wrote: and "https://www.chase.com/personal/credit-cards/amazon",

Chase.com - can't use Seamonkey at all. Must use FF.



They did something strange to their site a while back. Pages appear blank for a few seconds, then fade in gradually almost like some kind of video fade in/fade out effect. The pages all work and I can do everything I need to, but it takes a while for the pages to appear.

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 9th, 2019, 1:57 am

I had been using FF for the past 12 months because SM didn't work on Chase. I just tried it with SM and it looks like they fixed it. Yeah!!!
Thanks for letting me know, Wish you were here.

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 9th, 2019, 3:58 pm

Two more sites SM doesn't work on.

1. Creating a Youtube channel. White screen saying "loading youtube studio"
2. Gofundme.com. Text and videos messed up on page. Can't read page.

Doesn't require a response, just an FYI.

TPR75
 
Posts: 973
Joined: July 25th, 2011, 8:11 am
Location: Poland

Post Posted December 16th, 2019, 1:27 am

snorkelface wrote:Two more sites SM doesn't work on.


Somebody is trying to force people to use Chrome:
https://www.reddit.com/r/kde/comments/e ... _browsers/

:x

snorkelface
 
Posts: 16
Joined: August 16th, 2015, 10:06 pm

Post Posted December 16th, 2019, 2:42 am

So, if Seamonkey and Firefox use the Gecko engiine, and everything else uses Blink, why do so many sites work perfectly on FF and not on SM? Rhetorical Question.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 1 guest