MozillaZine

Page flashes solid grey in Discord in SeaMonkey 2.49.5.

User Help for Seamonkey and Mozilla Suite
TheRealMaestro
 
Posts: 1
Joined: December 22nd, 2019, 9:18 pm

Post Posted December 22nd, 2019, 9:54 pm

If I try to run Discord within SeaMonkey 2.49.5, I am able to log into my account without any complications, but after I have logged in, the Web page behaves strangely. The page renders normally at first, but often its display will be interrupted for a split second, instead showing a solid dark grey page (the same colour as Discord's sidebar in dark mode) before displaying properly again. This kind of flashing can happen many times a minute, and though sending and receiving messages work just fine in Discord, the whole screen flashing so often is rather painful.

I have tried my best to experiment to discern what triggers this, but it happens so often (and the flashing gives me so much of a physical headache) that I cannot discern what: it seems to be triggered by using the mouse or keyboard somehow (it does not blink on its own when no input is given), but I cannot determine what it is that I am doing in the course of using Discord normally that does it. It seems sometimes, but not always, to happen when moving the mouse between sections of the screen. On occasion it happens when trying to type messages into the box. There is nothing that I can do that consistently, every time, causes it to occur, though it happens often enough. One of the more (if not completely) reliable methods is bringing my mouse to the left bar (where servers are displayed) and moving the cursor up and down over the region. At one time, it even happened for every keystroke I made into the input box, though normally keystrokes do not cause the screen to flash; it seems much more often to do somehow with the mouse.

I have tried this in SeaMonkey 2.49.5 for both x64 and x86 versions in Windows 7 x64, and even x86 in Windows XP x86 (in a virtual machine), all in new installations of SeaMonkey without any extensions or settings changes, and the results are the same when trying to use Discord. I remember a similar problem existing in Firefox 52 ESR when I was still using that on this computer (W7 x64), despite the fact that Discord officially maintains support for Firefox 38+. That Discord works without any complications for me in Pale Moon 28.6.1 or its standalone client, and the Task Manager reports no CPU or RAM strain, attests that the problem is not due to hardware limitations with my computer.

I have tried searching and trying a few methods to solve the problem, to no avail. The closest forum thread anywhere that I could find suggested indirectly changing the useragent through about:config, but setting it to Firefox 63 as suggested there did not work. Likewise, disabling hardware acceleration through the preferences had not helped. I am at a loss on how to use Discord within SeaMonkey. How can I cause Discord to work without flashing so often in this Internet suite?

frg
 
Posts: 945
Joined: December 15th, 2015, 1:20 pm

Post Posted December 23rd, 2019, 1:34 am

Is there a public site to test it? Might just be one of the cases where a website no longer works with 2.49.5. 2.53.1 is in the works and a public beta should be out soon.
You can back up your profile and try the unofficial now: http://www.wg9s.com/comm-253/
Btw. Saw your question in the freenode log. At this time of day it is usually very quiet there :)

FRG

Frank Lion

User avatar
 
Posts: 20742
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted December 23rd, 2019, 4:42 am

frg wrote:Btw. Saw your question in the freenode log

This made me laugh -

Could somebody please help? I have been here over 30 minutes and nobody has even responded.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

LordOfTheBored
 
Posts: 305
Joined: December 7th, 2005, 8:36 pm

Post Posted December 27th, 2019, 1:25 am

TheRealMaestro wrote:If I try to run Discord within SeaMonkey 2.49.5, I am able to log into my account without any complications, but after I have logged in, the Web page behaves strangely. The page renders normally at first, but often its display will be interrupted for a split second, instead showing a solid dark grey page (the same colour as Discord's sidebar in dark mode) before displaying properly again. This kind of flashing can happen many times a minute, and though sending and receiving messages work just fine in Discord, the whole screen flashing so often is rather painful.

Having recently(and grudgingly) begun using Discord, I've seen this. It seems to be related to how much backlog is actually loaded. Like when I open it up, everything is fine, but if I scroll back to read all the "missed messages", it starts stuttering.
A quick tap of F5 to refresh seems to fix it(until I scroll through the backlog again, or a wild CONVERSATION appears!).



Frank Lion wrote:
frg wrote:Btw. Saw your question in the freenode log

This made me laugh -

Could somebody please help? I have been here over 30 minutes and nobody has even responded.

They don't call it Idler Relay Chat for nothin'.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 1 guest