MozillaZine

SM 2.53.1 and NPAPI plugins

User Help for Seamonkey and Mozilla Suite
grey_rat
 
Posts: 4
Joined: March 1st, 2020, 3:23 am

Post Posted March 1st, 2020, 3:48 am

In Firefox 60, 68 and SM 2.53.1 you can add VLC plugin if you create plugin.load_flash_only - false.
With this plug-in and ViewTube extension in Firefox 52, Pale Moon and SM 2.49, you could previously watch YouTube videos on very weak computers.

Here successfully tried to return NPAPI support to Firefox 60 https://blog.securityevaluators.com/binary-patching-attempting-to-restore-npapi-support-to-firefox-60-esr-f1b10c804fe7
Is it possible to return NPAPI to SM 2.53?

IMG
https://dl.dropboxusercontent.com/s/lvs ... 1/vlc%20(3).jpg
https://habrastorage.org/webt/wk/mv/xl/ ... nkaqk.jpeg

therube

User avatar
 
Posts: 20356
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 1st, 2020, 7:51 am

With, plugin.load_flash_only;false & npvlc.dll in /plugins/, VLC Web Plugin does show up in SeaMonkey 2.53.1 (x86).
(Now if it, or this ViewTube extension, actually works, I don't know.)


(Does not work in x64 SM as npvlc.dll is x86.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

grey_rat
 
Posts: 4
Joined: March 1st, 2020, 3:23 am

Post Posted March 1st, 2020, 1:34 pm

Win7 32 bit, SM 2.53.1

Vlc plugin does not work in SM
https://dl.dropboxusercontent.com/s/tg3 ... /vlcsm.jpg

grey_rat
 
Posts: 4
Joined: March 1st, 2020, 3:23 am

Post Posted March 3rd, 2020, 1:11 pm


frg
 
Posts: 916
Joined: December 15th, 2015, 1:20 pm

Post Posted March 3rd, 2020, 3:42 pm

The official line is: Support for NPAPI plugins other than Flash has been dropped in 2.53.1 and will not be reinstated.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 2 guests