problems with downloading

User Help for Seamonkey and Mozilla Suite
Posts: 4
Joined: November 17th, 2003, 1:29 am

Post Posted November 17th, 2003, 1:35 am


my mozilla recently freaked out, and is now not responding to any downloadable urls. when i click on a link reffering to ie an exe-file or a zip-file, nothing happens. the result is that i have to copy the link adress and paste it in iexplore to get it downloaded.

it first occured in mozilla 1.4, but didn't change even if i upgraded to mozilla 1.5.

i hafve heard that i'm not alone with this problem, but i haven't heard about a solution. i would like to keep using mozilla, but i want to be able to download files...

plz help?


(and please disregard my recent posting as "guest", i'm new to this forum)


User avatar
Posts: 709
Joined: September 30th, 2003, 1:16 am
Location: Toronto

Post Posted November 17th, 2003, 10:54 pm

Try this:


Post Posted November 19th, 2003, 3:15 pm

I delete the file downloads.rdf and still not responding to any downloadable urls...

┬┐Next try?

PD: Sorry for my english


User avatar
Posts: 709
Joined: September 30th, 2003, 1:16 am
Location: Toronto

Post Posted November 20th, 2003, 12:54 am

Have a look in Edit -> Preferences -> Navigator -> Helper Apps for anything unusual.


Post Posted November 20th, 2003, 1:18 am

Thank you, ChrisI. But i update my mozilla from 1.4 to 1.5, and run fine...

I don't understand the problem, but everything it's ok.

Thank you for your time and help.


Post Posted November 21st, 2003, 8:25 am

I have a problem pretty much exactly as desribed by the originator of this thread. But I haven't fixed it yet.

Using: Gentoo Linux kernel 2.4.20 or so, Mozilla 1.4-r3. Galeon works fine, so does Konquerer. Overall stable system.

After I install it, it works fine for a while (downloads, everything works flawlessly). Then one day I will get a crash while I'm using it, no error message, it just croaks. After that, i can't create a new profile, and I can't download ANYTHING. I mean ANYTHING. No downloadable links work. I can bring up download manager manually, but Save Target As... doesn't bring up a dialog, doesn't download the file, NOTTA, ZIP, ZILCH. And I get no errors, it just silently decides I've downloaded enough files and I can't download any more.

I have like 2 GB disk space free, 300 MB ram free... Not a resource problem. Killing all ps -ef | grep -i moz processes doesn't help, restarting X doesn't help, restarting linux doesn't help. I found last time this happened that reinstalling after deleting ALL mozilla files and directories does help. Deleteing a file under /usr/lib/mozilla/components/ that had something to do with component registrations (don't remember the name) kindof worked, in that it fixed downloads but broke everything else (like Java).

I've tried deleting my entire ~/.Mozilla directory, that downloads.rdf file, my download preferences in Prefereneces are set to use download manager, and there are no strange entries in Help Apps (in fact there are NO entries at all).

Any ideas or suggestions?

I'm getting tired of reinstalling mozilla.


Return to SeaMonkey Support

Who is online

Users browsing this forum: No registered users and 2 guests