MozillaZine

junk mail controls

User Help for Seamonkey and Mozilla Suite
startis
Guest
 

Post Posted November 23rd, 2003, 5:32 pm

For the life of me, I cannot save my Junk Mail Control preferences. I have an OK button but nothing happens when I click on it. I can only click on Cancel.

My Junk Mail Controls were working perfect, but then I had to uninstall and reinstall Mozilla 1.5, since then, I have not been able to click on the OK button to set my Junk Mail settings. I am using Windows XP.

Has anyone else experienced this? Is there a fix?

Thanks!

Tina

Scarrow

User avatar
 
Posts: 1326
Joined: November 5th, 2002, 12:20 am
Location: Japan, East

Post Posted November 23rd, 2003, 8:04 pm

I searched Bugzilla, however all that popped up relating to broken junk mail controls was Thunderbird specific and relatively new.

Try adjusting your settings under a new profile.

- Scarrow

Guest
Guest
 

Post Posted July 13th, 2004, 6:15 am

I have the same problem using mozilla 1.7 with XP. I want to disable junk mail controls, but it won't let me click OK in the junk mail control window, only cancel. Major frustration!!!!

Guest
Guest
 

Post Posted July 13th, 2004, 6:21 am

Sorry, forgot to mention that I tried to create a new profile, but that profile has the same problem! I'm using IMAP mail...
I moved from Netscape 4.8 (yes I know I was in the dark ages, but Netscapes 6 and 7 were too slow and not updated often enough, and bloated, and ...) to Mozilla and I love it; except for this annoying bug! Could it be another configuration that I messed up that wont let me modify the junk mail controls? The junk mail log is diabled, and I have no filters defined...

Any help would be greatly appreciated!

Mike Novack
Guest
 

Post Posted July 13th, 2004, 9:44 am

IMAP, eh?

Failure of OK (in almost any context) is because you have asked the system to do the impossible -- or a corrupted profile with no palce to store the "save" (but you eliminated THAT possibility with a new, presumably clean profile).

OK --- WHAT were you telling the junk mail controls to do? For example, if you were telling it to move messages identified as junk to folder X, does folder X exist? It cna frustrating trying to debug a problem when you don't get a meanigful error message. Here Mozilla (by refusing the OK) is just telling you that SOMETHING is wrong with what you just told it to do and you'll need to hunt and peck till you figure out what. Suggestion --- in this trial and error, take your time! Change only one thing at a time! I suggest you try by specifying a very minimalist specifcation for the Junk Filter, a specifcation for whihc you CAN get an OK to work -- even if sop minimalist a one wouldn't be useful to you. Then modify it addig one omre thing you need specificed each time unitl you hit on excatly what is being rejected.

Then you need to figure out WHY --- and friend, decades of experience have taught me one thing. No matter how impossible that might seem at first, the computer is always right (you, not it, have specified somethign illogical)

Guest
Guest
 

Post Posted July 13th, 2004, 10:47 am

Ahhhh!!!! Thanks Mike! I got it on the first try!

I still think this is a Mozilla bug, you decide:

I am trying to DISABLE the junk mail controls, so I unchecked the "enable junk mail control", but it won't let me click OK whether it's checked or not (even if I change nothing on the screen I can't click OK). Now, here was the problem: just below the "enable junk mail control" option there is an option for not marking the mail as junk if they are in a selected address book. Well, there was no address book selected when the screen first popped up (text box was empty) - since I wasn't going to turn on the junk mail controls anyway, I didn't care what address book is selected (that selection shouldn't matter especially since those options get turned off when I uncheck "enable junk mail controls" anyway) so I didn't select an address book since I wasn't using that option. Well, once I selected an address book, the OK button works, so I turned off the junk mail control.

Thanks again!

Mike Novack
Guest
 

Post Posted July 13th, 2004, 2:39 pm

Explanation

Not a bug in SEQUENTIAL logic. What you are saying is that "taken in entirety" there was no apparent logic problem because since the Junk controls were to be set "disabled" why should it matter than some component rule was impossible?

Two problems with that. First of all, the process of checking "is this OK to save?" (is it possible) is going to be done SEQUENTIALLY anad so even thinking the way you are, the order of the checking makes a difference. To work the way you think it should -- enabled/disabled would have to be checked FIRST (and if disabled, ignore any other inconsistencies). Nor would most programmers bother with the checking routine to proceed farther once the first inconsistency is found (you imagine that it sets "the can't save" flag at every inconsistency, keeps checking even if one has been found, but clears the flag if "disabled" is found later?)

But second, more important, you are misunderstanding "disabled". That does NOT mean "junk rules don't exist" but that "the process isn't enabled run". Presumably you could change your mind and switch to "enabled" at any time. So the rest of the rules are checked for consistency in either case.

The options you select are NOT "turned off" every time you "disable". Who would want to re-enter every time the junk filter was turned back on? Try it.

Guest
Guest
 

Post Posted July 14th, 2004, 6:10 am

Mike,

Fair enough, I see your point. Perhaps a future release would add a pop up window to alert the user as to what the checking routine didn't like so the mysterious "ok button didn't work problem" would be easier to solve.

Funny thing, I installed mozilla on another machine and I didn't have this problem (personal address book was selected by default); but on that machine I was going from netscape 7.1 to mozilla. So maybe it's only an issue for migrations from really old netscape products (4.x series).

Oh well. I'm just glad it's solved! Thanks for the help.

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 1 guest