Problems with gkplugin.dll

User Help for Seamonkey and Mozilla Suite
Posts: 226
Joined: August 30th, 2003, 1:28 am
Location: West Sussex, UK

Post Posted May 6th, 2006, 3:38 pm

Hi folks,

My Moz 1.7.12, and now 1.7.13 keeps crashing, and the following error appears:-


Can anyone shed any light on this, as it's becoming annoying. I have tonight created a new profile, and reinstalled Java, as I thought this might be the problem, but the crashes still occur.

Thanks for any help.
SeaMonkey 2.38, Windows 7 Home (Desktop), Windows 10 (Laptop)


User avatar
Posts: 14481
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 9th, 2006, 1:24 pm

gkplugin.dll would be found in the /GRE/ directory.
(Usually, C:\Program Files\Common Files\\GRE\{gre version}\components\, in Windows).

So I would not expect a new Profile to have any affect on the problem.

I would expect a new install, like from 1.7.12 to 1.7.13 to recreate the /GRE/ directories.

Only think I can suggest, is to ...

Uninstall Mozilla.
Verify that the /GRE/ directories are gone.
(Your Profile should remain, but thats why you made the backup).

See if that helps.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Posts: 226
Joined: August 30th, 2003, 1:28 am
Location: West Sussex, UK

Post Posted May 9th, 2006, 3:40 pm

Thanks for your reply.

I did uninstall 1.7.12 before installing 1.7.13, but didn't check the GRE directory. I have just done so, and there are folders in C:/Program Files/Common Files/ for each installation from 1.4, so it would seem that each new update creates a new GRE directory folder, and therefore, logically, the gkplugin.dll in use, should be the latest one installed, yes? I wonder if something else is causing the gkplugin.dll to freak out?

I did a Google search for 'gkplugin.dll', and found lots I could download freely. Would it be any use simply replacing the current gkplugin.dll with a new downloaded one, or could this mess things up completely, especially if it's not quite the same version number? The problem hasn't actually arisen again for the last couple of days, but I would still like to get to the bottom of it, if possible.
SeaMonkey 2.38, Windows 7 Home (Desktop), Windows 10 (Laptop)


Post Posted May 30th, 2006, 10:45 pm

I am having the exact same problem. I am using Mozilla 1.7.12 with XP also.
the error message also indicated that ' d8bd_appcompat.txt ' in my TEMP folder was an issue. I googled it but got nothing.

Posts: 1
Joined: October 13th, 2006, 7:15 am

Post Posted October 13th, 2006, 7:22 am

I have also recently started getting these errors after upgrading from 1.7.12 to 1.7.13. Platform is WinXP Pro. Has anyone found a possible cause/solution yet?

Thanks for any info!

Return to SeaMonkey Support

Who is online

Users browsing this forum: No registered users and 2 guests