MozillaZine

Enabled Java and cookies- but websites say I haven't

User Help for Seamonkey and Mozilla Suite
hudor
 
Posts: 34
Joined: August 20th, 2003, 6:29 am

Post Posted July 20th, 2006, 3:17 am

Well, I have "Enable Java" checked under "Preferences- Advanced" and "Allow all cookies" and "Accept cookies normally" checked under "Privacy and Security." However, I keep being told by websites that I need to enable javascript and cookies. I think I've done that. Any ideas about what might be going on?

Guest
Guest
 

Post Posted July 20th, 2006, 7:10 pm

(I'm not shouting at you, simply copying another post)

JAVA IS NOT JAVASCRIPT

"Java is Not JavaScript
JavaScript is Not Java"
http://www.dannyg.com/ref/javavsjavascript.html

"JavaScript is Not Java"
http://www.ericgiguere.com/articles/jav ... -java.html


You want to enable JavaScript (& probably more so then Java).
Edit | Preferences | Advanced | -> Scripts & Plug-ins --> Enable JavaScript for

Guest
Guest
 

Post Posted July 20th, 2006, 7:12 pm

(Oops, that was me, therube, who was not, & is not logged in)

hudor
 
Posts: 34
Joined: August 20th, 2003, 6:29 am

Post Posted July 23rd, 2006, 3:08 am

Thanks!

hudor
 
Posts: 34
Joined: August 20th, 2003, 6:29 am

Post Posted July 23rd, 2006, 3:13 am

Double checked. Javascript is already enabled. Sorry I wasn't clear about that. Javascript and cookies are both enabled, but the websites keep telling me otherwise.

Guest
Guest
 

Post Posted July 23rd, 2006, 11:18 am

(therube)

Then how about posting the sites where this occurs for you?
Are you using the NoScript extension?

hudor
 
Posts: 34
Joined: August 20th, 2003, 6:29 am

Post Posted July 23rd, 2006, 7:39 pm

No extensions. I made this discovery while trying to transfer bookmarks to a new profile.

Two such sites are http://my.netscape.com and http://my.myway.com

Guest
Guest
 

Post Posted July 24th, 2006, 7:46 pm

(therube)

I do use NoScript (which is a JavaScript blocker, in general terms).
On my intial attempts to load each site, I received the "you need JavaScript" message.

Enabling each site, through NoScript, to allow JavaScript, caused subsequent loads of the pages to load correctly.

So it would appear, that even though you have JavaScript enabled, something is still blocking it?

Code: Select all
The browser you're using is not allowing you to sign in to My Way.

Right now, your browser's settings are configured to disable cookies and/or javascript. In order to access your account, you must change your browser's settings to accept both cookies AND javascript.

Code: Select all
(netscape)
Invalid Browser Configuration

You have tried to access a feature which is not available for your current browser configuration. To use this feature, you must have:

* JavaScript enabled in your Preferences

How about creating a new, clean Profile, as a test, & see if that works correctly.

hudor
 
Posts: 34
Joined: August 20th, 2003, 6:29 am

Post Posted July 24th, 2006, 9:55 pm

Anonymous wrote:(therube)

I do use NoScript (which is a JavaScript blocker, in general terms).
On my intial attempts to load each site, I received the "you need JavaScript" message.

Enabling each site, through NoScript, to allow JavaScript, caused subsequent loads of the pages to load correctly.

So it would appear, that even though you have JavaScript enabled, something is still blocking it?

Code: Select all
The browser you're using is not allowing you to sign in to My Way.

Right now, your browser's settings are configured to disable cookies and/or javascript. In order to access your account, you must change your browser's settings to accept both cookies AND javascript.

Code: Select all
(netscape)
Invalid Browser Configuration

You have tried to access a feature which is not available for your current browser configuration. To use this feature, you must have:

* JavaScript enabled in your Preferences

How about creating a new, clean Profile, as a test, & see if that works correctly.
This *was* a new, clean profile!

Yep. Those are the very messages I got.

I'll try again! Thanks!

hudor
 
Posts: 34
Joined: August 20th, 2003, 6:29 am

Post Posted July 24th, 2006, 10:14 pm

Tried another new profile... with exactly the same result.

The only thing I can figure is that at some point- maybe back in the Mozilla days- I'd downloaded No Script globally. Where would I check to see what extensions I have? I've been using Firefox so long I've forgotten.

therube

User avatar
 
Posts: 12890
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted July 25th, 2006, 6:25 pm

In your %Profile%/chrome directory, you would find noscript.jar.
In your Mozilla/SeaMonkey installation directory, you would find components\noscriptService.js & defaults\pref\noscript.js.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to SeaMonkey Support


Who is online

Users browsing this forum: No registered users and 1 guest