MozillaZine

[FX] PowerBook: 2005-07-16 [Trunk/OS X] (G4, O3, Altivec)

Discussion of third-party/unofficial Firefox/Thunderbird/SeaMonkey builds.
krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 8th, 2005, 3:48 am

07/08 out.

Now compiled with autovectorization, as suggested by artooro.
I have not had the time to test how it performs. So please post feedback! :D


By the way, this bug is partially fixed:
298677 - Vertical scrollbar draws over toolbar and tabs when location or search bar has focus during scrolling

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted July 8th, 2005, 4:59 am

DeerPark alpha 2, Gecko 1.8a3...

Ok, now testing your new build config...

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 8th, 2005, 5:36 am

phiw13 wrote:DeerPark alpha 2, Gecko 1.8a3...
I totally missed that part! :oops:

weerez
 
Posts: 118
Joined: June 15th, 2004, 11:11 pm

Post Posted July 8th, 2005, 12:31 pm

powerbook, i have been sticking with this release because of all the copy+paste problems and scrollbar painting issues with the latest releases. im following your bug tracking, so just let me know if any of these have been fixed and ill download the latest nightlies again!

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 8th, 2005, 2:25 pm

weerez. No changes to the unresponsive keyboard shortcuts problem yet.
Neither have I found a pattern to reproduce it. It strikes just random...
The bug (299514) is yet to be confirmed or assigned to a developer. I'm really not sure what else I can do.

The scrollbar painting issue is partly fixed. Meaning the extra scrollbar on the left side dont show up anymore, but the page still jump uncontrolled in certain situations. The bug (298677) is still open to track that.

dschneiderch
 
Posts: 36
Joined: October 27th, 2003, 10:46 am

Post Posted July 8th, 2005, 8:22 pm

the address bar not updating itself when a new page loads seems to be back again... anyone else have this problem?

and dragging of webpages into bookmarks doesn't work again.

after 20 minutes of use, it definitely seems faster though
15" TiBook 1 Ghz, 512MB, DVD/CDRW OS X.4.1

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted July 8th, 2005, 9:09 pm

dschneiderch wrote:the address bar not updating itself when a new page loads seems to be back again... anyone else have this problem?

and dragging of webpages into bookmarks doesn't work again.

after 20 minutes of use, it definitely seems faster though


Both WorkForMe. Have you tried with a fresh, new profile?

======================
I'm not sure about this one, and it happens a bit randomly.
Open the DomInspector [**], and drill down a few nodes in the left pane. Move the DomI window. A number of times the movement was very jerky, with sudden jumps.

[**] the DomInspector window is the only window that I ever move around in Firefox, possibly the problem could happen with other windows as well.

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 9th, 2005, 4:59 am

07/09

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted July 9th, 2005, 6:31 am

argh, hitting the enter key doesn't do anything when used on the location bar. bug 300170

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 9th, 2005, 6:50 am

phiw13 wrote:argh, hitting the enter key doesn't do anything when used on the location bar. bug 300170

Annoying bug. Vote placed!

PaintedWolf
 
Posts: 2
Joined: July 9th, 2005, 7:35 am

Post Posted July 9th, 2005, 7:37 am

powerbook wrote:
phiw13 wrote:argh, hitting the enter key doesn't do anything when used on the location bar. bug 300170

Annoying bug. Vote placed!


Annoying bug? I would say it's rather indespensible to be able to use the browser.

phiw13
 
Posts: 2777
Joined: November 7th, 2002, 1:00 am
Location: Japan

Post Posted July 9th, 2005, 8:12 am

phiw13 wrote:argh, hitting the enter key doesn't do anything when used on the location bar. bug 300170


Bug has been marked as fixed. That was fast.

(by removing a patch for an other bug).

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 9th, 2005, 8:16 am

PaintedWolf wrote:Annoying bug? I would say it's rather indespensible to be able to use the browser.

Nitpicker! ;)
I agree that its an indispensable feature in a web browser, but I also say its annoying when it dont work.

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 9th, 2005, 8:21 am

phiw13 wrote:Bug has been marked as fixed. That was fast.
(by removing a patch for an other bug).
I spin a new build now!
Hold on...

It was a regression from the patch for this bug, which have been backed out now:
https://bugzilla.mozilla.org/show_bug.cgi?id=298807

krmathis

User avatar
 
Posts: 4699
Joined: May 24th, 2004, 9:40 pm
Location: Oslo, Norway

Post Posted July 9th, 2005, 8:42 am

The new fixed 2005.07.09 build ready for download.

Return to Third Party/Unofficial Builds


Who is online

Users browsing this forum: No registered users and 2 guests